Jump to content
×
×
  • Create New...
  • 0

armure invisible


skulldeath
 Share

Question

bonjour

alors voila j'ai implanter une armure néanmoins elle reste invisible ig j'ai déjà parcouru l'aide et question j'ai bien trouver mon problème j'ai donc appliquer se qui avait permis de résoudre le problème mais le mien demeure

j'ai bien rajouter le +1 au shapedata j'ai mis 100 au shapadatacount pour être tranquille j'ai bien ajouter mes fichier gr2 et texture j'ai bien repacker en respectant la procédure le shape index est bien égal a ma value 3 de mon item_proto les fichier pc et pc2 repack on bien mis le nom de l'armure en .gr2 l'item _list a été fait sans le gr2 juste avec le tga voila je pense que j'ai du faire a peu prés le tour de toute les solution que j'ai vu mais sa ne corrige pas mon problème.

donc je vois pas trop se qui bloque.

merci.

Link to comment
Share on other sites

  • Answers 57
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

Posted Images

Recommended Posts

  • 0
  • Developer

Il y a encore un problème avec tes fichiers msm. Tu devrais vérifier si le ShapeDataCount est bien égal au nombre de Group ShapeData qu'il y a dans ton fichier .msm, jusque là si tout est bon, il doit y avoir un problème avec le modèle de l'armure.

 

Vérifie aussi si les bonnes textures sont désignées dans le "Model" "SourceSkin" et "TargetSkin".

Link to comment
Share on other sites

  • 0

voila le srceen de l’armure et du msm et de 2 destination texture j'ai essaye de mettre gr2 a la place de GR2 aucun changement j'ai essaye de mettre le gr2 sans les sourceskin ni les targetskin aucun changement.

59fb3358d7634_Sanstitre4.png.e62eb4536590cf752abf24378c2abd52.png

59fb33590b891_Sanstitre5.png.875f21b012cf97f8267db3e080ff1a33.png

Link to comment
Share on other sites

  • 0
  • Developer

le shape index est bien égal a ma value 3 de mon item_proto les fichier pc et pc2 repack on bien mis le nom de l'armure en .gr2 l'item _list a été fait sans le gr2 juste avec le tga

 

Tu as ta réponse.

 

Étant donné que je ne m'y connais pas vraiment en 3D, je laisserai BoolyBoys57 te répondre, mais je pense que sa réponse est correcte et te permettra de résoudre le problème, car moi-même implantant des armures sur mon serveur de test, je n'ai jamais mis autant de .dds

 

Bonne journée.

Link to comment
Share on other sites

  • 0

voici la marti du msm qui nous interesse le shapedatacount n'est pas répéter 2 fois chaque shapeindex est unique je n'ai que un 28

Group ShapeData
{
PathName	"d:/ymir Work/pc2/sura/"

ShapeDataCount				100	

Group ShapeData00
{
	ShapeIndex			0

	Model				"sura_novice.GR2"
	SourceSkin			"sura_novice_red.dds"
	TargetSkin			"sura_novice_black.dds"
}
Group ShapeData01
{
	ShapeIndex			1

	Model				"sura_novice.GR2"
	SourceSkin			"sura_novice_red.dds"
	TargetSkin			"sura_novice_red.dds"
}
Group ShapeData02
{
	ShapeIndex			3
	Model				"sura_jinhon.GR2"
	SourceSkin			"sura_jinhon.dds"
	TargetSkin			"sura_jinhon.dds"
}
Group ShapeData03
{
	ShapeIndex			4
	Model				"sura_jinhon.GR2"
	SourceSkin			"sura_jinhon.dds"
	TargetSkin			"sura_mageuk.dds"
}
Group ShapeData04
{
	ShapeIndex			5
	Model				"sura_jinhon.GR2"
	SourceSkin			"sura_jinhon.dds"
	TargetSkin			"sura_biun.dds"
}	
Group ShapeData05
{
	ShapeIndex			6
	Model				"sura_saryeong.GR2"
	SourceSkin			"sura_saryeong.dds"
	TargetSkin			"sura_saryeong.dds"

	SourceSkin2			"sura_saryeong_cloak.dds"
	TargetSkin2			"sura_saryeong_cloak.dds"
}
Group ShapeData06
{
	ShapeIndex			7
	Model				"sura_saryeong.GR2"
	SourceSkin			"sura_saryeong.dds"
	TargetSkin			"sura_eumyang.dds"

	SourceSkin2			"sura_saryeong_cloak.dds"
	TargetSkin2			"sura_saryeong_cloak.dds"
}
Group ShapeData07
{
	ShapeIndex			8
	Model				"sura_saryeong.GR2"
	SourceSkin			"sura_saryeong.dds"
	TargetSkin			"sura_heukbi.dds"

	SourceSkin2			"sura_saryeong_cloak.dds"
	TargetSkin2			"sura_saryeong_cloak.dds"
}
Group ShapeData08
{
	ShapeIndex			9
	Model				"sura_unra.GR2"
	SourceSkin			"sura_unra.dds"
	TargetSkin			"sura_unra.dds"

	SourceSkin2			"sura_unra_cloak.dds"
	TargetSkin2			"sura_unra_cloak.dds"
}
Group ShapeData09
{
	ShapeIndex			10
	Model				"sura_unra.GR2"
	SourceSkin			"sura_unra.dds"
	TargetSkin			"sura_gwimyeon.dds"

	SourceSkin2			"sura_unra_cloak.dds"
	TargetSkin2			"sura_unra_cloak.dds"

}
Group ShapeData10
{
	ShapeIndex			11
	Model				"sura_unra.GR2"
	SourceSkin			"sura_unra.dds"
	TargetSkin			"sura_maryeong.dds"

	SourceSkin2			"sura_unra_cloak.dds"
	TargetSkin2			"sura_unra_cloak.dds"

}
Group ShapeData11
{
	SpecialPath			"d:/ymir work/monster/wolf/"

	ShapeIndex			100
	Model				"wolf.gr2"
	SourceSkin			"wolf.dds"
}
Group ShapeData12
{
	SpecialPath			"d:/ymir work/monster/wild_boar/"

	ShapeIndex			101
	Model				"wild_boar.gr2"
	SourceSkin			"wild_boar.dds"
}
Group ShapeData13
{
	SpecialPath			"d:/ymir work/monster/bear/"

	ShapeIndex			102
	Model				"bear.gr2"
	SourceSkin			"bear.dds"
}
Group ShapeData14
{
	SpecialPath			"d:/ymir work/monster/tiger/"

	ShapeIndex			103
	Model				"tiger.gr2"
	SourceSkin			"tiger.dds"
}
Group ShapeData15
{
	SpecialPath			"d:/ymir work/pc2/sura/"

	ShapeIndex			201
	Model				"sura_marry_01.gr2"
	SourceSkin			"sura_marry_01.dds"
	TargetSkin			"sura_marry_01.dds"
}
Group ShapeData16
{
	ShapeIndex			12
	Model				"sura_4-1.GR2"
	SourceSkin			"sura_4-1.dds"
	TargetSkin			"sura_4-1.dds"
}


Group ShapeData17
{
	ShapeIndex			14
	Model				"sura_jinhon.GR2"	
	SourceSkin			"sura_jinhon.dds"
	TargetSkin			"sura_1-1_jinhon copy_a.DDS"
}
Group ShapeData18
{
	ShapeIndex			15
	Model				"sura_jinhon.GR2"	
	SourceSkin			"sura_jinhon.dds"
	TargetSkin			"sura_1-2_mageuk_a.DDS"
}
Group ShapeData19
{
	ShapeIndex			16
	Model				"sura_jinhon.GR2"	
	SourceSkin			"sura_jinhon.dds"
	TargetSkin			"sura_1-3_biun_a.DDS"
}

Group ShapeData20
{
	ShapeIndex			17
	Model				"sura_saryeong.GR2"	
	SourceSkin			"sura_saryeong.dds"
	TargetSkin			"sura_2-1_saryeong_a.DDS"
}
Group ShapeData21
{
	ShapeIndex			18
	Model				"sura_saryeong.GR2"	
	SourceSkin			"sura_saryeong.dds"
	TargetSkin			"sura_2-2_eumyang_a.DDS"
}
Group ShapeData22
{
	ShapeIndex			19
	Model				"sura_saryeong.GR2"	
	SourceSkin			"sura_saryeong.dds"
	TargetSkin			"sura_2-3_heukbi_a.DDS"
}
Group ShapeData23
{
	ShapeIndex			20
	Model				"sura_unra.GR2"		
	SourceSkin			"sura_unra.dds"
	TargetSkin			"sura_3-1_unra_a.DDS"

	SourceSkin2			"sura_unra_cloak.dds"
	TargetSkin2			"sura_unra_cloak.dds"
}
Group ShapeData24
{
	ShapeIndex			22
	Model				"sura_maryeong.GR2"	
	SourceSkin			"sura_maryeong.dds"
	TargetSkin			"sura_maryung_a.DDS"
}
Group ShapeData25
{
	ShapeIndex			24	
	Model				"sura_lord.GR2"	
	SourceSkin			"sura_king01.dds"
	TargetSkin			"sura_king01.dds"
	SourceSkin2			"sura_king01_cloak.dds"
	TargetSkin2			"sura_king01_cloak.dds"


}
Group ShapeData26
{
	ShapeIndex			25	
	Model				"sura_lord.GR2"	
	SourceSkin			"sura_king01.dds"
	TargetSkin			"sura_king02.dds"
	SourceSkin2			"sura_king02_cloak.dds"
	TargetSkin2			"sura_king02_cloak.dds"


}
Group ShapeData27
{
	ShapeIndex			40
	Model				"sura_4-1.GR2"
	SourceSkin			"sura_4-1.DDS"
	TargetSkin			"sura_80_w.dds"
}
Group ShapeData28
{
	SpecialPath			"d:/ymir work/pc2/sura/"
	ShapeIndex			46
	Model				"sura_uni_1.GR2"
	SourceSkin			"surademone.dds"
	TargetSkin			"surademone.dds"
}
Group ShapeData29
{
	ShapeIndex			41
	Model				"sura_female.GR2"
}


}

Link to comment
Share on other sites

  • 0

j'ai bien ajouter mes fichier gr2 et texture j'ai bien repacker en respectant la procédure le shape index est bien égal a ma value 3 de mon item_proto les fichier pc et pc2 repack on bien mis le nom de l'armure en .gr2 et non GR2 l'item _list a été fait sans le gr2 juste avec le tga voila je pense que j'ai du faire a peu prés le tour de toute les solution que j'ai vu mais sa ne corrige pas mon problème.

donc je vois pas trop se qui bloque.

merci.

 

oui gagil j'ai bien tout respecter y compris les textures

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.