Jump to content
×
×
  • Create New...
  • 0

Soucis mob proto au démarrage du serveur


Alan
 Share

Go to solution Solved by Alan,

Question

Bonjour à tous, 

Sources : FE 2016  by @ Saw

J'ai un soucis lorsque j'essaye d'implanter un boss sur mon serveur (Connected refused).

Syserr :

Citation

SYSERR: Jul 25 16:19:57 :: pid_init: 
Start of pid: 1236

SYSERR: Jul 25 16:19:57 :: socket_connect: HOST 127.0.0.1:15000, could not connect.

Après plusieurs manip' je ne parviens pas à trouver le problème... Je vous partage le mob_ proto.txt. VNUM 2598 : Azrael déjà implanté / VNUM 2599 : le mob que j'essaye d'implanter (j'ai simplement recopié la ligne d'Azra en modifiant le VNUM, le level et le folder pour l'instant. Je précise que lorsque je remets le mob_proto d'origine, le serveur démarre, le problème vient donc bien de ma modification. Je vous remercie d'avance pour votre aide !


Hidden Content

    Give reaction to this post to see the hidden content.

 

Edited by Alan
Link to comment
Share on other sites

  • Answers 4
  • Created
  • Last Reply

Top Posters For This Question

4 answers to this question

Recommended Posts

  • 0
  • Solution
Posted (edited)

Solution trouvée vous pouvez fermer le sujet. Le problème venait de l'importation excel, je vous mets les screens de ce qui fonctionnent.

tape1.png

Etape2.png

Etape3.png

Edited by Funky Emulation
Core X - External 2 Internal
Link to comment
Share on other sites

  • 0
Il y a 20 heures, Alan a dit :

Bonjour à tous, 

Sources : FE 2016  by @ Saw

J'ai un soucis lorsque j'essaye d'implanter un boss sur mon serveur (Connected refused).

Syserr :

Après plusieurs manip' je ne parviens pas à trouver le problème... Je vous partage le mob_ proto.txt. VNUM 2598 : Azrael déjà implanté / VNUM 2599 : le mob que j'essaye d'implanter (j'ai simplement recopié la ligne d'Azra en modifiant le VNUM, le level et le folder pour l'instant. Je précise que lorsque je remets le mob_proto d'origine, le serveur démarre, le problème vient donc bien de ma modification. Je vous remercie d'avance pour votre aide !


Hidden Content

    Give reaction to this post to see the hidden content.

 

Tu as modifié le mob_proto c’est bien, mais est ce que tu as fais le reste ? 

Link to comment
Share on other sites

  • 0
Posted (edited)

Yalabi

J'ai suivi le tuto dont tu trouveras le lien ci-dessous. Je trouve que les modifications du côté serveur sont assez flou (même lorsque je me dirige vers le tuto d'édition des rates. J'ai simplement modifié l'item_proto.txt et l'item_name.txt. En fouillant un peu j'ai trouvé dans usr/metin2/share/data le dossier "monster", j'ai pris exemple sur le contenu des fichiers afin d'y mettre celui de mon mob avec les fichiers d'animations (.msa), le motlist.txt et le fichier .msm. 

 

Je me doute qu'il y a surement d'autres choses à faire mais je ne parviens pas à trouver d'infos à ce sujet. 

PS : Ce qui m'interroge aussi c'est que lorsque je delete la ligne ajouté dans le mob_proto et le mob_names l'erreur est toujours là, je suis donc obligé de remettre le fichier d'origine pourtant identique lorsque je les compares. 

 

Edit : Lorsque je réalise l'ouverture du fichier d'origine via excel (texte séparateur tabulation) et que j'enregistre le fichier sans le modifier, celui-ci n'est plus fonctionnel. Je précise que j'ai réalisé exactement les mêmes manipulations avec l'item_proto.txt et je n'ai pas ce soucis. Lorsque je modifie le fichier avec sublimetext cela fonctionne mais impossible de travailler comme ça...

 

Edited by Alan
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.