Jump to content
×
×
  • Create New...
  • 0

mysql_secure_installation: Command not found.


CpasToiCmoi
 Share

Question

Serveur dédié OVH

Freebsd 13

Mysql server client 8

Bonjour,

comme le mentionne mon titre d'aide , j’obtiens le message : mysql_secure_installation: Command not found.

savez pourquoi ?

Je suis novice en la matière et j'aimerai bien monter un serveur Metin2 en dédié .

Je pensai m'inspirer de ce tuto :

Je vous remercie d'avance pour l'aide que vous pourriez m'apporter .

Link to comment
Share on other sites

  • Answers 8
  • Created
  • Last Reply

Top Posters For This Question

Popular Days

Top Posters For This Question

8 answers to this question

Recommended Posts

  • 0

mysql  Ver 8.0.27 for FreeBSD13.0 on amd64 (Source distribution)

je ne pense pas qu'il y ai un rapport mais lorsque je fait

 pkg -y
pkg: illegal option -- y
pkg: Invalid argument provided

Link to comment
Share on other sites

  • 0
  • Administrator

Mon tutoriel a été basé sur la version 12 de BSD et sur une image ISO officielle (donc non modifiée par l'hébergeur).
Si SU ou SUDO ne permettent pas de débloquer la situation, il faudrait voir le changelog MySQL et vérifier si la commande (mysql_secure_installation) existe toujours, je ne pense pas quelle soit désactivée ou supprimée.

Sinon, il reste la bonne vieille méthode de configuration manuelle sans passer par cette commande.

french_banner.gif

Link to comment
Share on other sites

  • 0

OVH ne propose plus de version de FreeBSD , je suis donc passer par les .ISO de freebsd.org , le fichier est donc non modifié, peu tu me dire comment faire la configuration en mode manuel ?

Link to comment
Share on other sites

  • 0
  • Administrator

Le plus important, assure toi que l'utilisateur MySQL root ne soit pas accessible en extérieur, seulement en localhost.
Je ne me souviens plus si c'est le cas par défaut, ou pas.

french_banner.gif

Link to comment
Share on other sites

  • 0

J'ai finalement décidé de reprendre l'installation avec un freebsd 12, l'installation a rencontrer quelque problème que j'ai pu rectifier via google ( notre ami )

ERROR 1820 (HY000): You must reset your password using ALTER USER statement before executing this statement.

règler avec un :

ALTER USER 'root'@'localhost' IDENTIFIED  BY '***************';

néanmoins je suis devant un problème de connexion base de données :  mysql 10061 unknown error

si je fait :

CREATE USER 'mon id'@'localhost' IDENTIFIED WITH mysql_native_password BY 'mon pass';
CREATE USER 'mon id'@'%' IDENTIFIED WITH mysql_native_password BY 'mon pass';

CREATE USER 'mon id 2'@'localhost' IDENTIFIED WITH mysql_native_password BY 'mon pass 2';
CREATE USER 'mon id 2'@'%' IDENTIFIED WITH mysql_native_password BY 'mon pass 2';

et que je donne les droits avec :

GRANT ALL PRIVILEGES ON metin2.* TO 'mon id'@'localhost';
GRANT ALL PRIVILEGES ON metin2.* TO 'mon id'@'%';

GRANT ALL PRIVILEGES ON account.* TO 'mon id 2'@'localhost';
GRANT ALL PRIVILEGES ON common.* TO 'mon id 2'@'localhost';
GRANT ALL PRIVILEGES ON player.* TO 'mon id 2'@'localhost';
GRANT ALL PRIVILEGES ON hotbackup.* TO 'mon id 2'@'localhost';
GRANT ALL PRIVILEGES ON log.* TO 'mon id 2'@'localhost';

GRANT ALL PRIVILEGES ON account.* TO 'mon id 2'@'%';
GRANT ALL PRIVILEGES ON common.* TO 'mon id 2'@'%';
GRANT ALL PRIVILEGES ON player.* TO 'mon id 2'@'%';
GRANT ALL PRIVILEGES ON hotbackup.* TO 'mon id 2'@'%';
GRANT ALL PRIVILEGES ON log.* TO 'mon id 2'@'%';

FLUSH PRIVILEGES;

je devrais en principe pouvoir me connecter a mon ip serveur avec les identifiants :

mon id

mon pass

ou

mon id 2

mon pass 2

?

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.