Aller au contenu

1.0.1 | Metin2 Project | Kraizy Full Edition


Messages recommandés

  • Réponses 91
  • Created
  • Dernière réponse

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Introduction Aujourd'hui disparu, Metin2 Project est la suite logique du développement des files ayant été commencé il y a quelques temps par l'équipe de Funky Emulation. La dernière sortie des files est la 3.0. Le développement de Metin2 Project a été basé sur ces dernières. Kraizy Full Edition, est la première branche de Metin2 Project. Celle-ci permet d'exécuter un serveur privé Metin2 avec des améliorations, des systèmes, l'objectif étant de sa rapprocher le plus possible des mises à jo

Je t'invite à suivre le guide M2 Project ===> https://project.metin2.dev/topic/7-cmasterguideinit-le-guide-du-débutant/ Tu y trouveras tous les sujets utile  

M2P 1.0.1 | Metin2 Project | Free Server Files | Nargoth Files     M2P 1.0.1 est enfin disponible en téléchargement, la maintenant, tout de suite pour votre plus grand plaisir ! Vous pouvez découvrir les corrections et les ajouts de la 1.0.1 : Historique des modifications. Vous pouvez découvrir les images de la 1.0.1 : Voir les Prévisualisations. Disponible et utilisable en anglais et en français ! N'hésitez pas à rejoindre notre Discord pour échanger

Il y a 22 heures, Unix97 a dit :

To fix mysql errors i rebooted the VPS and from what i see everything works fine.

Hey @ASIKOO when u will release version 1.1.0, could you specify the file where you made changes so that we can compare the files with version 1.0.1? :D

Lien à poster

Btw, when the client source compiles maybe most will get the next error

Error    RC1015    cannot open include file 'afxres.h'.

I fixed the error by making the following change:

I opened the file UserInterface.rc and instead of #include "afxres.h" i replaced with #include "windows.h"

:)

Lien à poster
  • Administrateur
il y a 59 minutes, Unix97 a dit :

Btw, when the client source compiles maybe most will get the next error

Error    RC1015    cannot open include file 'afxres.h'.

I fixed the error by making the following change:

I opened the file UserInterface.rc and instead of #include "afxres.h" i replaced with #include "windows.h"

:)

You are missing Visual Studio includes

Le 22/03/2021 à 10:20, Unix97 a dit :

Hey @ASIKOO when u will release version 1.1.0, could you specify the file where you made changes so that we can compare the files with version 1.0.1? :D

 

I would push on github like every version, otherwise there is WinMerge.

090100logo.png 090149logo-4-bis.png

Lien à poster

Super :)

I found some problems

1. I created a new account but it looks like i can't receive yang ( https://i.gyazo.com/e819644fa1e8cdd90af1dbd2f1fd5ace.mp4 )
I dont see any errors in syserr. And i think there's another problem with the pet type.

 

2. Yhis happens when the pet is invoked. When i change my char or disconnect from the game, that effect on the item doesnt disappear, but the pet disappears.
https://prnt.sc/10tfdo9

3. Trade doesnt work :(

0323 13:54:08519 :: R ::   File "game.py", line 974, in StartExchange

0323 13:54:08520 :: R ::   File "interfaceModule.py", line 863, in StartExchange

0323 13:54:08520 :: R ::   File "uiExchange.py", line 110, in OpenDialog

0323 13:54:08520 :: R :: TypeError
0323 13:54:08520 :: R :: : 
0323 13:54:08520 :: R :: not enough arguments for format string
0323 13:54:08520 :: R :: 

PS: The trade problem is only for locale/en, and to solve the problem make the following changes:
Open locale_game.txt search
EXCHANGE_TITLE    Trade with %s (%d)

EXCHANGE_TITLE	Trade with %s (%d)

replace with

EXCHANGE_TITLE	Trade with %s

 

That's all i've found so far :) I would be happy if you could offer a solution for these

Modifié par Unix97
  • J'adore 1
Lien à poster
Le 23/03/2021 à 21:29, ASIKOO a dit :

Wtf... nobody has the big bugs you have. (1)
(2) and (3) not tested

Hey @ASIKOO in the end i managed to make everything functional :d

I've a question about the specular (the gloss on the armor/weapons) what did u modify to get that gloss only in certain parts of the armor/weapons?

Ex: https://i.gyazo.com/5c02fa6b7251d905860739a7283aeb93.mp4 | https://i.gyazo.com/6a1e77fdd32e46ff79d087afe6fb2a43.mp4

Modifié par Unix97
Lien à poster

Hey @ASIKOO ive a question about debug mode.

I need debug mode for the launcher, i compiled the client successfully but when i open the game i get the following error:

The application was unable to start correctly (0xc0150002)/

Can u give me some advice on what i can do? :)

Modifié par Unix97
Lien à poster
  • Administrateur
Il y a 2 heures, Unix97 a dit :

Hey @ASIKOO ive a question about debug mode.

I need debug mode for the launcher, i compiled the client successfully but when i open the game i get the following error:

The application was unable to start correctly (0xc0150002)/

Can u give me some advice on what i can do? :)

https://cdn.discordapp.com/attachments/448044421204934656/812369088797737011/VC_x86Runtime.exe

  • J'adore 2

090100logo.png 090149logo-4-bis.png

Lien à poster
  • Administrateur
Il y a 2 heures, Unix97 a dit :

hey @ASIKOO ive a question for you

If int64_t is used for signed long long, for unsigned long long what can i use?

I dont see anything like that in  the list, thats why i ask :D

 

uint64_t

  • J'adore 1

090100logo.png 090149logo-4-bis.png

Lien à poster

Hey @ASIKOO what did you use to convert gr2 models to version 2.9.12.0 ?

I added a sash on the server, can't see it, i changed the model with the same sash found in the client from M2PROJ 1.0.1, and it seems to have worked.

 

Lien à poster
  • Administrateur
Il y a 7 heures, Unix97 a dit :

Hey @ASIKOO what did you use to convert gr2 models to version 2.9.12.0 ?

I added a sash on the server, can't see it, i changed the model with the same sash found in the client from M2PROJ 1.0.1, and it seems to have worked.

 

I didn't change the version of granny

090100logo.png 090149logo-4-bis.png

Lien à poster
Le 02/04/2021 à 23:11, ASIKOO a dit :

I didn't change the version of granny

Ok, but from what i noticed the client uses granny 2.9.12.0 . Is there a converter to read the gr2 models? He doesnt read many new models :(

PS: I solved. I updated granny version and it seems that everything works perfectly :)

Modifié par Unix97
Lien à poster
  • 2 weeks later...

Hello, good evening...

 would like to congratulate you for this incredible work. Since 2010, when I became interested in Metin2 and how to create a server for him, I have never seen a server file so good to start and still free for anyone who is not lazy. Thank you very much and congratulations for the project.

Lien à poster

Merci !

Du Coup les logins ne marchent pas sur putty // aussi pouvez vous faire un mag offline dans la prochaine maj? :))♥

 

[URL=http://epvpimg.com/wgHceab][IMG]http://i.epvpimg.com/wgHceab.png[/IMG][/URL]

Modifié par parallelhuriko
Lien à poster

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant



×
×
  • Créer...

Information importante

Conditions d’utilisation / Politique de confidentialité / Règles / Nous avons placé des cookies sur votre appareil pour aider à améliorer ce site. Vous pouvez choisir d’ajuster vos paramètres de cookie, sinon nous supposerons que vous êtes d’accord pour continuer.