Aller au contenu
  • 0

VM pkg install


Saejin

Question

Bonjour,

 

Je contre un soucis lors de l'installation de mysql57,

je possède la VM que Saw à partagé.

Cette VM est fournis avec mysql55 d'installé.

 

Hors je souhaiterais passer à la version 57.

Pour cela, je tape les commandes suivante :

 

#pkg install mysql57-server mysql57-client

#pkg install mysql57-server

#cd /usr/ports/databases/mysql57-server

#make

#make install

 

Mais aucune d'entre elles ne fonctionnent.

Voici ce qui m'est renvoyer :

 

spacer.png

 

 

 

J'ai bien le dossier de mysql57-server et mysql57-client à l'emplacement ci dessous :

 

cd /usr/ports/databases/mysql57-server

cd /usr/ports/databases/mysql57-client

 

Merci d'avance

Modifié par Saejin
Lien à poster

12 réponses à cette question

Messages recommandés

  • 0

Bonjour et merci d'avoir répondu,

 

J'ai bien essayer plusieurs commandes comme :

portsnap fetch extract

portsnap fetch update

pkg update

 

Mais aucune ne résout mon soucis.

 

Lorsque je j’exécute la commande pkg update j'obtiens ceci :

spacer.png

 

Merci d'avance

Lien à poster
  • 0

Merci d'avoir répondu,

 

Je dois regarder quel iso prendre de FreeBSD entre

FreeBSD 12.0-RELEASE
FreeBSD 11.2-RELEASE
FreeBSD 10.2-RELEASE

 

Lequel me conseiller vous ? Et aussi, je vois plusieurs image, "amd64, i386, etc..." Lequel prendre ?

 

spacer.png

 

Merci d'avance

Modifié par Saejin
Lien à poster
  • 0

Merci d'avoir répondu,

 

Bon j'ai installer ma nouvelle VM et installer quasi tout les packages mais je n'arrive pas à installer compat7x via la commande :

pkg install compat7x

cd /usr/ports/misc/compat7x && make -DBATCH install clean

 

Comment pourrais-je faire ?

 

aussi, je n'ai pas réussi à installer gcc49 via cette commande :

pkg install gcc49

 

Du coup j'ai juste fait :

pkg install gcc

 

Ca ne changera rien au fait de compiler mes sources où je peux avoir des erreurs ?

 

Merci d'avance

 

Lien à poster
  • 0

Merci d'avoir répondu,

 

D'accord, là par exemple j'ai lancer :

pkg install gcc

Ca me met ceci :

 Installing gcc-9_4...

J'en conclu que c'est la version 9.4, c'est bien cela ?

Car lorsque je lance la compilation, j'obtiens cette erreur et la compilation s'arrête :

gmake: g++49: Command not found

si je change dans le makefile g++49 en g++ j'obtiens un tas d'erreurs et j'obtiens pas de game.

 

 

Quelqu'un saurait comment je peux installer G++49 sur FreeBSD 12 ?

 

Et pour compat7x, quelqu'un saurait la commande ? Car "pkg install compat7x" ne fonctionne pas
 

 

Merci d'avance
 

Modifié par Saejin
Lien à poster
  • 0
  • Administrateur

Si la compilation se lance, c'est que c'est bon.

Si tu as des erreurs, il faut les corriger.

 

Je te conseille d'utiliser la VDI pour compiler si tu ne peux pas corriger les erreurs toi même ( il y en aura pas mal il me semble ).

Le dédié pour le serveur ;) 

Lien à poster
  • 0

Bonjour et merci d'avoir répondu,

 

J'ai une petite question, sachant que de mon côté "pkg install gcc42 / pkg install gcc49" ne fonctionne pas chez moi, j'ai donc fais :

pkg install gcc

 

Mais quelle est la version installé svp ? 

 

J'ai ceci

spacer.png

 

 

Merci d'avance

Lien à poster
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.


Shoutbox

Shoutbox

Chatroom Rules

 

Rejoignez notre Discord

Une demande d'aide = Bannissement de la Shoutbox

Soyez respectueux & Respectez les règles

 

×
×
  • Créer...

Information importante

Conditions d’utilisation / Politique de confidentialité / Règles / Nous avons placé des cookies sur votre appareil pour aider à améliorer ce site. Vous pouvez choisir d’ajuster vos paramètres de cookie, sinon nous supposerons que vous êtes d’accord pour continuer.