Jump to content
  • 0
Sign in to follow this  
Yalabi

en cours Probleme avec systeme de rareté

Question

Version des Files / Type d’Émulateur Files 2016

Domaine ( Base de Données, Client, Core, Sources... ) : Client

Niveau : Débutant

 

1. Description du dysfonctionnement / Question :

Bonjour, voila j'ai essayer d'ajouter le systeme de rareté sur mon serveur, j'ai suivis ce tutoriel

 Mais le probleme c'est qu'une fois enregistré et repack =, je lance mon jeu et apres l'id et le mdp le client se ferme...

Le syserr me parle de la ligne 828

2. SysErr ( Client / Server ) / SysLog ( Server )

 

Révélation

1016 16:41:08780 :: 
networkModule.py(line:208) SetSelectCharacterPhase
system.py(line:131) __pack_import
system.py(line:110) _process_result
introSelect.py(line:11) <module>
system.py(line:131) __pack_import
system.py(line:110) _process_result
uiTarget.py(line:12) <module>
system.py(line:131) __pack_import

networkModule.SetSelectCharacterPhase - <type 'exceptions.IndentationError'>:expected an indented block (uiToolTip.py, line 828)

1016 16:41:08780 :: ============================================================================================================
1016 16:41:08780 :: Abort!!!!

 

uiToolTip :

	def __AppendAttributeInformation(self, attrSlot):
    if 0 != attrSlot: <-La ligne 828
            TitleColor = self.GetBonusColor(attrSlot)
            for i in xrange(player.ATTRIBUTE_SLOT_MAX_NUM):
                    type = attrSlot[i][0]
                    value = attrSlot[i][1]

                    if 0 == value:
                            continue

                    affectString = self.__GetAffectString(type, value)
                    if affectString:
                            affectColor = self.__GetAttributeColor(i, value)
                            if attrSlot[3][1] > 0:
                                    self.AppendTextLine(affectString, TitleColor)
                    else:
                                    self.AppendTextLine(affectString, affectColor)

Et mon uiToolTip ICI

J'affirme avoir lu et accepté le règlement de Funky Émulation

Edited by Yalabi
Résolu ou pas (see edit history)

Share this post


Link to post

7 answers to this question

Recommended Posts

  • 0
Guest

Bonjour,

 

Il faut remplacer tes espaces par des tabulations :

1628122019-10-16-17-27-30.jpg1628122019-10-16-17-27-36.jpg

 

 

 

  • Like 1

Share this post


Link to post
  • 0

Je ne comprend pas pourquoi ca compte des espace au lieu des tab quand j'utilise la touche tab,

Et maintenant c'est la ligne 1008 qui pose probleme:

Mon uiToolTip

 

Edited by Yalabi
Nouvelle erreur (see edit history)

Share this post


Link to post
  • 0
Guest

Tes tabulations sont mal faites (le premier code étant le bon, le deuxième étant le tiens) :

1645442019-10-16-19-45-00.jpg

 

 

EDIT : Idem pour le code de la ligne 1008, toute la fonction possède des tabulations erronées 

Edited by Xayah (see edit history)
  • Like 1

Share this post


Link to post
  • 0

Voila j'ai recopié exactement comme sur le tuto mais je vois pas ou mettre les tab du coup le sysser me dis ligne 994 maintenant...

Au cas ou je remet mon uitooltip que je viens de modifier.

Share this post


Link to post
  • 0

Ajoute une tabulation a tes lignes de 994 à 1010.

Tu a des caractères erroné (a supprimer) ici :

 - a la ligne 1001 après le ":"

 - a la ligne 1010 avant le "("

 

  • Like 1

Share this post


Link to post
  • 0

Eh bah bravo les gars !

Je sèche toutes l’après midi sur des broutilles, heureusement que vous êtes la, je vous remercie ça fonctionne niquel.

 

Au cas ou si certaines personnes utilise les files 2016 et aurais le même problème en suivant le tuto je partage mon fichier uitooltip.py

Petit problème je crois que j'ai parlé trop vite ...

J'ai enfin pu me co sur le client mais maintenant tous mes items n'ont plus de description, quand je passe mon curseur dessus il n'y a rien.

 

Help :(

  • Like 1

Share this post


Link to post
  • 0
Sans réponse - Le sujet étant sans réponse ou non résolu, il se voit verrouillé et déplacé dans le forum : Résolu ou sans réponse...

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.