Jump to content
  • 0

Question Implantation


Yalabi

Question

Version des Files / Type d’Émulateur 2016 Team FE

Domaine ( Base de Données, Client, Core, Sources... ) : Client / Serveur

Niveau : Débutant

 

1. Description du dysfonctionnement / Question :

Bonjour, je viens vers vous pour vous parler de mon problème quand j'implante une arme ou une armure, j'implante en suivant le tutoriel du forum a la lettre mais rien n'y fait, je remplit l'item_list, l'item_proto, ..., je repack le tout, je me connecte au jeu, je m'équipe de l'arme et de l'armure et la ... bah rien, j'ai bien les effets des bonus mais pas de model 3D ni de texture, quand je m'équipe de l'arme mon personnage reste figé... J'ai essayé avec plusieurs armes et armures trouvées sur le forum mais c'est toujours le même délire.

J’espère que vous m'offrirez votre lumière sur mon problème, merci ;)

 

 

3. Comment le reproduire ?

Quand j'implante ça se reproduit.

 

J'affirme avoir lu et accepté le règlement de Funky Émulation

013344signature-forum.png

Link to post

22 answers to this question

Recommended Posts

  • 0

La fin de mon item_list avec deux des armes

Citation

21200    ARMOR    icon/item/21200.tga
21201    ARMOR    icon/item/21200.tga
21202    ARMOR    icon/item/21200.tga
21203    ARMOR    icon/item/21200.tga
21204    ARMOR    icon/item/21200.tga
21205    ARMOR    icon/item/21200.tga
21206    ARMOR    icon/item/21200.tga
21207    ARMOR    icon/item/21200.tga
21208    ARMOR    icon/item/21200.tga
21209    ARMOR    icon/item/21200.tga
80100    WEAPON    icon/item/set_6_sword_s.tga    d:/ymir work/item/weapon/set_6_sword_s.gr2
80110    WEAPON    icon/item/wa_ledraw.tga    d:/ymir work/item/weapon/sw_ledraw.gr2

 

Et j'utilise l'outil DumpProto partagé par Calypso.

Edited by Yalabi (see edit history)

013344signature-forum.png

Link to post
  • 0

Bon j'ai suivi ton conseil j'ai descendu mon id a 3300 et je constate une petite amélioration, quand je m'équipe de l'arme le personnage agis comme s'il en avait une mais elle est toujours invisible.

013344signature-forum.png

Link to post
  • 0
  • Bot

A tes lignes tu as mis des tirets du 8 look :

3300	WEAPON	icon/item/set_6_sword_s.tga	d_:/ymir work/item/weapon/set_6_sword_s.gr2
3310	WEAPON	icon/item/wa_ledraw.tga	d_:/ymir work/item/weapon/sw_ledraw.GR2

Enlève les _ comme ça :

3300	WEAPON	icon/item/set_6_sword_s.tga	d:/ymir work/item/weapon/set_6_sword_s.gr2
3310	WEAPON	icon/item/wa_ledraw.tga	d:/ymir work/item/weapon/sw_ledraw.GR2

 

Metin2 Download - Funky Émulation - Metin2 Dev - MiaW Network

Link to post
  • 0

Montre moi ta ligne item_proto.txt/item_names/item_list

ainsi qu'un screen du chemin de tes .dds émis par granny et le chemin de là où tu les a mis et idem pour le .GR2

Link to post
  • 0

item_proto :

Citation

3300    Epee S    ITEM_WEAPON    WEAPON_SWORD    2    ANTI_MUDANG | ANTI_MUSA | ANTI_ASSASSIN | ANTI_WOLFMAN    NONE    WEAR_WEAPON    NONE    0    0    0    0    0    LEVEL    120    LIMIT_NONE    0    APPLY_CRITICAL_PCT    100    APPLY_NORMAL_HIT_DAMAGE_BONUS    50    APPLY_SKILL_DAMAGE_BONUS    50    0    30000    40000    15000    20000    0    0    0    0
3310    Epee desert    ITEM_WEAPON    WEAPON_SWORD    2    ANTI_MUDANG | ANTI_MUSA | ANTI_ASSASSIN | ANTI_WOLFMAN    NONE    WEAR_WEAPON    NONE    0    0    0    0    0    LEVEL    150    LIMIT_NONE    0    APPLY_INT    50    APPLY_MAX_HP_PCT    50000    APPLY_MOV_SPEED    150    0    1000    2500    5000    6000    0    0    0    0

 

item_name

Citation

3300    Epee S
3310    Epee desert

 

item_list

Citation

3300 WEAPON icon/item/set_6_sword_s.tga d:/ymir work/item/weapon/set_6_sword_s.gr2

3310 WEAPON icon/item/wa_ledraw.tga d:/ymir work/item/weapon/sw_ledraw.GR2

 

Les GR2

Révélation

1749451.PNG
1749452.PNG
1749453.PNG
1749454.PNG

 

013344signature-forum.png

Link to post
  • 0

Hello @Yalabi,

 

Essaie de depack tes fichiers directement dans le client pour voir si ton arme est bien implantée. C'est une erreur qui arrive très souvent, on repack et on oublie de remplacer tout ça dans le client. Ou alors on oublie de repack. Depack son client est un bon moyen de vérifier si on a bien tout fait correctement.

 

Tu peux essayer aussi avec un autre VNUM. Pour savoir si ça vient du VNUM, tu peux mettre l'ID d'une arme existante. Par exemple 10. Si ça fonctionne, c'est que le VNUM 3300 n'est pas dans la bonne plage (à vrai dire, je ne connais pas l'intervalle)

 

Et aussi, avant de tester tout ça, vérifie bien qu'après tout tes tests, tu n'as pas une erreur, de lettres en trop / moins ou une faute de frappe dans l'item_list, etc ...

 

 

Link to post
Guest
This topic is now closed to further replies.


×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.