• 0
Veltor88

resolu Instance me déconnecte

Question

Bonsoir,

 

Je souhaiterai essayer les instances Gorges du purgatoire ainsi que l'instance du Mont Sohan

Mais quand je veux y accéder à partir de la map Flame

Sans-titre.png

 

Ça me déconnecte automatiquement des que je m'approche trop près et pour ce qui est de l'instance du Mont Sohan, après avoir parlé au PNJ ça me déconnecte aussi (après être TP, juste le temps de voir la map 1 sec et être déco)

Juste eu le temps de prendre le screen :

Sans-titre.png

 

J'ai regardé ce tuto :

Et j'ai bien l'impression que c'est déjà implanté (tout est déjà fait côté serveur)

Pour rappel j'utilise ces files 

Une idée du problème ?

Merci d'avance

Edited by quentin88

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Pour la déconnexion, je ne suis pas sur mais il faut " reconstruire " la map, la mettre sous worldedit, et régénérer les fichiers et surtout vérifier les zones ou l'ont peut marcher, j'avais corrigé ce bug comme ça après avoir analysé les logs, j'étais systématiquement déconnecté sur la map flame pour justement me rendre dans l'instance, impossible d'y aller....

 

( Voir tuto calypso pour la " création " d'une map si tu ne sais pas faire )

- Tu depack le client.

- Tu copies la Map dans ton disque (D : /)

- Tu vérifies les zones de marche, eau, bla bla etc...

- Tu enregistres, export la map.

- Tu remplaces le dossier de ta map dans ton client.

- Sur ton FTP, dans le dossier des maps côté serveur, il te faut remplacer les fichiers servera_attr et un autre qui se trouve dans dans la map de ton client.

 

SINON - il nous faut les logs client + serveur, ( syserr )...

Share this post


Link to post
Share on other sites
  • 0

Wesh,

 

Ton problème provient en effet de ce qu'à dit @ASIKOO. Dans les files que tu possèdes il y'a un système "Anti Wall-Hack", en raison des mauvais positionnement de ta map sur W.E etc, le serveur croit que tu WallHack donc t'es déconnecté. Soit tu retire ce système, ou bien tu refais la map comme a dit Asikoo.

Share this post


Link to post
Share on other sites
  • 0
Il y a 4 heures, #Saw a dit :

Wesh,

 

Ton problème provient en effet de ce qu'à dit @ASIKOO. Dans les files que tu possèdes il y'a un système "Anti Wall-Hack", en raison des mauvais positionnement de ta map sur W.E etc, le serveur croit que tu WallHack donc t'es déconnecté. Soit tu retire ce système, ou bien tu refais la map comme a dit Asikoo.

 

Je préfère enlever le systeme de WH ça sera plus simple et rapide, dans ce cas comment le supprimer ?

Edited by quentin88

Share this post


Link to post
Share on other sites
  • 0

" Refaire " la map prend 5mn à tout casser entre ouvrir le logiciel, charger la map et la reexporte sur client / serveur ^^'

Share this post


Link to post
Share on other sites
  • 0
il y a 15 minutes, ASIKOO a dit :

" Refaire " la map prend 5mn à tout casser entre ouvrir le logiciel, charger la map et la reexporte sur client / serveur ^^'

 

Ça réponds pas a ma question lol, je préfère faire comme ça 🤨

Share this post


Link to post
Share on other sites
  • 0

Tu vas dans input_main.cpp

 

et tu supprime ce bout de code :

 

		PIXEL_POSITION pos = ch->GetXYZ();
		if (!SECTREE_MANAGER::instance().GetMovablePosition(ch->GetMapIndex(), pos.x, pos.y, pos)) {
			if (ch->GetDesc()) {
				LogManager::instance().HackLog("WALLHACK", ch);
				ch->GetDesc()->DelayedDisconnect(3);
			}
		}

 

Edited by #Saw

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.