Aller au contenu
  • 0

Création serveur 1.29


Veltor88

Question

Bonjour,

 

Je cherche à faire un serveur Dofus 1.29 en local mais je suis perdu, j'ai réussi à suivre un tuto pour Vemu, installer les BDD dans l'ordre mais je reste bloqué, il n'y a pas de client fourni avec.

 

Quelqu'un saurait-il m'aider s'il vous plaît ?

Modifié par quentin88 (Voir l’historique des modifications)
Lien à poster

16 réponses à cette question

Messages recommandés

  • 1
  • Modérateur

Ou alors remplace juste 443 par 442 dans ta colonne 'port' dans 'servers_list'.

En fait, tu as configuré pour que le realm se lance sur le port 443 et le game sur le port 442. Mais dans la base de données tu indique que le game est sur le port 443, donc le realm se redirige vers lui même (d'où le fait que tu tourne en rond).

  • J'adore 1

java style =)

Lien à poster
  • 0
  • Modérateur

Salut,

Tu peux trouver le client sur le site officiel de Dofus : lien vers les téléchargements (scroll un peu il y a un encadré pour Dofus 1.29 : lien direct)

 

Sinon tu pourra le trouver ici même dans ce sujet : lien funky emu

Si ton installation de Vemµ est bien fonctionnelle, pourquoi ne pas rédiger tutoriel sur l'installation de cet émulateur ? Ca se passe ici, ce serait sympa pour d'autres débutants et ca aiderait bien le forum :)

 

java style =)

Lien à poster
  • 0
  • Modérateur

Je pense que tu as mal installé la BDD. La base ca va mais tu dois t'être trompé sur les patch d'update. Normalement la plupart sont à exécuter sur vemu_others (je pense qu'il n'y a que "character_vers_0_2_1_0" qui ne soit pas à mettre sur vemu_others mais sur vemu_characters).

java style =)

Lien à poster
  • 0

C'est bon finalement j'ai réussi j'ai dû tout recommencer, je pense avoir oublié quelque chose

J'ai galéré a mettre de bon port correspondant entre le serveur et le config.xml

J'ai créé mon compte depuis navicat mais maintenant j'ai de nouveau un problème

Je tourne en boucle dans le choix du serveur, en gros je choisi le serveur, je fais "ok", ça charge et ça me ramène juste avant

Lien à poster
  • 0
Il y a 3 heures, Homeomorphe a dit :

Je te conseille de supprimer les comptes et personnages qui sont dans la base de donnée et de te créer un compte manuellement depuis la base de donnée.

Cordialement

 

J'ai de nouveau tout supprimé (compte et perso), même problème ☹️

Lien à poster
  • 0
il y a 26 minutes, Homeomorphe a dit :

Tu dois avoir une table dans ta base de donnée qui doit s’intituler ‘server’ ou quelque chose comme ça, regarde les données qui sont dedans et compare les à tes configurations (port etc.)

 

Homeo

<config>

<delay value="500"/>
<rdelay value="3000"/>
<rcount value="10"/>

<conf name="En ligne">
<connserver name="Officiel" ip="213.248.126.11" port="443" />
<connserver name="Zaros" ip="127.0.0.1"port="443" />
<dataserver url="data/" type="local" priority="1" />
<dataserver url="http://127.0.0.1/dofus/"priority="3" />
<dataserver url="http://staticns.ankama.com/dofus/gamedata/dofus/"priority="2" />
<dataserver url="http://gamedata.ankama-games.com/dofus/"priority="0" />
</conf>

<conf name="En ligne (TEST)" type="test">
<dataserver url="data/" type="local" priority="3" />
<dataserver url="http://staticns.ankama.com/dofus/gamedata/dofustest/" priority="1" />
<dataserver url="http://gamedata.ankama-games.com/dofustest/" priority="0" /> 
</conf> 

<cacheasbitmap>
<cache element="ExternalContainer/InteractionCell" value="false" />
<cache element="ExternalContainer/Ground" value="false" />
<cache element="ExternalContainer/Object1" value="false" />
<cache element="ExternalContainer/Object2" value="false" />
<cache element="ExternalContainer/Zone" value="false" />
<cache element="ExternalContainer/Select" value="false" />
<cache element="ExternalContainer/Grid" value="false" />
<cache element="ExternalContainer/Pointer" value="false" />
<cache element="GAPI/UI" value="false" />
<cache element="GAPI/UITop" value="false" />
<cache element="GAPI/Popup" value="false" />
<cache element="GAPI/UIUltimate" value="false" />
<cache element="GAPI/Cursor" value="false" />
<cache element="mapHandler/BACKGROUND" value="false" />
<cache element="mapHandler/Cell/Ground" value="false" />
<cache element="mapHandler/Cell/Object1" value="false" />
<cache element="mapHandler/Cell/Object2" value="false" />
<cache element="mapHandler/Cell/ObjectExternal" value="false" />
<cache element="Zone/Zone" value="true" />
<cache element="Zone/Pointers" value="true" />
</cacheasbitmap>

</config>

181224063046542800.png

 

 

Voila mon fichier xml et mes infos pour server_list (BDD)

 

Engine.txt

SYSTEM_PORT = 4040
USELESS_PORT = 481
GAME_ID = 1
GAME_PORT = 442

SQL_IP = localhost
SQL_USER = root
SQL_PASS = 

SQL_ACCOUNTS = vemu_accounts
SQL_CHARACTERS = vemu_characters
SQL_OTHERS = vemu_others

MSG_COLOR = #CC0000
MSG_WELCOME = Bienvenue sur Quentin Serveur
MSG_ONCONNECT = false

START_LEVEL = 1
START_KAMAS = 10000000
START_STATS = 0

START_MAP = 10279
START_CELL = 284
START_DIR = 3

ENABLE_AURA = true
ENABLE_NIGHT = true

RATES_PVP = 1
RATES_PVM = 0
DROPS_RATE = 1

ANTISPAM_COMMERCE = 30
ANTISPAM_RECRUITMENT = 30

CENSURED_WORDS = .save

SHOW_INFOS = True
SHOW_NOTICES = True
SHOW_WARNINGS = True

POINTS_NAME = Points

PRISM_SIZE = 90

STATS_RATE = 1

ACTIVE_CMD_TRAQUE = true

realm.txt

LOGIN_VERSION = 1.29.1
LOGIN_PORT = 443

SQL_IP = localhost
SQL_USER = root
SQL_PASS = 

SQL_ACCOUNTS = vemu_accounts
SQL_OTHERS = vemu_others

SHOW_INFOS = false
SHOW_NOTICES = false
SHOW_WARNINGS = false

MAX_PLAYER = 500

 

 

J'ai oublié quelque chose ? Je trouve pas

Modifié par quentin88 (Voir l’historique des modifications)
Lien à poster
  • 0
Il y a 10 heures, Nicosti a dit :

Ou alors remplace juste 443 par 442 dans ta colonne 'port' dans 'servers_list'.

En fait, tu as configuré pour que le realm se lance sur le port 443 et le game sur le port 442. Mais dans la base de données tu indique que le game est sur le port 443, donc le realm se redirige vers lui même (d'où le fait que tu tourne en rond).

 

Trop fort merci ça marche ! 😍

 

Edit: Par contre c'est normal que je ne gagne pas d'xp après un combat ?

Modifié par quentin88 (Voir l’historique des modifications)
Lien à poster
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.


×
×
  • Créer...

Information importante

Conditions d’utilisation / Politique de confidentialité / Règles / Nous avons placé des cookies sur votre appareil pour aider à améliorer ce site. Vous pouvez choisir d’ajuster vos paramètres de cookie, sinon nous supposerons que vous êtes d’accord pour continuer.