• 0
Xenne

en cours Problème client qui crash

Question

Version des fichiers/ Type d'émulateur : Files 2016 (Saejin).

Domaine (Base de données, Client, Core...) : Client.

Votre niveau (Débutant, Intermédiaire, Avancé..) : Débutant.

 

Description du problème : Après la modification du dossier property, je le repack, je lance le client et après l'image de chargement il se ferme.

Comment reproduire le problème ? : Lancer le client, se connecter, changer/ajouter un objet dans le dossier property depack.

Recherches et tests effectués Mettre le property de base (fonctionnel), modifier le property.

 

Screenshot du problème concerné :

Aucun car je ne peux pas prendre de Screenshots du client qui se ferme ^^

Aucune erreur indiquée dans le sysser client.

En vous remerciant d'avance.

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le Règlement de Funky-Emulation.

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

bien sur j'ai ajouté tous ça

 

ps: j'ai essayé de les ajoutée 1à 1 , objet par objets mais des que je rajoute 1 objet (même au hasard) le client crash 

 

285312zzzzdddddd.PNG

Edited by Xenne

Share this post


Link to post
Share on other sites
  • 0

Le problème vient du packer je pense. Il ne doit pas retranscrire tous les fichiers quand tu depack. (Ça m'est déjà arrivé)

Share this post


Link to post
Share on other sites
  • 0

Pour vérifier, est-ce qu'entre le pack original et le modifié il y a un changement drastique de poids ?

 

Ou plus simplement, depack, puis repack et vois si ça mache déjà comme ça !

Edited by Takuma

Share this post


Link to post
Share on other sites
  • 0

celui de base en .epk fais 334ko , celui modifier fait exactement 21 689 ko

 

et quand je depack celui de base et que je le repack ça marche 

Share this post


Link to post
Share on other sites
  • 0

Vérifie que tu n'as pas des noms de fichiers étranges. Tu utilises quoi pour dépack/repack ? Certains outils ne fonctionnent pas toujours correctement.

Share this post


Link to post
Share on other sites
  • 0

bonjour j'utilise Eternexus (celui ci EterNexus 1.0.3.1a) , et non le property ne contient pas de fichier étrange car dans le logiciel World Editor c'est moi qui ai donné les noms des objets (exemple muraille , palette , mur , herbes1,2,3 etc).

 

Cordialement Xenne

Share this post


Link to post
Share on other sites
  • 0

Salut, hélas c'est pas un problème courant, c'est la première fois que je vois un tel problème.
J'ai aucune piste pour t'aider à ce sujet.

Share this post


Link to post
Share on other sites
  • 0

Slt,

 

Y a deux hypothèses:

 

Soit le nom de ton/tes fichier sont mal compressé par le packer et donc sont mal lu par le client ( chose qui m'est déjà arrivé en changeant de repacker)

 

Ou bien les fichiers que tu ajoutes sont corrompus, très probable car généralement quand ça ferme sans syserr c'est parfois que tes fichiers sont corrompus. 

 

Je te propose d'essayer de mettre tes fichiers dans un nouveau pack à part pour voir si ça ferme encore.

 

Cdt,

#Saw

Share this post


Link to post
Share on other sites
  • 0

Bonjour 

Merci pour vos réponse , mais hélas ça marcher très bien mon dossier property quand j'avais les file By Gin ( je l'ai ai plus car oublier de faire une sauvegarde des files) , j'ai essayé de les rajoutée dans une dossier à part et la le client se lance plus du tout sans mettre d'erreur dans le sysser.

 

Si vous avez d'autre solution je suis preneur

 

Cordialement Xenne

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.