Jump to content
  • 0

erreur TABLE NAVICAT


ShadowMt2

Question

Version des fichiers/ Type d'émulateur :freebsd

Domaine (Base de données, Client, Core...) :2012

Votre niveau (Débutant, Intermédiaire, Avancé..) :debutant

 

Description du problème : erreur en deplacant les tables

Comment reproduire le problème ? :

Recherches et tests effectués :

bonjour

J'ai un soucis en transfere des tables sql dans navicat, j'ai des erreurs pendants le transfere donc perte de fichier

Screenshot du problème concerné :

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le Règlement de Funky-Emulation.

Edited by titi1706 (see edit history)
Link to post

11 answers to this question

Recommended Posts

  • 0
il y a 5 minutes, Calypso a dit :

Donne nous toute l'erreur dans la mettant dans une balise code

[Err] 1067 - Invalid default value for 'create_time'
[Err] CREATE TABLE `account` (
  `id` int(11) NOT NULL auto_increment,
  `login` varchar(30) NOT NULL default '',
  `password` varchar(45) NOT NULL default '',
  `password_decrypt` varchar(30) default NULL,
  `real_name` varchar(16) NOT NULL default '',
  `social_id` varchar(7) NOT NULL default '',
  `email` varchar(64) NOT NULL default '',
  `phone1` varchar(16) default NULL,
  `phone2` varchar(16) default NULL,
  `address` varchar(128) default NULL,
  `zipcode` varchar(7) NOT NULL default '',
  `create_time` datetime NOT NULL default '0000-00-00 00:00:00',
  `question1` varchar(48) default NULL,
  `answer1` varchar(48) default NULL,
  `question2` varchar(48) default NULL,
  `answer2` varchar(48) default NULL,
  `is_testor` tinyint(1) NOT NULL default '0',
  `status` varchar(8) NOT NULL default 'OK',
  `securitycode` varchar(192) default '',
  `newsletter` tinyint(1) NOT NULL default '0',
  `empire` tinyint(4) NOT NULL default '0',
  `name_checked` tinyint(1) NOT NULL default '0',
  `availDt` datetime NOT NULL default '0000-00-00 00:00:00',
  `mileage` int(11) NOT NULL default '0',
  `cash` int(11) NOT NULL default '0',
  `gold_expire` datetime NOT NULL default '0000-00-00 00:00:00',
  `silver_expire` datetime NOT NULL default '0000-00-00 00:00:00',
  `safebox_expire` datetime NOT NULL default '0000-00-00 00:00:00',
  `autoloot_expire` datetime NOT NULL default '0000-00-00 00:00:00',
  `fish_mind_expire` datetime NOT NULL default '0000-00-00 00:00:00',
  `marriage_fast_expire` datetime NOT NULL default '0000-00-00 00:00:00',
  `money_drop_rate_expire` datetime NOT NULL default '0000-00-00 00:00:00',
  `ttl_cash` int(11) NOT NULL default '0',
  `ttl_mileage` int(11) NOT NULL default '0',
  `channel_company` varchar(30) NOT NULL default '',
  `rang` tinyint(4) default NULL,
  `ipbox` text NOT NULL,
  `coins` int(11) NOT NULL default '0',
  `web_admin` int(1) NOT NULL default '0',
  `web_ip` varchar(15) NOT NULL,
  `web_aktiviert` varchar(32) NOT NULL,
  PRIMARY KEY  (`id`),
  UNIQUE KEY `login` (`login`),
  KEY `social_id` (`social_id`)
) ENGINE=MyISAM AUTO_INCREMENT=7607 DEFAULT CHARSET=latin1;
[Msg] Finished - Unsuccessfully
--------------------------------------------------

 

Link to post
  • 0

Dans ton account.sql, au début du fichier, ajouter ces lignes et ressaie :

 

/*!40101 SET @[email protected]@CHARACTER_SET_CLIENT */;
/*!40101 SET @[email protected]@CHARACTER_SET_RESULTS */;
/*!40101 SET @[email protected]@COLLATION_CONNECTION */;
/*!40101 SET NAMES utf8 */;
/*!40103 SET @[email protected]@TIME_ZONE */;
/*!40103 SET TIME_ZONE='+00:00' */;
/*!40014 SET @[email protected]@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;
/*!40014 SET @[email protected]@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;
/*!40101 SET @[email protected]@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO' */;
/*!40111 SET @[email protected]@SQL_NOTES, SQL_NOTES=0 */;

 

Ces lignes permette de définir les paramètres de ta dabatase. Je pense que cela bloque au SQL_MODE

Link to post
  • 0

Merci , ca a fonctionné parcontre idem sur la table Log 

 

[Err] 1067 - Invalid default value for '4'
[Err] CREATE TABLE `dragon_slay_log` (
  `1` varchar(16) NOT NULL,
  `2` varchar(16) NOT NULL,
  `3` timestamp NOT NULL default CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP,
  `4` timestamp NOT NULL default '0000-00-00 00:00:00'
) ENGINE=MyISAM DEFAULT CHARSET=latin1;
[Msg] Finished - Unsuccessfully
--------------------------------------------------

 

Link to post
Guest
This topic is now closed to further replies.


×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.