• 0
MT2Online

en cours [RÉSOLU]Impossible de creer un perso

Question

Version des fichiers/ Type d'émulateur : files 2016 pas plus de précisions

Domaine (Base de données, Client, Core...) : db 2016

Votre niveau (Débutant, Intermédiaire, Avancé..) : intermédiaire

 

Description du problème : je n'arrive pas a créer un personnage j'ai testé plusieurs table player mais rien y fait

Comment reproduire le problème ? :

Recherches et tests effectués : je cherche depuis 2 jours sur google rien n'a résolu le problème 

 

Screenshot du problème concerné :

syserr DB

 

SYSERR: Oct 20 20:13:49 :: pid_init: 
Start of pid: 25810

SYSERR: Oct 20 20:13:49 :: Start: TABLE_POSTFIX not configured use default
SYSERR: Oct 20 20:13:53 :: ChildLoop: AsyncSQL: query failed: Incorrect string value: '\x9A?????...' for column 'name' at row 1 (query: replace into mob_proto (vnum, name, locale_name, type, rank, battle_type, level, size, ai_flag, setRaceFlag, setImmuneFlag, on_click, empire, drop_item, resurrection_vnum, folder, st, dx, ht, iq, damage_min, damage_max, max_hp, regen_cycle, regen_percent, exp, gold_min, gold_max, def, attack_speed, move_speed, aggressive_hp_pct, aggressive_sight, attack_range, polymorph_item, enchant_curse, enchant_slow, enchant_poison, enchant_stun, enchant_critical, enchant_penetrate, resist_sword, resist_twohand, resist_dagger, resist_bell, resist_fan, resist_bow, resist_fire, resist_elect, resist_magic, resist_wind, resist_poison, dam_multiply, summon, drain_sp, skill_vnum0, skill_level0, skill_vnum1, skill_level1, skill_vnum2, skill_level2, skill_vnum3, skill_level3, skill_vnum4, skill_level4, sp_berserk, sp_stoneskin, sp_godspeed, sp_deathblow, sp_revive) values (10098, "°?š?????3?? 98
SYSERR: Oct 20 20:15:03 :: DirectQuery: AsyncSQL::DirectQuery : mysql_query error: Field 'money' doesn't have a default value
query: INSERT INTO player (id, account_id, name, level, st, ht, dx, iq, job, voice, dir, x, y, z, hp, mp, random_hp, random_sp, stat_point, stamina, part_base, part_main, part_hair, part_acce, part_shield, gold, playtime, skill_level, quickslot) VALUES(0, 95, 'teste', 1, 5, 3, 3, 5, 2, 0, 0, 3857845, 3859865, 0, 770, 300, 0, 0, 0, 800, 0, 0, 0, 0, 0, 0, 0, '\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0
SYSERR: Oct 20 20:15:03 :: __QUERY_PLAYER_CREATE: QUERY_ERROR: UPDATE player_index SET pid1=0 WHERE id=95

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le Règlement de Funky-Emulation.

Edited by MT2Online

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

déjà pour ta table_posfix regard qu'il sont comme ça dans le fichier config db:

 

204923ereur.PNG

 

Après ta un problême au niveau de la colonne money de ton player à se que je vois. Envoi screen

Edited by bd59140

Share this post


Link to post
Share on other sites
  • 0
 INSERT INTO player (id, account_id, name, level, st, ht, dx, iq, job, voice, dir, x, y, z, hp, mp, random_hp, random_sp, stat_point, stamina, part_base, part_main, part_hair, part_acce, part_shield, gold, playtime, skill_level, quickslot) 

La colonne money n'existe pas .

Share this post


Link to post
Share on other sites
  • 0
DirectQuery: AsyncSQL::DirectQuery : mysql_query error: Field 'money' doesn't have a default value

Le syserr dit à cette ligne que la colonne money n'a pas de valeur par défaut.

Fais clic droit sur ta table player -> Design table -> Tu cherches le champ money et tu modifies la valeur par défaut à 0.

214815money.JPG

 

Ensuite il y a une grosse erreur à ce niveau là :

 ChildLoop: AsyncSQL: query failed: Incorrect string value: '\x9A?????...' for column 'name' at row 1

Je pense qu'il y a un soucis avec le mob_proto qui doit utiliser des caractères coréens ou un truc dans le style, tu peux le coller ici qu'on puisse voir ?

 

Share this post


Link to post
Share on other sites
  • 0
il y a 32 minutes, _Sufhal a dit :
DirectQuery: AsyncSQL::DirectQuery : mysql_query error: Field 'money' doesn't have a default value

Le syserr dit à cette ligne que la colonne money n'a pas de valeur par défaut.

Fais clic droit sur ta table player -> Design table -> Tu cherches le champ money et tu modifies la valeur par défaut à 0.

214815money.JPG

 

Ensuite il y a une grosse erreur à ce niveau là :

 ChildLoop: AsyncSQL: query failed: Incorrect string value: '\x9A?????...' for column 'name' at row 1

Je pense qu'il y a un soucis avec le mob_proto qui doit utiliser des caractères coréens ou un truc dans le style, tu peux le coller ici qu'on puisse voir ?

 

Merci pour la partie money c'est résolu le souci du mob_proto pas encore et j'ai d'autre erreur dans les syserr je les dépose aussi ici ?

 

Je poste le mob proto se soir la je suis en vadrouille. En tout cas merci pour l'aide et le réponses que vous fournissez tous

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.