Aller au contenu

Nouveau membre ?! Pense à te présenter pour accéder au contenu du forum !

New member ?! Introduce yourself to get access to the forum !

  • 0
Rweys

en cours Crash & écran noir apres l'implantation du switch bot

Question

Bonjour,

J'ai réussi a configurer le serveur 2016 & 2014 tout fonctionne bien. ça fait déjà 3  jours  trois où je n'ai pas de problème, or j'ai eu l'idée d'implanter un switch bot,  j'ai suivi  le poste qui nous aide à l'implanter donc des modifications dans les fichers root ce qui a été fait comme sur le tuto. (Aucun problème pour ça je connais la manip) 

Donc une fois que j'ouvre le  clien ça me fait un écran noir...

J'ai donc eu l'idée d'essayer de l'implanter sur la file 2014...  J'ai eu casiment le même problème. Ca ne me faisait pas un écran noir  certes, mais ça faisait un crash dès que je me connectais .

 Voici le tuto que j'ai suivi :

Merci.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

24 réponses à cette question

Messages recommandés

  • 0

Bonjour,

 

peux-tu poster le contenu du fichier syserr.txt présent à la racine de ton client ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

Je viens de réesayer  sur le  clien 2016 ( donc j'ai refait les manips etc) alors cette fois ci il ne fait plus un écran noir il a triché sur le 2014 :') il reste bloqué à 100%

Bien sur voici mon syserr

0826 14:14:18016 :: Traceback (most recent call last):

0826 14:14:18017 ::   File "networkModule.py", line 245, in SetGamePhase

0826 14:14:18018 ::   File "system.py", line 130, in __pack_import

0826 14:14:18019 ::   File "
0826 14:14:18019 :: game.py
0826 14:14:18019 :: ", line 
0826 14:14:18019 :: 134
0826 14:14:18019 :: 

0826 14:14:18019 ::     
0826 14:14:18019 :: [TAB][TAB]self.switchbot = Bot()

0826 14:14:18019 ::     
0826 14:14:18019 ::  
0826 14:14:18019 ::  
0826 14:14:18019 ::  
0826 14:14:18019 ::  
0826 14:14:18019 ::  
0826 14:14:18019 ::  
0826 14:14:18019 ::  
0826 14:14:18019 ::  
0826 14:14:18019 ::  
0826 14:14:18019 ::  
0826 14:14:18019 ::  
0826 14:14:18019 ::  
0826 14:14:18019 ::  
0826 14:14:18019 :: ^

0826 14:14:18019 :: SyntaxError
0826 14:14:18055 :: : 
0826 14:14:18055 :: invalid syntax
0826 14:14:18055 :: 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Quand on te dit " [TAB][TAB]self.switchbot = Bot() ".

 

Il faut remplacer [TAB] par la touche tabulation de ton clavier ^^ En gros c'est un gros espace. Le python est très pointilleux.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

donc [TAB] = 1 espace ?²

   

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Donc [TAB] = la touche tabulation de ton clavier. Tabulation =/= Espace

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

En effet je viens de tester ça sur note pad ça fait un gros espace ^^ merci j'espère que ça marchera

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Si cela ne fonctionne toujours pas, n'hésite pas à re-poster le syserr.txt, il donne les indications sur les erreurs ;)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Merci asikoo et antok de votre attention :)

Alors j'ai remplacé [TAB] par la touche tabulation 

J'ai enregistrer, archiver, mis les roots... dans le pack

J'ai relancé le client et ça fait la même chose qu'avant 

Voici mon syserr   J'ai pas compris pourquoi il dit qu'il y a une erreur  à la ligne 134 alors que j'ai fait comme sur le tuto.. après j'ai certainement fait une erreur ou mal suivi le tuto je sais pas.. :( 

 

0826 15:43:12678 :: Traceback (most recent call last):

0826 15:43:12702 ::   File "networkModule.py", line 245, in SetGamePhase

0826 15:43:12738 ::   File "system.py", line 130, in __pack_import

0826 15:43:12741 ::   File "
0826 15:43:12741 :: game.py
0826 15:43:12741 :: ", line 
0826 15:43:12741 :: 134
0826 15:43:12741 :: 

0826 15:43:12741 ::     
0826 15:43:12741 :: self.switchbot = Bot()

0826 15:43:12741 ::     
0826 15:43:12742 :: ^

0826 15:43:12742 :: IndentationError
0826 15:43:12742 :: : 
0826 15:43:12742 :: unexpected indent
0826 15:43:12742 :: 

Merci

Modifié par Rweys

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Toujours cette histoire d'indentation. As-tu fais attention qu'il n'y ai pas d'espace ?

Dans notepad++ > Affichage > Symboles Spéciaux > Afficher les blancs et les tabulations.

 

Une flèche = Tabulation

Point = Espace

 

Dans cet exemple : 

[tab][esp]Tabulation[esp]Tabulation[esp]

 

Vérifie bien qu'il n'y est pas de " point " qui correspondent aux espaces en début de ligne / fin de ligne principalement.

 

image.png

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

:S C'est si  compliqué le python .

Tu dis en debut de ligne fin de ligne

[TAB][TAB]self.switchbot = Bot()
[TAB][TAB]self.switchbot.Hide()

Donc dans cette exemple le " self.switchbot" je ne mets pas d'espace au  "." car il n'est pas au début de ligne ni à la fin  

Modifié par Rweys

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Le python est sensible à l'indentation, c'est la particularité de ce langage, l'avantage, tout le monde dev avec la même exigeance.

Oui juste au début / fin de ligne.

 

Quand on fait des copier / coller, cela à tendance à copier des caractères invisibles (en début comme en fin de ligne) ce qui peut expliquer ton problème. Sinon, fait un screenshot de la la zone concernée.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

En effet alors je vais recommencer sans le copier coller ^^ Je te tiens au courant  quand j'aurai fini 

Modifié par Rweys

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Je l'ai fait sans copier coller. ( deux fois pour être sûr  ) 

Même chose ..  que faire :( 

0826 16:25:39712 :: Traceback (most recent call last):

0826 16:25:39712 ::   File "networkModule.py", line 245, in SetGamePhase

0826 16:25:39712 ::   File "system.py", line 130, in __pack_import

0826 16:25:39713 ::   File "
0826 16:25:39713 :: game.py
0826 16:25:39713 :: ", line 
0826 16:25:39713 :: 133
0826 16:25:39713 :: 

0826 16:25:39713 ::     
0826 16:25:39713 :: self.switchbot = Bot()

0826 16:25:39713 ::     
0826 16:25:39713 :: ^

0826 16:25:39713 :: IndentationError
0826 16:25:39729 :: : 
0826 16:25:39729 :: unexpected indent
0826 16:25:39729 ::  

PS : Je précise que mon client marchait avant et que c'est  sûr à 99,99 % que c'est  le switch bot qui fait tout bug 

Modifié par Rweys

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Screenshot vers la ligne 133 ou se trouve " self.switchbot = Bot() ".

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Re, excuse moi du temps 

Je viens juste d'installer screenshot voici le screen

http://prntscr.com/kn1spg

Merci ^^

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

La ligne : self.switchbot = Bot() comporte 4 TAB's la ligne en dessous en comporte 5, le tutoriel indique [TAB][TAB]. Tu as mis trop de tabulation. Regarde les lignes juste au dessus, elles sont alignées

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Oui tu as  raison j'avais pas vu ça comme ça moi 

je m'explique

quand je mets tab tab a la premiere ligne 

http://prntscr.com/kn1vpp et que j'appuie sur entrer ça me  fait déjà un gros espace et moi j'ai cru que c'était normal et qu'il faillait réappuyer sur tab tab qu'il n'y avait pas à s’inquiéter mais si ^^  du coup je vais refaire ça 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

L'important est de comprendre son erreur ;) 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Exactement , et je te remercie de me l'avoir fait comprendre ! :)

Du coup, pour ici http://prntscr.com/kn1www

 les deux tab sont déjà fait automatiquement ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Vérifie que ce sont bien des tab's si c'est le cas, notepad++ te les ajoutes automatiquement dans ton cas.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Re,

Alors j'ai tout fait correctement et une fois que je lance la page cette fois ci elle se charge jusqu'à 100% Cependant, un écran noir s'affiche directement.

0826 17:32:45090 :: Traceback (most recent call last):

0826 17:32:45090 ::   File "uiPhaseCurtain.py", line 61, in OnUpdate

0826 17:32:45091 ::   File "networkModule.py", line 150, in __ChangePhaseWindow

0826 17:32:45091 ::   File "game.py", line 195, in Open

0826 17:32:45092 ::   File "game.py", line 429, in __BuildKeyDict

0826 17:32:45092 :: NameError
0826 17:32:45108 :: : 
0826 17:32:45108 :: global name 'ap' is not defined
0826 17:32:45108 :: 

:( 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Hum tu as bien mis " app " au lieu de " ap " ? J'ai un doute.

[TAB][TAB]onPressKeyDict[app.DIK_F6]= lambda : self.__toggleSwitchbot()

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

En effet tu as raison!

à un  p près tout plante c'est incroyable l'informatique comme il  fait des manières comme pas possible^^

Si c'est pas un espace c'est un 'p'  x)

Merci beaucoup pour ton aide  que tu m'as apporté  

Sujet qui peut être fermé je pense ^^

j'explique mon problème j'ai pas remplacé le [TAB] par la touche tab^^

2eme problème ma touche tab se faisaient automatiquement donc parfois  y'en avait  5 x)

3eme problème j'ai  oublié un p à app   mdr ^^

mille mercis !

  

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

:)

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×

Information importante

By using this site, you agree to our Conditions d’utilisation.