Jump to content
×
×
  • Create New...
  • 0

[Sources] Erreur de compilation


Sufhal

Question

  • Modérateur

Bonjour à tous,

 

J'essaie de compiler le game 40250 mais une erreur survient immédiatement à la commande gmake -j20

gmake: *** No rule to make target '/usr/include/c++/4.2/cstdlib', needed by 'OBJDIR/BattleArena.o'.  Stop.

 

J'imagine qu'il sagit d'une lib manquante mais j'ai mis absolument tout ce que j'avais à ma disposition et j'ai scrupuleusement suivi les indications sur ces posts :

 

Avez-vous une idée ?

PS: J'ai essayé avec les sources vierges de Kraizy et les sources de la team FE (fournies avec les files 2016), même constat.

C'est donc la machine qui est responsable du problème, j'utilise un dédié sous FreeBSD 10.4

Merci par avance.

Link to comment
  • Answers 12
  • Created
  • Last Reply

Top Posters For This Question

12 answers to this question

Recommended Posts

  • 0

Les sources sont configurés pour compiler avec la version 4.2 gcc. Donc tu peux soit les configurer pour compiler avec une version supérieure ou bien tu continues à compiler en local.

Edited by #Saw
Link to comment
  • 0
  • Modérateur
il y a une heure, #Saw a dit :

Les sources sont configurés pour compiler avec la version 4.2 gcc. Donc tu peux soit les configurer pour compiler avec une version supérieure ou bien tu continues à compiler en local.

 

Il faut juste configurer le Makefile ?

 

il y a une heure, Reaper a dit :

Ton dédier possède combien de ram (go) ?

Normalement la compilation faut avoir maximum 3-4go pour compiler..

 

Mais je te conseil de compiler en local, vraiment plus simple!

 

Il a 4Go de RAM donc je pense pas que ce soit ça le problème..

Par contre je ne vois quoi en quoi c'est plus simple étant donné qu'il faut en plus faire tourner une machine virtuelle o.O

 

 

Merci pour vos réponses ^_^

Link to comment
  • 0

configurer le makefil et il me semble qu'il faut modifier quelques lib et code dans les sources db/game en fonction de la version de gcc que tu installes.

Edited by #Saw
Link to comment
  • 0
  • Modérateur

La seule ligne qui fait référence à GCC c'est celle là :

GCC_VERSION = $(shell $(CC) --version 2>&1 | grep "(GCC)" | cut -d' ' -f3  | cut -d'.' -f1)

Et très sincèrement je vois pas trop quoi modifier ici

 

Edit: mais en fait j'ai la 4.2 :

183801fe1.JPG

Edited by _Sufhal
Link to comment
  • 0
  • Modérateur

Du nouveau ; en installant gcc 4.3 et en supprimant le acce.cpp dans le Makefile j'ai pu compiler mais il y avait pas mal d'erreur.

Je me suis donc tourné vers une machine virtuelle préparée pour la compilation pour plus d’efficacité.

 

Merci à @Reaper pour son aide précieuse !

Topic à lock, merci ^_^ 

Edited by _Sufhal
Link to comment
Guest
This topic is now closed to further replies.


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.