Vous devez être connecté et donner une réaction ( Like ) au sujet pour débloquer les liens de téléchargements...

Question

Bonsoir, en voulant installer le système d'effet qui est disponible sur ce forum j'ai pas mal d'erreurs.. 

 

étant donner débutant je ne sais pas trop pourquoi.. quelqu'un pour m'aider ? merci 

 

Screen erreurs : 1533238861-caee.png

Edited by MeehmetYeeah

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Bonsoir,

 

Clique droit sur le projet UserIntarface -> Ajouter au projet -> Elements existants -> Selectionnes le .cpp et le .h et voilà.

 

Bonne soirée :)

Share this post


Link to post
Share on other sites
  • 0

Up : 

J'ai ces erreurs maintenant : Erreur    1    error C2065: 'vnum' : identificateur non déclaré    D:\Acer PC\Sources client2\Client\client\UserInterface\InstanceBase.cpp    2904    1    UserInterface
    2    IntelliSense : identificateur "vnum" non défini    d:\Acer PC\Sources client2\Client\client\UserInterface\InstanceBase.cpp    2905    29    UserInterface

 

Donc,

        if (!shiningdata.empty())
        {
            for (shiningit = shiningdata.begin(); shiningit != shiningdata.end(); shiningit++)
                DWORD vnum = pItem->GetIndex();
                if (shiningit->first == vnum)
                {
                std::string substr(shiningit->second);
                std::vector<string> chars;
                boost::split(chars, substr, boost::is_any_of("#"));
                for (std::vector<string>::size_type i = 0; i != chars.size(); i++)
                {
                    __AttachEffectToArmours(chars);
                }
            }
        }

 

 

Remarque : J'ai rajouter moi même :                 DWORD vnum = pItem->GetIndex(); pour essayer.. 


EDIT : J'ai pu finalement  compiler... Mais maintenant j'ai des erreurs syserr client :

0803 23:07:32152 :: CEffectManager::RegisterEffect - LoadScript(d:/ymir work/pc/common/effect/armor/aze_shining_white.mse) Error
0803 23:07:36985 :: CEffectManager::RegisterEffect - LoadScript(d:/ymir work/pc/common/effect/armor/aze_shining_red.mse) Error
0803 23:07:50102 :: CEffectManager::RegisterEffect - LoadScript(d:/ymir work/pc/common/effect/armor/aze_shining_red.mse) Error
0803 23:07:52874 :: CEffectManager::RegisterEffect - LoadScript(d:/ymir work/pc/common/effect/armor/aze_shining_red.mse) Error
0803 23:08:17455 :: CEffectManager::RegisterEffect - LoadScript(d:/ymir work/pc/common/effect/armor/aze_shining_white.mse) Error
0803 23:08:53245 :: CEffectManager::RegisterEffect - LoadScript(d:/ymir work/pc/common/effect/armor/aze_shining_red.mse) Error

Merci d'avance.

Edited by MeehmetYeeah

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.