Aller au contenu

Nouveau membre ?! Pense à te présenter pour accéder au contenu du forum !

New member ?! Introduce yourself to get access to the forum !

  • 0
Testuff

en cours Modifier la limite de vitesse des joueurs

Question

Version des fichiers/ Type d'émulateur : 2014

Domaine (Base de données, Client, Core...) : Core

Votre niveau (Débutant, Intermédiaire, Avancé..) : Débutant

 

Description du problème : Je souhaiterais pouvoir changer la limite de vitesse maximum de déplacement des joueurs avant le rollback

Comment reproduire le problème ? : Lorsque j'utilise le lion avec les bons bonus, le joueur subit des rollback. C'est également le cas avec le cheval noir 

Recherches et tests effectués : Modifier le char.cpp avec les limit de POINT_MOV_SPEED, mais aucun effet sur le rollback + de plusieurs heures de recherche sur le net.

 

merci à tous pour votre aide

 

Screenshot du problème concerné : NEANT

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le Règlement de Funky-Emulation.

Partager ce message


Lien à poster
Partager sur d’autres sites

6 réponses à cette question

Messages recommandés

  • 0

Salut !

 

input_main.cpp :

if (((false == ch->IsRiding() && fDist > 25) || fDist > 40) && OXEVENT_MAP_INDEX != ch->GetMapIndex())

 

Remplace 25 pour la vitesse à pied et 40 pour la vitesse sur monture.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Merci pour cette super réponse, je teste ça ce soir.

 

Tu aurais une idée des valeurs à mettre pour ne pas bugger avec le lion en monture, stp ?

 

merci à toi

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Vérifie déjà que le mob (le vnum du mob) utilisé pour le Lion redirige sur le bon dossier dans ton mob_proto.

Plusieurs cas démontrent qu'un mauvais chemin d'accès au dossier de la monture crée des rollbacks car les données

sont mal traitées.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Posté(e) (modifié)

Désolé, je suis vraiment débutant, je n'ai pas compris ce que tu viens de me préciser, stp ?

 

Effectivement le changement ne donne rien pour le lion et le cheval noir.

 

Pour info j'utilise les files 2016 optimisé de la teamFE par Saw => 

Je viens de remarquer que ce problème de rollback n'existe pas sur la version files 2016 de la teamFE avant l'optimisation :

J'ai essayé d'inverser les mob_proto.txt entre les versions optimisé et non optimisé et ça ne change rien

 

J'ai gardé le même client pour tous les tests, donc ce la ne vient pas du client

Modifié par Testuff

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Probleme, visiblement résolu, j'ai supprimer ce qu'il y avait dans la colonne "folder" du mob_proto.txt pour les montures qui créées des rollback.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Posté(e) (modifié)

C'est ce que je disais, vérifie que le mob pointe sur le bon folder.

 

Edit:

Du coup, je classe le sujet :).

Modifié par Kameyu

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×

Information importante

By using this site, you agree to our Conditions d’utilisation.