Jump to content
×
×
  • Create New...
  • 0

Modifier la limite de vitesse des joueurs


Testuff
 Share

Question

Version des fichiers/ Type d'émulateur : 2014

Domaine (Base de données, Client, Core...) : Core

Votre niveau (Débutant, Intermédiaire, Avancé..) : Débutant

 

Description du problème : Je souhaiterais pouvoir changer la limite de vitesse maximum de déplacement des joueurs avant le rollback

Comment reproduire le problème ? : Lorsque j'utilise le lion avec les bons bonus, le joueur subit des rollback. C'est également le cas avec le cheval noir 

Recherches et tests effectués : Modifier le char.cpp avec les limit de POINT_MOV_SPEED, mais aucun effet sur le rollback + de plusieurs heures de recherche sur le net.

 

merci à tous pour votre aide

 

Screenshot du problème concerné : NEANT

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le Règlement de Funky-Emulation.

Link to comment
Share on other sites

  • Answers 6
  • Created
  • Last Reply

Top Posters For This Question

6 answers to this question

Recommended Posts

  • 0
  • Developer

Salut !

 

input_main.cpp :

if (((false == ch->IsRiding() && fDist > 25) || fDist > 40) && OXEVENT_MAP_INDEX != ch->GetMapIndex())

 

Remplace 25 pour la vitesse à pied et 40 pour la vitesse sur monture.

Link to comment
Share on other sites

  • 0
  • Developer

Vérifie déjà que le mob (le vnum du mob) utilisé pour le Lion redirige sur le bon dossier dans ton mob_proto.

Plusieurs cas démontrent qu'un mauvais chemin d'accès au dossier de la monture crée des rollbacks car les données

sont mal traitées.

Link to comment
Share on other sites

  • 0

Désolé, je suis vraiment débutant, je n'ai pas compris ce que tu viens de me préciser, stp ?

 

Effectivement le changement ne donne rien pour le lion et le cheval noir.

 

Pour info j'utilise les files 2016 optimisé de la teamFE par Saw => 

Je viens de remarquer que ce problème de rollback n'existe pas sur la version files 2016 de la teamFE avant l'optimisation :

J'ai essayé d'inverser les mob_proto.txt entre les versions optimisé et non optimisé et ça ne change rien

 

J'ai gardé le même client pour tous les tests, donc ce la ne vient pas du client

Edited by Testuff
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.