Aller au contenu

Nouveau membre ?! Pense à te présenter pour accéder au contenu du forum !

New member ?! Introduce yourself to get access to the forum !

  • 0
Hunk

en cours [Résolu] Serveur Hamachi, Accès refuser via navicat

Question

Posté(e) (modifié)

Bonsoir,

 

J'ai un problème concernant mon serveur hamachi, tout est correctement fait, mais, quand je veux me connecté sur le navicat ça me met un message d'erreur :

"1045 - Access denied for user........ (using password: YES)".

 

En espérant qu'une personne aura la solution.

Modifié par Kameyu

Partager ce message


Lien à poster
Partager sur d’autres sites

14 réponses à cette question

Messages recommandés

  • 0

C'est juste que tu t'es trompé de mot de passe.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Pourtant j'ai utilisé tout les mdp, j'ai utilisé le client et le vdi du tuto pour un serveur hamachi.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Hamachi ne fonctionne pas pour les dernières SF Metin2, c'est soit en localhost, soit avec un dédier,
 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Et mon erreur viens d'où ? parce que je vois pas du tout d'où ça peut venir.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

tu utilise quel VM ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

j'utilise oracle VM virtual box

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

J'ai pas dit le logiciel mais la VM que tu utilise le .vdi

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Serveur Metin2.vdi celui du tuto pour un serveur hamachi

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Sinon pour un serveur hamachi tu as d'autre VDI de disponible je pense aux VDI des files 2016 et 2014 que Saw a partagé et qui fonctionne bien et pour un débutant c'est suffisant 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Sinon tu vas sur ta VM, tu reset ton password mysql, cherche sur internet du trouveras comment le changer.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

D'accord, je vais faire ça, merci.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Tu as réussi à résoudre ton probleme ? Parce que j'ai le meme j'ai tout essayer impossible ma couille

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Posté(e) (modifié)

Si vous êtes sûrs que votre mot de passe est correct (car vous l'avez vous-même créé par exemple, ) mais que vous obtenez cette erreur:

 

Citation

1045 - Access denied for user........ (using password: YES)

 

C'est que le blocage ne provient pas du mot de passe.

Un accès refusé peut se manifester également lorsque l'adresse IP qui souhaite se connecter au serveur n'est pas explicitement autorisée dans la liste des utilisateurs.

Par exemple, un utilisateur défini comme: 'root'@'%' pourra se connecter via n'importe quelle adresse IP (le '%' étant un masque d'adresse IP signifiant "toutes directions").

 

Essayez de créer un utilisateur via le compte mysql local:

[email protected]# mysql -u mt2 -p [email protected]#
[email protected]# mysql -u mt2 -p epv4minq
(normalement, vous avez l'un ou l'autre qui devrait marcher)

Une fois connecté en local, vous avez deux options:

1) Créer un utilisateur qui acceptera toute adresse IP entrante ( avec le '%' )

2) Créer un utilisateur pour vous seul (avec une IP entrante prédéfinie)

/!\ Attention /!\ en revanche, si votre IP Hamachi change, vous perdrez l'accès car votre nouvelle IP ne sera pas acceptée avec l'option 2.

 

Pour ce faire, une fois connecté au serveur mysql:

CREATE USER  'ID'@'IP_HAMACHI' IDENTIFIED BY 'VOTRE_MOT_DE_PASSE';
GRANT ALL PRIVILEGES ON *.* TO 'ID'@'IP_HAMACHI' WITH GRANT OPTION;
FLUSH PRIVILEGES; #Juste au cas où, mais ce n'est pas nécessaire.

Bien entendu, vous remplacerez "ID" par l'identifiant que vous désirez utiliser pour vous connecter à MySQL, "VOTRE_MOT_DE_PASSE" par votre mot de passe (évidemment)

ainsi que "IP_HAMACHI" par votre IP Hamachi. Si vous souhaitez l'option 1, pour pouvoir vous connecter depuis n'importe quelle IP, mettez juste un % à la place de IP_HAMACHI

comme ceci par exemple:

CREATE USER 'Kameyu'@'%' IDENTIFIED BY '123456789011223344';

Si ça ne marche toujours pas, c'est que vous avez mal configuré vos paramètres réseau.

 

La bise!

Modifié par Kameyu

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Hello @Hunk,

 

L'information de @AriusII n'est malheureusement pas erroné.

Tu n'auras aucun problème à lancer ton serveur Metin2 sur Hamachi avec des files récentes (> 2012) et de t'y connecter. Cependant, les personnes externes à ton réseau ne pourront pas (déco à la section des personnages)

La structure actuelle ne le permet pas et même après avoir cherché et cherché avec @Kijaru, on a rien trouvé de bien fonctionnel. Un problème d'IP à ce que j'ai compris.

 

Si tu trouves la solution un jour, n'hésite pas à nous la partager !

Sinon pour ton problème MySQL, @Kameyu.

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×

Information importante

By using this site, you agree to our Conditions d’utilisation.