Aller au contenu

Nouveau membre ?! Pense à te présenter pour accéder au contenu du forum !

New member ?! Introduce yourself to get access to the forum !

  • 0
Link

en cours Chat inter royaume files 2014 bug

Question

Bonjour à tous,

 

J'ai un problème quand j'essaie d'implanter le chat inter royaume sous files 2014 vierge j'utilise celle de la VM optimisé de @#Saw quand je met mon bout de code qui est le suivant dans mon input_man.cpp 

 

		if(global_chat)
		{
			const char* kingdoms[3] = { "|cFFFF0000[Shinsoo]|r", "|cFFFFFF00[Chunjo]|r", "|cFF0080FF[Jinno]|r" };
			const char * GMs = "|cFFFFC700[Team]|r";
			const char * GMIMPLEMENTOR = "|cFFAA51A4[STAFF]|r";
			char chatbuf_global[CHAT_MAX_LEN + 1];
			if (ch->GetGMLevel() == GM_PLAYER)
			{
				snprintf(chatbuf_global, sizeof(chatbuf_global), "%s %s", kingdoms[ch->GetEmpire() - 1], chatbuf);
			}
			else if (ch->GetGMLevel() == GM_IMPLEMENTOR)
			{
				snprintf(chatbuf_global, sizeof(chatbuf_global), "%s %s", GMIMPLEMENTOR, chatbuf);
			}
			else
			{
				snprintf(chatbuf_global, sizeof(chatbuf_global), "%s  %s", GMs, chatbuf);
			}

			TPacketGGShout p;
			
			
			p.bHeader = HEADER_GG_SHOUT;
			p.bEmpire = ch->GetEmpire();
			strlcpy(p.szText, chatbuf_global, sizeof(p.szText));
			
			
			P2P_MANAGER::instance().Send(&p, sizeof(TPacketGGShout));
			

			SendShout(chatbuf_global, ch->GetEmpire());
			

			return (iExtraLen);
		}
	}

A la compilation il me dit que il y a une erreur qui est celle ci:

 

input_main.cpp: In member function 'int CInputMain::Chat(CHARACTER*, const char*, size_t)':
input_main.cpp:744: error: 'global_chat' was not declared in this scope
gmake: *** [Makefile:130: OBJDIR/input_main.o] Error 1
gmake: *** Waiting for unfinished jobs....
[email protected]:/usr/src/mainline/Srcs/Server/game/src #

 

Si quelqu'un pourrai m'aider car la je bloque :/

 

Merci d'avance,

 

Cordialement, Link.

Modifié par Link

Partager ce message


Lien à poster
Partager sur d’autres sites

5 réponses à cette question

Messages recommandés

  • 0

EDIT: J'ai plus les erreurs, j'ai déclarer les fonctions dans le config.cpp et config.h mais quand j'écris en IG entre les royaumes personnes ne vois les écritures la ligne est bien déclarer dans les CONFIG des files pourtant :/ 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Sujet a lock problème résolue, on peut compter que sur sois même.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

En même temps, c'est vendredi soir, il est 17h40, donc clairement les gens sont soit encore au boulot, soit dans les transports, maintenant si tu nous paie des chauffeurs privés ça nous enlèvera le problème de la conduite et on pourra répondre sereinement à tes topics ;)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

MDRRR. Tu me fais rire quand même. 

Y'a certains problèmes que j'ai pu rencontrer et qui m'ont fait attendre 4 jours une réponse et pourtant, j'suis rester patient et j'me plains pas. Toi tu attends 2 petites heures et tu arrives encore à pleurer. 

De plus si tu utilises les files optimisée de Saw c'est les files 2016 et le chat inter royaume est déjà présent dessus. (Sauf erreur de ma part). Bref... Passons :) 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Sans commentaire..

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×

Information importante

By using this site, you agree to our Conditions d’utilisation.