• 0
dyr924

en cours [Résolu]Gameserver will not run.

Question

1.

1.PNG%22%20width=%22740%22%20height=%225

 

2.

3.PNG%22%20width=%22740%22%20height=%224

 

3.

2.PNG%22%20width=%22740%22%20height=%225

 

 

Look at the picture above.
You can see that there are many quest, no items that are wrong.
"Gameserver.exe" will not run with this error.
Why are you doing this?

 

Thank you^^

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
Guest

Hi,

 

Some parts of the server files are not debug yet, but this is supposed to work anyway.

 

Please use Notepad ++ for configuration files edition, the Windows Notepad causes issues with some files.

 

Can you upload me the latest mlog.txt of your game server?

Share this post


Link to post
Share on other sites
  • 0
Guest

As far as i see, i have the same errors but my server is launching.

 

If you can, try to compile the GameServer from the sources, to see if it fixes the problem.

 

Edit: Problem found, it seems that it comes from the system/Strings/abuse.txt file, which has an incorrect encoding / EOL.

 

Open the file in Notepad++, go to Edit->End of Line -> Switch the end of line type to Windows type, and it should work.

 

Edited by Kijaru

Share this post


Link to post
Share on other sites
  • 0

je croie avoir le même problème peux t on m'aider 

après il ce ferme 

 

j ai bien éditer avec notpad ++

merci

pangya16.jpg

Share this post


Link to post
Share on other sites
  • 0

Thank you!!

 

But there was a problem.
The game server works, but if you look at the login server,
Does not make All start.
And when you enter your ID and password in the game,
A message window appears.
" Server is running. Please send connecting with la-ter "

 

11.PNG%22%20width=%22740%22%20height=%22

Share this post


Link to post
Share on other sites
  • 0
Guest

  @vegetax

Tu peux m'uploader les derniers mlog.txt pour ton gameserver et masterserver ?

 

@dyr924

Can you check in the Database Account the tables world and server and send a screenshot of what they look like?

 

Share this post


Link to post
Share on other sites
  • 0
Guest
il y a 1 minute, vegetax a dit :

voila pour toi @Kijaru https://mega.nz/#!EXpT2JyZ!Pkrn1_D2L8kmP51F-sqACwhR73liYxBUVFLJqFtns6A

 A priori la manip que tu as fait sur le txt n'a pas marché.

 

Pour vérifier, fais comme sur le screen suivant, clique sur le bouton des caractères non imprimables, et vérifie que tu aies bien les deux symboles CR et LF à la fin des lignes.

http://prntscr.com/hwvtau

 

Si ça ne marche toujours pas, fais la même manipulation sur le abuse_PWE.txt.

Share this post


Link to post
Share on other sites
  • 0

ID and password were tested.

I have not yet created ID and password.
Can you tell me how to make it?

Edited by dyr924

Share this post


Link to post
Share on other sites
  • 0
Guest
il y a 2 minutes, vegetax a dit :

le fichier et bien abuse_db.txt ? 

 

Non, le fichier c'est system/string/abuse.txt, situé dans le dossier GameServer.

Share this post


Link to post
Share on other sites
  • 0
Guest
il y a 14 minutes, dyr924 a dit :

ID and password were tested.

I have not opened an account yet.
Can you tell me how to make it?

 

You can follow this tutorial to create your account:

 

Share this post


Link to post
Share on other sites
  • 0
Guest
il y a 4 minutes, vegetax a dit :

ok voila j ai le LF mais pas le CR

 

je te laisse appliquer la procédure que j'ai mis pour dyr924 et ça devrait aller mieux ;)

Share this post


Link to post
Share on other sites
  • 0
Guest
il y a 5 minutes, vegetax a dit :

ben écoute j ai fait comme tu a dit et rien il ce coupe après 

 

Vérifie que tu as bien LR et CF sur le abuse.txt, et si oui, fais la même procédure pour le abuse_PWE.txt.

penses à bien fermer les serveurs, faire les modifications, enregistrer, et ensuite seulement relancer les serveurs.

Share this post


Link to post
Share on other sites
  • 0

I created an account the way you told me.
However, the same error still occurs.
" Server is running. Please connect with la-ter "

Share this post


Link to post
Share on other sites
  • 0
Guest
il y a 1 minute, dyr924 a dit :

I created an account the way you told me.
However, the same error still occurs.
" Server is running. Please connect with la-ter "

 

Can you check in the Database Account the tables world and server and send a screenshot of what they look like?

Share this post


Link to post
Share on other sites
  • 0

je n 'arrive pas a avoir le CF sur les fichier txt

 

voila ceux que j ai 

 

 d z i w k LF
3zoom LF
3zoom.com LF

abschaum LF
abschei©¬er LF

Edited by vegetax
Exemple que j ai

Share this post


Link to post
Share on other sites
  • 0
Guest
il y a 21 minutes, dyr924 a dit :

111.PNG%22%20width=%22740%22%20height=%2

 

 

222.PNG%22%20width=%22527%22%20height=%2

 

Here^^

 

Then the problem comes from the database which is not updated properly.

If you can wait a couple hours i'll release a server launcher that should fix the problem.

 

Share this post


Link to post
Share on other sites
  • 0
Guest
il y a 5 minutes, vegetax a dit :

je n 'arrive pas a avoir le CF sur les fichier txt

 

Il faut aller dans le Notepad++, puis dans Edition->Convertir les fins de ligne -> Windows

Share this post


Link to post
Share on other sites
  • 0

ok super cela fonctionne MERCIIIII

 

maintenant autre problème mon client ce ferme directement ( je suis sur Win10 )

Share this post


Link to post
Share on other sites
  • 0
Guest
il y a 18 minutes, vegetax a dit :

ok super cela fonctionne MERCIIIII

 

maintenant autre problème mon client ce ferme directement ( je suis sur Win10 )

 

Tu as bien installé les redistribuables?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.