Aller au contenu

Nouveau membre ?! Pense à te présenter pour accéder au contenu du forum !

New member ?! Introduce yourself to get access to the forum !

Question

Bonjours, Je présente mon problème.

J'ai recensement demander dans les aide pour un bug ou je ne sais trop quoi a propos du mdp de Navicat, ont ma donner le code la qui a fait que sa fonctionner.

 

/usr/local/etc/rc.d/mysql-server stop

mysqld_safe --skip-grant-tables &

mysql -u root

use mysql;

update user set password=PASSWORD('Ton mdp') where user='root';

flush privileges;

quit


service mysql-server restart

 

Mais a chaque fois que je redemarre mon serveur je peut pas me connecter avec le nouveau mots de passe fourni je suis obliger de retaper cette commande dans VirtualBox pour que ca fonctione

 

Help plz 

Partager ce message


Lien à poster
Partager sur d’autres sites

19 réponses à cette question

Messages recommandés

  • 0
il y a 13 minutes, Taiqo a dit :

update user set password=PASSWORD('Ton mdp') where user='root';

Bonsoir,

update user set password=PASSWORD('A Remplace Ton Nouveau Mot de passe') where user='root';

 

des que tu termines la commande tu reboot le serveur !

Modifié par FrancH

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

c'est ce que j'ai fait mais sa fonctionne pas.. a chaque fois que je reboot je suis obliger de retape la commande.. 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

/usr/local/etc/rc.d/mysql-server stop

/etc/rc.d/init.d/mysql stop

mysqld_safe --skip-grant-tables &

mysql -u root

use mysql;

update user set password=PASSWORD(" Ton Nouveau Mot de passe ") where User='root';

flush privileges;

quit

/usr/local/etc/rc.d/mysql-server stop

/usr/local/etc/rc.d/mysql-server start

mysql -u root -p

(Ton nouveau mot de passe)

reboot

Modifié par FrancH

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Une simple question mon mot de passe je le met bien la ou il y a "PASSWORD" ? ou dans les parenthése? 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Parenthèse

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

dans les parenthèse

update user set password=PASSWORD(" Ton Nouveau Mot de passe ") where User='root';

mais la non => tu écris seulement ton nouveau mot de passe

il y a 7 minutes, FrancH a dit :

(Ton nouveau mot de passe)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Ah ok, je vais voir ca alors merci je vous tient au courant si jamais sais bon j'editerai 

Merci bcp 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Toujours, pas quand je met mon nouveau mots de passe a la fin de la commande, il me dit acces denied etc.. ><

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Au pire, supprime MySQL et réinstalle le au propre.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bah meme en refaisant tous a zero sa fonctionne pas.. donc chepas comment mais vrement pas la :x

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Tu utilies quel vm et quel file

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

VirtualBox avec les files 1012

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Connecte toi à MySQL sur VirtualBox et fais cette commande:

 

SELECT host, user, password FROM mysql.user;

 

Et screen nous le résultat

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Je peut pas screen quand je fait la touche pour screen, sa reboot le serveur..

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

L'installation de la vm a du être farfelu, essaye de dl la vm des files 2014 partagé, et tu remplace juste les files par ceux de ta vm

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bah c'est la vm des files 2014 que j'ai et j'ai installer directement les files 2012 dessus.. le seul probleme que j'ai sais navicat sinon tous fonctionne parfaitement..

 

Voila le screen avec la commande demander.. 

http://hpics.li/17a3266

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bah si tu utilises là VM que j'ai partagé tu n'as pas besoin d'effectuer toutes ces commandes, MySQL fonctionne déjà

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Oui, mais Navicat veut pas me faire acceder a mes table , il me dit Acces Denied.. Pourtant tous est configurer comme dans le topic.. 

J'ai utiliser le topic Calipso avec No-Ip.. 

Modifié par Taiqo

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Ce que tu fais, c'est que tu te connectes à mysql sur Virtualbox. Tu fais cette commande:

 

GRANT ALL PRIVILEGES ON *.* TO 'funky'@'%' IDENTIFIED BY 'emu' WITH GRANT OPTION;

 

Ensuite tu fais:

 

flush privileges;

 

Et essaie de te co à navicat avec ces identifiants:

 

Login: funky

Mot de passe: emu

 

Ca devrait le faire. 

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×

Information importante

By using this site, you agree to our Conditions d’utilisation.