Aller au contenu

Nouveau membre ?! Pense à te présenter pour accéder au contenu du forum !

New member ?! Introduce yourself to get access to the forum !

  • 0

Question

Bonjour.

 

J'ai une nouvelle question à vous poser aujourd'hui (oui encore)  :*)

 

Alors voilà, j'ai remarqué que ça arrivait sur certaines map sur certains serveurs mais cela ne me gênait pas étant donné que je ne n'étais pas concerné jusqu'à hier. Je m'explique.

Le problème est que j'ai créer une map (en grand flemmard invétéré que je suis j'ai prit le nom et la base position d'une map déjà existante que j'ai remplacé par celle faite par mes soins). L'accès à cette dernière est via une quête qui reste constamment affiché du style les quêtes de statistique si vous ne voyez pas ce que je veux dire.

Donc on clique sur la quête on dit qu'on veut être TP à la map et on y est TP dans une safezone, jusque là rien d'anormal. Ensuite pour être téléporté dans la zone de combat il faut faire la même manœuvre via la même quête sur laquelle j'ai mis une restriction selon le map index, genre si t'es pas sur la map ça te tp safezone, si t'es sur la map ça te tp zone de combat. Tout était fonctionnel jusqu'à hier. Lorsque je suis sur la map et que je demande à être TP zone de combat, la TP s'opère sauf qu'immédiatement après être arrivé sur la zone de combat, le personnage est re-TP automatiquement dans la safezone. J'aimerais savoir à quoi cela est dû et surtout comment régler ce petit problème.

 

EDIT : Je viens de remarquer que la tp-auto redirige immédiatement aux coordonnées du Town.txt, même lors de la TP de base à la map sur la safezone, ça ne me met pas aux coordonnées entrées dans la quête, ça me re-dirige immédiatement aux coordonnées locale de la map mise dans mon town.txt

 

EDIT 2.0 :hehe: : Même si je fais un /warp avec un perso GM à n'importe quel endroit de la map, je suis redirigé vers les coordonnées du town.txt

 

Je vous remercie d'avance pour votre aide et je reste disponible si vous avez besoin d'information supplémentaire pour être en mesure de me donner des réponses.

 

Sincère considération.

Partager ce message


Lien à poster
Partager sur d’autres sites

18 réponses à cette question

Messages recommandés

  • 0

Faudrait peut être nous donner plus d'informations sur ta MAP, Coordonnées, Quêtes si tu veux que quelqu'un puisse t'apporter une aide ^^

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

j'ai pas compris ta quête xD ( la fin ) a partir de elseif a == 1 ....

 

ça te tp 2x une fois a 85500, 2500

 

une autre fois a 89200, 6000

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

en gros le premier elseif permet de TP le joueur map pvp si son map index est différent de celui de la map pvp, le deuxième, permet, une fois sur la map pvp d'être tp dans la zone de combat si le joueur reclique sur la même quête

Mais comme je l'ai dit le problème ne vient probablement pas de là puisque ça fonctionnait jusqu'à hier (quête que j'ai faite il y a plus d'un mois)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Pourtant ça vient bien de la structure de ta quest

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

bah moi je vois que ça te tp juste 2x de suite

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Vérifie que t'aies pas un conflit de quête.

Genre, deux quêtes qui te téléportent pour les mêmes raisons mais à des endroits différents.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Déjà vérifié, j'ai vérifié aussi si ça venait pas d'un logout begin avec un warp() mais non, ça ne vient pas de là non plus, j'ai essayé en faisant une quête basique en reprenant celle du téléporteur en changeant juste les coordonnées et c'est pareil, redirection immédiate au coordonnées du town.txt et @"Jafar" pour la quête elle ne TP pas 2x de suite, elle TP premièrement sur la safezone de la map, et une fois sur cette map, si tu relances la même quêtes, là elle va te tp zone de combat, d'où la restriction par le map index.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Change tes BasePosition pour voir si le problème le vient pas de là.

 

Ce qui est bizarre c'est que ça te fasse ça "du jour au lendemain", tu as certainement modifié quelque chose sans le vouloir, ou

compilé d'anciens fichiers sans t'en rendre compte.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Et bein disons que j'ai eux un gros gros bug à cause d'un upgrade, le serveur crashait et tout  et ça nous a prit près d'une semaine pour régler le problème. Une fois le bug réglé ça fonctionnait toujours nickel et ça a commencé à ne plus marcher à peu près en même temps que quand j'ai commencé à faire mon patcher.

Ce qui est galère c'est que même sans la quête ça ne marche pas, all warp ou go sur cette map sont redirigé aux coordonnées du town.

Je vais essayer de changer mes baseposition je vous tiens au courant.

 

EDIT : ce qui est étonnant c'est que la map/la quête/le town/la BasePosition sont identiques à ceux de mon serveur test, et sur ce dernier je n'ai aucun bug, enfin pas de redirection automatique quoi, c'est ça qui est étonnant

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

problème toujours présent après modification de la BasePosition

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

T'as pas regardé dans tes syserr/log pour voir si quelque chose n'allait pas ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

sauvegarde ta quête, et ensuite enlève le 2ème elseif a == 1 and pc.get ....

 

et essaye comme ça

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Déjà essayé aussi, j'ai même test sans quête d'aller via les coordonnées globales idem ça re TP au town, et rien dans les syserr/log non plus

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Je ne sais plus ce qu'il se passe lorsque deux maps se superpose, ça ne serait pas ça le problème ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Je ne sais pas du tout, comment ça "deux maps qui se superpose", parce que à la base ouai j'ai implanté ma map sur a la place d'une map déjà existante, la map qui s'appelle "gm_guild_build"

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Quand deux maps se superpose c'est quand les coordonnées se chevauchent..

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Il n'y avait pas de superposition ni rien, comme je l'ai dit au début, le bug est sorti de nul part, sans aucune raison, et il est reparti exactement de la même manière.. Je n'ai n'y explication ni réponse à mes questions, le problème est apparu et s'est résolu sans aucune raison valable..

Enfin bref, toujours utile que je vous remercie pour vos réponses.

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×

Information importante

By using this site, you agree to our Conditions d’utilisation.