Aller au contenu
Funky-Emulation Recrute
  • 0
VorGam

en cours Problème création de guilde

Question

Bonjour à tous,

 

J'ai un soucis quand je créer une guilde le serveur me dit que la guilde est belle est bien créée sauf que le nom de la guilde apparait pas au dessus de la tête du personnage, pourquoi ?

 

Si quelqu'un pourrai m'aider sa serais super merci :P

 

voici les screens:

 

IG: http://prntscr.com/ft7875 - http://prntscr.com/ft7895

bdd: http://prntscr.com/ft78ff

syserr client: http://prntscr.com/ft78co

 

syserr db: SYSERR: Jul 8 19:49:18.851740 :: DirectQuery: AsyncSQL::DirectQuery : mysql_query error: Column 'name' in field list is ambiguous

query: SELECT empire, pid, name, money, windate FROM monarch a, player b where a.pid=b.id

SYSERR: Jul 8 19:53:03.197938 :: DirectQuery: AsyncSQL::DirectQuery : mysql_query error: Duplicate entry '2' for key 'pid'

query: INSERT INTO guild_member VALUES(2, 4, 1, 0, 0)

SYSERR: Jul 8 19:53:03.223946 :: GuildAddMember: Query failed when getting guild member data SELECT pid, grade, is_general, offer, level, job, name FROM guild_member , player WHERE guild_id = 4 and pid = id and pid = 2

 

Cordialement.

Partager ce message


Lien à poster
Partager sur d’autres sites

12 réponses à cette question

Messages recommandés

  • 0

Stop ton serveur, efface le contenu des tables "guild" "guild_comment" "guild_grade" "guild_war" "guild_member" "guild_war" "guild_war_bet" "guild_war_reservation", relance ton serveur et réessaye et dit moi.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Aucun rapport ^^' les tables sont pas défaut vide quand tu n'as aucune guilde donc le soucis n'est pas là ^^

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Non j'ai plus de syserr coté serveur

 

client j'ai sa:

 

0708 18:40:46133 :: Unknown packet header: 12, last: 75 75

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

As-tu fais une modification au niveau de tes sources? car on dirait que ton game/db ne sont pas en accord avec ton lanceur.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Yep un problème de paquets, en gros ton serveur envoi un paquet sauf que ton client est incapable de savoir à quoi cela correspond. Conséquence il crash. Le problème du début je te l'ai fais corrigé, maintenant il faut savoir ce que tu as modifié au niveau source ^^

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×

Information importante

By using this site, you agree to our Conditions d’utilisation.