Aller au contenu

Nouveau membre ?! Pense à te présenter pour accéder au contenu du forum !

New member ?! Introduce yourself to get access to the forum !

  • 0
Daymortel

en cours Problèmes d'implantation de costumes

Question

Salut

 

Version des files : 2016

Domaine (Base de données, Core, etc.) : Implantation de costumes

Votre niveau (débutant, intermédiaire, avancé) : Intermédiaire

 

Description du problème : Quand j'essaye d'implanter des nouveaux costumes, je rencontre quelques problèmes : Les costumes de Noël 2016 sont toutes blanche alors que je n'ai pas fait d'erreur de texture (j'ai bien regardé), les costumes de 2 couleurs différentes sont de la même couleur, et on ne voit pas les casques quand on les portes ...

Comment reproduire le problème :

Recherches et tests effectué :

Résultat des recherches et tests :

 

Message d'erreur, capture d'écran :

0319 18:05:10608 :: Traceback (most recent call last):

 

0319 18:05:10608 ::   File "ui.py", line 1505, in OnOverInItem

 

0319 18:05:10608 ::   File "ui.py", line 88, in __call__

 

0319 18:05:10609 ::   File "ui.py", line 79, in __call__

 

0319 18:05:10609 ::   File "uiInventory.py", line 1049, in OverInItem

 

0319 18:05:10609 ::   File "uiInventory.py", line 1293, in ShowToolTip

 

0319 18:05:10609 ::   File "uiToolTip.py", line 582, in SetInventoryItem

 

0319 18:05:10609 ::   File "uiToolTip.py", line 1022, in AddItemData

 

0319 18:05:10609 ::   File "uiToolTip.py", line 1439, in __AppendHairIcon

 

0319 18:05:10610 ::   File "uiToolTip.py", line 268, in ResizeToolTip

 

0319 18:05:10610 ::   File "ui.py", line 1924, in SetSize

 

0319 18:05:10610 :: RuntimeError

0319 18:05:10610 :: : 

0319 18:05:10610 :: Failed to load image (filename: icon/hair/45258.sub)

0319 18:05:10610 :: 

 

0319 18:05:20123 :: CreateFromMemoryFile: Cannot create texture

0319 18:06:27191 :: CreateFromMemoryFile: Cannot create texture

0319 18:06:42574 :: CreateFromMemoryFile: Cannot create texture

0319 18:06:48725 :: CreateFromMemoryFile: Cannot create texture

0319 18:10:57536 :: CreateFromMemoryFile: Cannot create texture

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le règlement des demandes d'aides.

Partager ce message


Lien à poster
Partager sur d’autres sites

14 réponses à cette question

Messages recommandés

  • 0

Je ne suis pas sûr, peux tu indiquer le contenu de icon/hair/45258.sub ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Je ne trouve pas icon/hair/45258.sub ...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Voilà tu as la réponse à ta question, il te manque en ce moment un fichier ;)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Ça ne vient pas de là, car il n'y est même pas sur le FR, et maintenant ça me sort 45071 ! Comment je dois faire pour voir les coiffes que j'implante quand je les portes ? Et pour les costumes blancs ? J'ai bien regardé plusieurs fois et il n'y a aucune erreur de texture ... Pourquoi sont-ils blancs alors ? Et comment je fais pour que le costume d'Halloween 2016, il y en ai un gris et un rouge, et non 2 gris ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Salut,

 

Premièrement, si, ça vient de là. Le système n'arrive pas à localiser la texture (Failed to load image (filename: icon/hair/45258.sub)) ce qui renvoie l'erreur de création de texture depuis la mémoire (CreateFromMemoryFile: Cannot create texture).

Deux solutions: tu vérifie que le .sub ou le .tga est là, et tu modifie le chemin de l'item_list pour qu'il aille chercher le fichier qui existe (ici, soit 45258.tga, soit 45258.sub).

 

Deuxièmement, un tutoriel a été fait sur ça, ça s'implante comme une armure, faut le mettre dans le MSM.

 

Troisièmement, si les costumes sont blancs, c'est que le jeu ne trouve pas la texture, donc soit elle n'est pas du tout dans ton client, soit elle est au mauvais endroit. Vérifié le chemin de la texture avec Granny Viewer (ouvre le .gr2 du costume et va dans l'onglet "Textures").

 

Quatrièmement, quand tu les a implanté, soit tu as laissé la texture de base, soit ut as utilisé le système de remplacement (SourceSkin/TargetSkin, il suffit de regarder comment ça marche sur d'autres costumes ou armures).

 

Bonne soirée,

 

Asius

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Le truc de couleurs est réglé, j'ai bien les 2 costumes de 2 couleurs différentes ... Et puis j'ai bien regardé, et il y a les textures au bon endroit avec le bon nom :/ C'est pour ça que je ne comprends pas ? Et puis les 2 fichiers .sub ne sont pas présents en icon/hair, donc comment je dois faire pour les créer ? Et pour les costumes blancs, je les ai pris sur le FR, cela aurait-il un rapport avec le fait qu'elles soient blanches ? Si c'est le cas, pourriez vous me donner les textures de l'armure de Noël 2016 SVP ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Pour les fichiers .sub, regarde si par hasard les icônes ne sont pas en .tga plutôt.

Si c'est le cas, tu as juste à remplacer .sub par .tga dans l'item_list

 

Rien à voir, le fait qu'ils soient blancs vient d'un problème de texture, elle est au mavia sendroit visiblement.

SI tu es sûr et certain qu'elle est au bon endroit, vérifie tes repack.

 

Désolé, je ne les ai pas du tout :/

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Utilise bien EterNexus.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Ben pourtant les coiffures sont bien mises dans l'item_list

item_list

45258 ETC icon/item/45258.tga

45259 ETC icon/item/45259.tga

45260 ETC icon/item/45260.tga

45261 ETC icon/item/45261.tga

41703 ETC icon/item/45703.tga

41701 ETC icon/item/45701.tga

41702 ETC icon/item/45702.tga

41700 ETC icon/item/45700.tga

 

Et puis pour les texture du costume de Noël 2016, j'ai regardé et reregardé, elles sont bien avec le bon nom et au bonne endroit ... Je vais cependant tester des les mettre directement dans PC/pc2 au lieu de dans le patch xmas, je vous redis ça ^^

A mon avis, ce sont les textures qui sont bug ^^ Si quelqu'un avait des textures des costumes de Noël 2016 qui marchent, je suis preneur ... Et pour les coiffes, je suis toujours à la recherche d'une solution ^^

Bonne soirée

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Je suis toujours à la recherche d'une solution à mon problème de costume de Noël 2016 tout blanc et des coiffes qu'on ne vois pas quand on les porte ... Car j'ai essayé de faire comme vous me l'avez dit, mais ça ne marche toujours pas ... bonne soirée !

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Hey , tes msm sont correct ? Si oui regarde bien ta value3 pour les coiffure du moins.

 

Pour ce qui est des costumes de Noël tout blanc as-tu bien remplis le msm pour chaque races ( sourceskin etc ...) ?

 

Si tu as tout fait correctement aurait-tu autres choses à signaler ?

As-tu ouvert le Gr2 avec granny voir ou était placé les textures ?

 

Cordialement, History.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Les costumes de Noël 2016 ne sont plus blancs, mais bien de la couleur souhaité, car un pote m'a donné d'autres textures ... C'était bien celles du FR qui buggaient ... Mais j'ai toujours le problème au niveau des coiffes ... Car elles ne se voient toujours pas ... J'ai pourtant bien regardé partout, et elles sont bien misent ... Peut-être qu'il y a un truc à faire pour les coiffes de spécial que je n'ai pas fait ... Mais quoi ? Merci pour votre aide et bonne journée ^^

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

Avez vous bien remplis les msm pour les coiffs ?

 

Cordialement, History.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

J'archive ! ♥

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×

Information importante

By using this site, you agree to our Conditions d’utilisation.