Jump to content
×
×
  • Create New...
  • 0

Problème SRVHamachi Erreur de la conn


MacDonarty

Question

Version des files : Files 2012

Domaine (Base de données, Core, etc.) : Virutal Box, Hamachi

Votre niveau (débutant, intermédiaire, avancé) : Débutant

 

Description du problème : J'ai installé le serveur avec VirutalBox et fait les bonnes configurations, en utilisant une adresse IP hamachi finissant par .100. Comme sur le tutoriel de Melissandre, j'arrive bien à me connecter sur WinSCP et Navicat, j'ai effectuer les modifications des fichiers CONFIG des Channels, de db et Auth. J'ai bien mes port de Port MAP en vert. J'ai effectuer l'installations du serveur en files 2012, le fichier tar.gz + la commande etc... tout ce passe bien pas d'erreur venant de la console. Je lance avec sh start etc... choisis le nombre de channel. Et quand je lance le lanceur metin2client du fichier client ExternalMT2 téléchargé en même temps que les files 2012 et les table SQL. Je tape mes ID et MDP créé sur Navicat, j'ai Erreur lors de la connexion.  J'ai regardé dans les Aides et Questions, et je n'ai pas trouvé de solutions au problème. Vous parlé d'un fichier serveurinfo.py mais je ne vois pas comment on l'obtient etc..

 

Faut-il que je change de lanceur, de client ? Comment obtenir le fichier serveurinfo.py ? J'ai bien vu qu'il faut mettre son ip mais personne ne dit comment l'avoir, sauf un tuto où on parle de dépack Local_fr mais où ? dans quoi etc.. ? ^^ 

 

Comment reproduire le problème : Relancer le client

Recherches et tests effectué : Revérification de la configuration carte réseau de la machine virtuelle, Acces par pont : LoGMein hamachi --> OK

IP dans sysintall --> OK  Connexion Win SCP --> OK Navicat --> OK, aucun probleme venant de la console. Hamachi bien ouvert --> OK.

Résultat des recherches et tests : Toujours la même erreur

 

Message d'erreur, capture d'écran : Erreur lors de la connexion.

 

Merci de votre compréhension. A bientôt et merci pour les tutoriels !!!

Link to comment

17 answers to this question

Recommended Posts

  • 0
  • Funkiest

Salut !

 

Ton erreur de connexion vient du serverinfo.py: c'est le fichier qui dit au client comment se connecter au serveur, s'il n'est pas bien rempli, tu ne pourras jamais te connecter ;)

Pour l'avoir, il faut décompresser, comme une archive, le pack root, qui se situe dans le dossier "pack" du client. Tu peux faire ça avec l'Eternexus: http://www27.zippyshare.com/v/91617093/file.html

Link to comment
  • 0

Ah mince d'accord, du coup je suis en train de re-télécharger le client 2012, je vais refaire le serveurinfo.py et ensuite je vais voir si ça me le refait j'essayerais.

 

Merci beaucoup. Dois-je laisser le serveurinfo.py dans le dossier ou root ou je dois le mettre à la racine avec le lanceur et tout ?

Link to comment
  • 0

Alors : 

 

J'ai réussis à le lancer avec le truc de compatibilité etc.... Ca me met aussi l'erreur sur des comptes qui n'existe pas : genre ID: greererere et mdp: 222222 = Erreur lors de la connexion.

De plus : je pense bien avoir configurer mes tables : Execute batch file je prend la table sql correspondante etc... pour chaque. Sauf une item_proto

Mais toujours la même erreur, voici mon serveurinfo.py :

 

import app

import locale

 

app.ServerName = None

if (locale.IsEUROPE() and app.GetLocalePath()):

STATE_NONE = '...'

 

STATE_DICT = {

0 : '....',

1 : 'NORM',

2 : 'BUSY',

3 : 'FULL' }

 

SERVER1_CHANNEL_DICT = {

1:{'key':11,'name':'CH1','ip':'25.61.0.100','tcp_port':13000,'udp_port':13000,'state':STATE_NONE,},

2:{'key':12,'name':'CH2','ip':'25.61.0.100','tcp_port':13001,'udp_port':13001,'state':STATE_NONE,},

3:{'key':13,'name':'CH3','ip':'25.61.0.100','tcp_port':13002,'udp_port':13002,'state':STATE_NONE,},

4:{'key':14,'name':'CH4','ip':'25.61.0.100','tcp_port':13003,'udp_port':13003,'state':STATE_NONE,},

5:{'key':15,'name':'CH5','ip':'25.61.0.100','tcp_port':13004,'udp_port':13004,'state':STATE_NONE,},

}

 

REGION_NAME_DICT = {

0 : 'TAIWAN',

}

 

REGION_AUTH_SERVER_DICT = {

0 : {

1 : { 'ip':'25.61.0.100', 'port':11002, },

}

}

 

REGION_DICT = {

0 : {

1 : { 'name' : 'Files 2012', 'channel' : SERVER1_CHANNEL_DICT, },

  },

}

 

MARKADDR_DICT = {

10 : { 'ip' : '25.61.0.100', 'tcp_port' : 13000, 'mark' : '10.tga', 'symbol_path' : '10', },

  }

 

TESTADDR = { 'ip' : '25.61.0.100', 'tcp_port' : 50000, 'udp_port' : 50000, }

Link to comment
  • 0

Alors j'ai réussis a corriger tout ça ! J'ai glisser item_proto dans player, j'ai repack root.

J'ai réussis à me connecter et voir mon ch1 en NORM ::)  J'ai fait un reboot et la quand je tape mes ID et MDP j'ai connexion en cours puis erreur lors de la connexion.......

 

POURQUOI ? ^^^

 

Merci !

Link to comment
  • 0
  • Funkiest

Alors là ...

Je sais qu'en files 2014 il y a des problèmes avec hamachi², je ne pensais pas qu'il y en avait aussi sur les anciennes files. je pense qu'Hamachi a un problème avec les jeux en ligne, avant presque tous les jeux étaient jouables avec, mais maintenant c'est devenu impossible de l'utiliser avec 99% des jeux ...

 

Éventuellement, tu peux passer en No-IP, ça ça marchera toujours ! :)

Link to comment
  • 0

Du coup j'ai commencé a refaire une machine, mais après le sysinstall dans la BDD je fais ifconfig mais je n'ai pas d'adresse commençant par 192.168.X.X du coup je ne peut pas me connecter a winSCP etcc 

J'ai bien changer et mis ma carte réseau à la place de LogMein hamachi. et j'ai bien refait une nouvelle machine et non juste modifier mon ancienne.

Que dois-je faire ?

Link to comment
Guest
This topic is now closed to further replies.


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.