Jump to content
×
×
  • Create New...
  • 0

Erreur 1130 avec Navicat


Victier

Question

Bonjour

 

J'essaie d'appliquer le tutoriel de Galet (Créer un environnement complet pour serveur metin2).

Tout est normalement paramétré, je souhaite ajouter les tables SQL.

 

Version des files : 2006

Domaine (Base de données, Core, etc.) : Navicat 

Votre niveau (débutant, intermédiaire, avancé) : Débutant

 

Description du problème :

J'essaie de me connecter à Navicat, mais je ne peux pas... j'ai cette erreur qui apparaît : Erreur 1130 - Host '192.168.0.10' is not allowed to connect to this MySQL server.

 

 

 

Recherches et tests effectué : Personne ne semble avoir eu ce problème sur le forum.

Pour le moment j'ai essayé de me connecter en laissant "localhost" mais aussi en utilisant l'IP du serveur.  J'ai essayé de me connecter avec un mot de passe personnel, mais également avec 16427rcl.

 

Si je laisse "localhost" j'ai cette erreur qui apparaît : 2003 - Can't connect to MySQL server on 'localhost' (10061)" J'en ai déduit que c'est avec l'IP du serveur que je pourrai me connecter.

 

 

Mais rien n'y fait, j'ai toujours cette erreur 1130...

 

 

J'ai trouvé ça sur internet : Si l’erreur ci-dessous se produit quand vous essayez de vous connecter à partir d’un autre hôte que celui sur lequel le serveur MySQL fonctionne, cela signifie qu’il n’y a pas de ligne dans la table utilisateur avec une valeur d’hôte qui corresponde à l’hôte client :

Host ... is not allowed to connect to this MySQL server

Vous pouvez résoudre ce problème en configurant un compte pour la combinaison du nom d’hôte du client et le nom d’utilisateur que vous utilisez quand vous essayez de vous connecter.

 

(http://wiki.navicat.com/fr/index.php/Erreur_1130)

C'est peut-être bien mon problème, mais ce qu'ils expliquent là reste flou pour moi...

 

Merci d'avance,

Et bonne journée !

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le règlement des demandes d'aides.[Message d'introduction]

59fb33980717d_Erreur1130.png.d4115f12a8ece489a7374da5fbcfdb16.png

59fb339823f73_Erreur2003.png.1d5d2d2af6c16b4433b3215a134731fe.png

Link to comment
  • Answers 2
  • Created
  • Last Reply

Top Posters For This Question

Popular Days

Top Posters For This Question

Posted Images

2 answers to this question

Recommended Posts

  • 0

Hellow, 

 

J'ai eu ce problème il y a fort longtemps mais je crois qu'il faut que tu crée un utilisateur avec tout les droit =)  car la l'erreur te dit clairement que l'utilisateur n'a pas les droit pour se connecter.

  • J'adore 1
Link to comment
  • 0

Ce que tu me dit correspond à ce que j'avais fais quelques minutes plus tôt. Du coup j'ai réitéré l'opération et cette fois-ci ça a fonctionné.

 

Comme indiqué dans le post de Galet :

 

 

  1. "GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED BY 'Entrez_ici_votre_mot_de_passe' WITH GRANT OPTION;"
  2. Puis : "GRANT ALL PRIVILEGES ON *.* TO 'mt2'@'localhost' IDENTIFIED BY 'epv4minq' WITH GRANT OPTION;"
  3. Tapez : "flush privileges;"
  4. Et pour finir : "quit".

Merci ^^

 

Bonne journée !

Link to comment
Guest
This topic is now closed to further replies.


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.