Jump to content
×
×
  • Create New...
  • 0

Probleme implantation switchbot


Bizarre

Question

[Message d'introduction]

 

Version des files : 2012

Domaine (Base de données, Core, etc.) : Client

Votre niveau (débutant, intermédiaire, avancé) : Debutant

 

Description du problème : j'ai suivit le tuto de Kijaru pour implanter le switchbot, mais une fois que je me connecte a mon serveur et que je lance mon personnage , la barre de chargement reste bloqué a la fin

Comment reproduire le problème : Aucune idée

Recherches et tests effectué : Verifier lettre par lettre et tab par tab ce que j'ai fais

Résultat des recherches et tests : negatif

 

Message d'erreur, capture d'écran : Client: http://prntscr.com/c3eekl

Sysser: http://prntscr.com/c3eews

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le règlement des demandes d'aides.

Link to comment
  • Answers 14
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

14 answers to this question

Recommended Posts

  • 0

Yo,

 

Visiblement, ça vient de ton system.py ligne 130 appelé par l'interfacemodule, tu as mal indenté un block à cette ligne, essaie de vérifier la définition de fonction / classe de cette ligne pour voir ;) petit conseil, le principe du scoping du python est que tu ouvre un scope avec des "deux points" ":" et que tout ce qui appartiennent à ces deux points doivent être une tabulation plus loin que cette instruction, en résumé :

 

def functionRandom: #Déclaration d'un nouveau scope
 print "hello"
#fin du scope

 

Donc techniquement il attend une instruction scopé mais tu ne lui fournis pas, donc pense aussi à vérifier les ":" déclarant que tu crée un nouveau scope.

Link to comment
  • 0

Yo,

 

Visiblement, ça vient de ton system.py ligne 130 appelé par l'interfacemodule, tu as mal indenté un block à cette ligne, essaie de vérifier la définition de fonction / classe de cette ligne pour voir ;) petit conseil, le principe du scoping du python est que tu ouvre un scope avec des "deux points" ":" et que tout ce qui appartiennent à ces deux points doivent être une tabulation plus loin que cette instruction, en résumé :

 

def functionRandom: #Déclaration d'un nouveau scope
 print "hello"
#fin du scope

 

Donc techniquement il attend une instruction scopé mais tu ne lui fournis pas, donc pense aussi à vérifier les ":" déclarant que tu crée un nouveau scope.

 

Voici ma ligne 130

newmodule = _process_result(compile(pack_file(filename,'r').read(),filename,'exec'),name)

Ou est l'erreur?

Link to comment
  • 0

Yo,

 

Visiblement, ça vient de ton system.py ligne 130 appelé par l'interfacemodule, tu as mal indenté un block à cette ligne, essaie de vérifier la définition de fonction / classe de cette ligne pour voir ;) petit conseil, le principe du scoping du python est que tu ouvre un scope avec des "deux points" ":" et que tout ce qui appartiennent à ces deux points doivent être une tabulation plus loin que cette instruction, en résumé :

 

def functionRandom: #Déclaration d'un nouveau scope
 print "hello"
#fin du scope

 

Donc techniquement il attend une instruction scopé mais tu ne lui fournis pas, donc pense aussi à vérifier les ":" déclarant que tu crée un nouveau scope.

 

Voici ma ligne 130

newmodule = _process_result(compile(pack_file(filename,'r').read(),filename,'exec'),name)

Ou est l'erreur?

 

peux-tu me pastebin ton code ? :)

Link to comment


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.