Jump to content
×
×
  • Create New...
  • 0

Problème installation apache


tibouni

Question

[Message d'introduction]

 

Version des files : FreeBSD 10.3 64bit

 

Votre niveau (débutant, intermédiaire, avancé) : débutant

 

Description du problème : J'ai suivi le tuto https://funky-emu.net/showthread.php?tid=48315&highlight=apache24 car celui que j'avais sur internet ne marchais pas mais j'ai toujours le même soucis lorsque je me connecte via internet sur le site celui ci n’interprète pas le php mais je ne sais pas pourquoi et je suis novice dans le domaine x)

 

Message d'erreur, capture d'écran : p><p> En postant ma demande d.[Message d'introduction]

Link to comment
  • Answers 19
  • Created
  • Last Reply

Top Posters For This Question

19 answers to this question

Recommended Posts

  • 0

Je connais bien ce souci j'ai fait quelques versions de freebsd xD

 

Alors pour commencer, désinstalle apache, php, les extensions (en gros recommence à zéro). 

 

pour installer apache et php ne tape pas les commandes que tu connais c'est à dire : 

cd /usr/ports/www/apache24
make install clean

cd /usr/ports/lang/php55
make install clean

cd /usr/ports/lang/php55-extensions
make install clean

 

Mais rentre cette commande : 

 

cd /usr/ports/www/mod_php55
make install clean

 

Ceci à pour but d'installer apache24, php55 et le module php qui va avec. 

Une fois l'installation terminée, tape cette commande : 

cd /usr/ports/lang/php55-extensions
make config

(séléctionne PDO, PDO MYSQL, MYSQL, SOCKET, ZLIB)

make install clean

C'est fini ! enfin presque. 

Il faut ensuite modifier ton fichier httpd.conf pour que apache24 prenne en compte le php par défaut : 

ee /usr/local/etc/apache24/httpd.conf

 

Premièrement il faut vérifier si ton fichier charge la lib "libphp5.so : 

Regarde dans ton fichier si la ligne ci dessou est présente, si elle ne l'est pas ajoute la : 

LoadModule php5_module        libexec/apache24/libphp5.so

 

Deuxièmement, il faut ajouter index.php dans la catégorie : 

   DirectoryIndex index.html


à remplacer par : 


    DirectoryIndex index.html, index.php

 

Pour finir ajoute ces deux lignes à la fin de ton fichier :

AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

 

Sauvegarde le fichier, un petit apachectl restart et le tour est joué ;)

Azukay.

  • J'adore 1
Link to comment
  • 0

Je suis de retour alors j'ai testé ta méthode mais je une erreur que voici :

 

[email protected]:/usr/ports/www/mod_php55 # make install clean

make: "/usr/ports/www/mod_php55/Makefile" line 16: Cannot open /usr/ports/www/mod_php55/../../lang/php55/Makefile

make: Fatal errors encountered -- cannot continue

make: stopped in /usr/ports/www/mod_php55

 

ps : je n'ai peut être désinstaller comme il faut apache ni tout supprimé j'ai peur de faire une bêtise vu que le serveur est utilisé pour d'autres choses ...

 

pss: le dossier /usr/ports/www/mod_php55 ne contient qu'un seul fichier nommé Makefile. Le contenu de ce fichier est :

 

CATEGORIES= www devel

PKGNAMEPREFIX= mod_

 

 

PHP_PORT= lang/php55

MASTERDIR= ${.CURDIR}/../../${PHP_PORT}

 

OPTIONS_DEFINE= AP2FILTER

AP2FILTER_DESC= Use Apache 2.x filter interface (experimental)

OPTIONS_EXCLUDE= CGI CLI FPM EMBED

 

.include "${MASTERDIR}/Makefile"

Link to comment
  • 0

ok merci maintenant le problème est le suivant (je n'ai pas vraiment cherché à réglé le problème je regarderai demain)

:

[email protected]:/usr/ports/www/mod_php55 # make install clean

make: "/usr/local/etc/php.conf" line 6: Need an operator

make: "/usr/local/etc/php.conf" line 9: Need an operator

make: "/usr/local/etc/php.conf" line 11: Need an operator

make: "/usr/local/etc/php.conf" line 12: Need an operator

make: "/usr/local/etc/php.conf" line 13: Need an operator

make: "/usr/local/etc/php.conf" line 14: Need an operator

make: "/usr/local/etc/php.conf" line 15: Need an operator

make: Fatal errors encountered -- cannot continue

make: stopped in /usr/ports/www/mod_php55

 

voici mon php.conf :

 

 

PHP_VER=56

PHP_VERSION=5.6.22

PHP_SAPI=cli cgi fpm

PHP_EXT_INC=pcre spl

 

DirectoryIndex index.php index.html

 

SetHandler application/x-httpd-php

SetHandler application/x-httpd-php-source

Link to comment
  • 0

Bon j'ai bien avancé cet aprés midi :D par contre quand je fais le restart pour apache j'ai une erreur sur la ligne que tu m'as fait rajouté

 

"LoadModule php5_module libexec/apache24/libphp5.so"

 

il me dit syntax error et du coup il n'arrive pas a charger le fichier httpd.conf

Link to comment
  • 0

Alors, la première erreur tu as mis ça : 

AddType application/x-httpd-php
AddType application/x-httpd-php-source

 

or il faut que tu mette ça : 

AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

 

ajoute bien les .php et .phps a la fin ;)

Pour ta deuxième erreur je t'ai dit de vérifier si tu avais la ligne et de l'ajouter si elle n'y etait pas, peut être que tu l'as ajoutée alors qu'elle y est déjà et c'est ca qui cause le problème, check ;).

Link to comment
  • 0

Pour la première tu as raison je me suis trompé sur cette ligne j'avais mis un / au lieu du point ...

 

concernant la Deuxième erreur ce n'est pas ça j'ai bien vérifier je pense que c'est parce que je n'ai pas ce qu'il faut je te met le pkg version dans quelques instants

 

[email protected]:~ # pkg version

apache24-2.4.20_1 =

apr-1.5.2.1.5.4 =

autoconf-2.69 <

autoconf-wrapper-20131203 =

automake-1.15_1 =

automake-wrapper-20131203 =

bash-4.3.39 <

ca_root_nss-3.19.3 <

cmake-3.4.1 <

cmake-modules-3.4.1 <

curl-7.43.0_2 <

db5-5.3.28_2 <

dialog4ports-0.1.5_2 =

dmidecode-2.12 <

expat-2.1.0_3 <

fping-3.10 =

freetype2-2.6.3 =

gdbm-1.11_2 <

gettext-runtime-0.19.4 <

gettext-tools-0.19.6 <

gmake-4.1_2 <

gmake-lite-4.1_1 <

help2man-1.43.3_1 =

indexinfo-0.2.3 <

jpeg-turbo-1.4.2 =

jsoncpp-0.6.0.r2_2 <

kbproto-1.0.7 =

ldns-1.6.17_4 <

lftp-4.6.3a <

libICE-1.0.9_1,1 =

libSM-1.2.2_3,1 =

libX11-1.6.3,1 =

libXau-1.0.8_3 =

libXaw-1.0.13,2 =

libXdmcp-1.1.2 =

libXext-1.3.3_1,1 =

libXmu-1.1.2_3,1 =

libXp-1.0.3,1 =

libXpm-3.5.11_4 =

libXt-1.1.5,1 =

libarchive-3.1.2_4,1 <

libevent2-2.0.22_1 =

libffi-3.2.1 =

libiconv-1.14_9 =

libidn-1.31 =

libpci-3.3.1_1 <

libpthread-stubs-0.3_6 =

libsmi-0.4.8_1 =

libtool-2.4.6 =

libxcb-1.11.1 =

libxml2-2.9.3 =

lsof-4.89.e,8 <

lynx-2.8.8.2_2,1 <

lzo2-2.09 =

m4-1.4.17_1,1 =

mtr-nox11-0.86 =

mysql55-client-5.5.46 <

mysql55-server-5.5.46 <

ncftp-3.2.5 =

ovh-rtm-0.9.4.3 ?

p5-Locale-gettext-1.06 =

pciids-20150615 <

pciutils-3.3.1_1 <

pcre-8.37_4 <

perl5-5.20.2_5 <

php55-5.5.37 =

php55-ctype-5.5.37 =

php55-dom-5.5.37 =

php55-extensions-1.8 =

php55-filter-5.5.37 =

php55-hash-5.5.37 =

php55-iconv-5.5.37 =

php55-json-5.5.37 =

php55-mysql-5.5.37 =

php55-opcache-5.5.37 =

php55-pdo-5.5.37 =

php55-pdo_mysql-5.5.37 =

php55-pdo_sqlite-5.5.37 =

php55-phar-5.5.37 =

php55-posix-5.5.37 =

php55-session-5.5.37 =

php55-simplexml-5.5.37 =

php55-sockets-5.5.37 =

php55-sqlite3-5.5.37 =

php55-tokenizer-5.5.37 =

php55-xml-5.5.37 =

php55-xmlreader-5.5.37 =

php55-xmlwriter-5.5.37 =

php55-zlib-5.5.37 =

pkg-1.7.2 <

pkgconf-0.9.11 <

png-1.6.21 =

printproto-1.0.5 =

py27-Babel-2.1.1 <

py27-Jinja2-2.8 =

py27-MarkupSafe-0.23 =

py27-alabaster-0.7.6 =

py27-docutils-0.12 =

py27-pygments-2.0.2 <

py27-pystemmer-1.3.0_1 =

py27-pytz-2015.7,1 <

py27-setuptools27-18.7 <

py27-six-1.9.0 <

py27-snowballstemmer-1.2.0_1 =

py27-sphinx-1.3.1_2 <

py27-sphinx_rtd_theme-0.1.8 <

python2-2_3 =

python27-2.7.10_1 <

rsync-3.1.1_3 <

scons-2.3.0_1 <

screen-4.3.1 <

smartmontools-6.4_1 <

sqlite3-3.11.1 <

t1lib-5.1.2_4,1 =

tcpdump-4.7.4 =

tmux-2.0 <

unbound-1.5.3_1 <

vim-lite-7.4.752 <

wget-1.16.3 <

xextproto-7.3.0 =

xproto-7.0.28 =

zsh-5.0.8_3 <

You have new mail.

[email protected]:~ #

 

ps : j'ai tout enlevé je test avec php7 et apache 4? je suis pas sur de la version de apache mais installation en cours

Link to comment


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.