Jump to content
×
×
  • Create New...
  • 0

Problème déconnexion serveur en local


BusyIzi
 Share

Question

Bonjour, c'est à nouveau moi avec un soucis cette fois-ci concernant des problèmes de déconnexion du serveur.

 

Version des files : 2014

Domaine (Base de données, Core, etc.) : Ingame

Votre niveau (débutant, intermédiaire, avancé) : Intermédiaire

 

Description du problème : La VM hébergeant le jeu est sur mon pc, je peux ouvrir un client et jouer sans problème sans jamais être déconnecté. En revanche lorsque quelqu'un d'autre joue avec moi (sur un pc différent mais sur le réseau local 192.160.0.XX), il peut se connecter et jouer normalement mais se fait déconnecter très fréquemment,parfois au bout de 10 secondes parfois au bout de 10 minutes. 

Là où je sèche complètement c'est qu'il n'y a rien dans les syserr (Auth, db, game99, core1 2 3 4 5, ...) qui pourrait expliquer cette déconnexion momentanée. Et cela arrive en faisant des choses complètement différentes (en ne bougeant pas, en xp, en bougeant à cheval, a pied, avec ou sans skills, ..) 

 

Comment reproduire le problème : Impossible à reproduire consciemment, ça arrive n'importe quand sans prévenir

Recherches et tests effectué : Recherche dans les syserr, mise en réseau du PC par câble plutôt que wifi

Résultat des recherches et tests : Rien ne change, les déconnexions sont toujours aussi fréquentes

 

 

Des pistes vers lesquelles je pourrai me diriger ? Mon réseau wifi est assez performant pour supporter deux connexions simultanées... Et la VM est suffisamment dimensionnée avec 2GO de ram

Link to comment
Share on other sites

  • Answers 10
  • Created
  • Last Reply

Top Posters For This Question

Popular Days

10 answers to this question

Recommended Posts

  • 0
  • Retraité

Tu dis héberger le serveur sur ton PC (Hamachi ou NoIP ?) mais normalement, la connexion devrait se fermer au choix du personnage :/

 

En fait le truc que le serveur récupère pas l'adresse IP publique du coup ça foire ..

Link to comment
Share on other sites

  • 0

Je suis en IP locale, c'est à dire que pour le moment j'ai configuré le client avec l'ip locale de mon réseau (192.168.0.X), donc ni hamachi ni no_ip. De ce fait seulement les pc du même réseau local (mon réseau wifi) peuvent s'y connecter. Et cela fonctionne très bien ! C'est à dire que depuis un autre pc je peux jouer tranquillement jusqu'à me faire déconnecter brutalement au bout de 5, 10 minutes ou même une heure c'est très aléatoire. En revanche si le jeu est lancé depuis la machine sur laquelle se trouve la VM je ne me fais jamais déconnecter, c'est uniquement d'un autre ordi du même réseau.

 

Effectivement je comprends mieux ton tuto dans le cas où la deconnexion arrive dès la sélection du personnage

Link to comment
Share on other sites

  • 0

Verdict, Hamachi n'a rien résolu  :huh:

 

Je ne comprends vraiment pas ce qui justifie ces déconnexions. La VM est bien dimensionnée, je n'ai pas de problème particulier concernant mon réseau local. Vraiment je ne vois pas 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.