Jump to content
×
×
  • Create New...
  • 0

Bug de connexion


skee
 Share

Question

Bonjour, j'ai un souci au niveau de la connexion au serveur avec les joueurs qui veulent se connecter. En fait avec mon PC ça marche très bien (co, création de perso, co dans le jeu), mais mes joueurs n'y arrivent pas : ils sont déco au moment ou ils choisissent le serveur et avec n'importe quel émulateur. Je ne sais pas ou est le problème (ports,...). Donc si qqn a déjà eu ce souci ou si qqn connait la solution, merci de votre aide !

 

Skee

Link to comment
Share on other sites

  • Answers 23
  • Created
  • Last Reply

Top Posters For This Question

23 answers to this question

Recommended Posts

  • 0

Salut salut !

 

Avant de réclamer une aide, il serait tout d'abord préférable que tu lises le sujet "A lire avant de poster".

Ainsi nous aurions eu plus d'informations pour pouvoir t'aider ^^.

 

Je suis prêt à parier que c'est un simple problème de ports.

 

Peux-tu nous partager la config ? Peux-tu nous montrer un message d'erreur (si il y en a un) ?

On ne connait également pas l'émulateur que tu utilises..

 

Tu peux également chercher dans les sujets résolus, je pense que cela peut t'aider (si ce n'est pas déjà fait).

Link to comment
Share on other sites

  • 0

Coucou Tituc, ça fait un bail !

 

Je pense également que ça vient des ports, mais je suis actuellement en train d'essayer de voir aussi au niveau de mes hosts pour voir si ça vient pas de là. Je te redis dans la soirée

Après, concernant la config, je ne pense pas que ça vienne de là sachant que ça me fait à peu près le même souci avec chaque émulateur (bug au niveau du choix de serveur avec les autres ordis).

 

Merci de ton aide :)

Link to comment
Share on other sites

  • 0
  • Retraité

Si le soucis vient bien du port ce qui m'a aussi l'air très probable, c'est sans aucun doute ton GAME_PORT qui n'est peut-être pas ouvert au niveau de ta box (Si tu héberges bien le serveur sur ton ordi ... ?). Il me semble qu'il m'arrivait souvent de me faire avoir par le fait que mon ip locale changeait régulièrement et que donc l'ip cible renseignée dans les redirections de port (NAT) n'était plus valide.

Utilises-tu no-ip ?

Link to comment
Share on other sites

  • 0

###~Game Server~###

HOST_IP = 192.168.1.105

GAME_PORT = 5555

REALM_PORT = 443

PLAYER_LIMIT = 150

PLAYER_IP = 100

MOTD =bvn lol

MOTD_COLOR = 9C0000

 

###~Base de données~###

DB_HOST = 127.0.0.1

 

Et oui j'utilise bien NO-IP

Link to comment
Share on other sites

  • 0

On a tendance à l'oublier mais dans certains émulateurs (Ancestra Remake par exemple), il y a également des éléments à remplir dans la base de donnée.

Toujours dans l'exemple d'Ancestra Remake, il y a une table nommée "gameservers" qui doit être remplie correctement.

 

Sinon je pense que les autres joueurs auront du mal à se connecter à ton serveur.

"192.168.1.105" est une adresse locale non ?

Link to comment
Share on other sites

  • 0
  • Retraité

Effectivement, tu dois renseigner ton adresse no-ip dans HOST_IP et t'assurer que les REALM_PORT & GAME_PORT sont ouverts sur ta box.

Actuellement tes joueurs tentent de joindre un gameserver sur un ip de leur réseau local (ou même pas d'ailleurs) ; ça marche effectivement pas super. Toi tu peux en revanche te connecter sans soucis étant donné que tu es sur le réseau du serveur.

Si tu as AR54 ou tout autre ému multi serveur tu dois aussi correctement remplir la table gameservers comme l'a dit Tituc, en utilisant ton adresse no-ip & non locale.

Link to comment
Share on other sites

  • 0
  • Retraité

Comment se fait-il que tu ne parviennes pas à ouvrir ton port 5555 ? As-tu une erreur ou quoi que ce soit ?

Sinon, tu peux utiliser ton port 80 seulement si tu n'as pas de serveur web. Si tu comptes mettre ton gameserver sur le port 80, vérifie que l'émulateur réagit bien aux requêtes http qu'il pourrait malencontreusement recevoir (tente d'accéder à ton no-ip sur un navigateur avec l'émulateur lancé), juste histoire de s'assurer qu'il n'y a pas d'erreur gênantes.

Il est tout de même largement préférable que tu utilises un port non utilisé par d'autres services.

Link to comment
Share on other sites

  • 0

Beh je sais pas comment ça se fait que je ne puisse pas l'ouvrir, y a pas d'erreur ni rien, d'ailleurs sur la page de mon fai il est ouvert mais sur les sites que j'ai été voir et dans mon invite de commandes il est fermé é_è

 

J'ai essayé quelques ports ouverts mais je recois une erreur dans l'émulateur... abusé c'est la première fois que ca me fait ca

Link to comment
Share on other sites

  • 0

Non, la voici en entier :

 

 

###~Game Server~###

HOST_IP = 192.168.1.105

GAME_PORT = 3306

REALM_PORT = 445

PLAYER_LIMIT = 150

PLAYER_IP = 100

MOTD =bvn lol

MOTD_COLOR = 9C0000

 

###~Base de données~###

DB_HOST = 127.0.0.1

DB_USER = root

DB_PASS =

STATIC_DB_NAME = illimitycore

OTHER_DB_NAME = illimitycore

 

###~Publicité~###

PUB1 = Information : Revision 0.0.2 de IllimityCore

PUB2 = Information : Revision 0.0.2 de IllimityCore

PUB3 = Information : Revision 0.0.2 de IllimityCore

 

###~Start~###

START_LEVEL = 160

START_KAMAS = 30000000

START_ITEMS = 7143:1

START_MAP = 7411

START_CELL = 208

 

###~Reboot~###

ACTIV_REBOOT = false

REBOOT_TIME = 20000000

 

###~Rates~###

XP_PVP = 1

XP_METIER = 1

XP_PVM = 1

DROP = 1

KAMAS = 1

HONOR = 1

PORC_FM = 1

 

###~MAX : PA & PM~###

MAXPA = 12

MAXPM = 6

 

###~Téléportation~###

PVM_MAP = 7411

PVM_CELL = 208

 

PVP_MAP = 7411

PVP_CELL = 208

 

COMMERCE_MAP = 7411

COMMERCE_CELL = 208

 

PHOENIX_MAP = 8534

PHOENIX_CELL = 141

 

SHOP_MAP = 8534

SHOP_CELL = 141

 

###~True or False~###

SMALL_DEBUG = true

DEBUG = true

ACTIV_PUB = false

ACTIV_CARACT_2 = true

ACTIVER_XP_DEFI = false

USE_MOBS = true

ALLOW_MULE_PVP = false

ALLOW_MULTI_ACCOUNT = true

AURA_SYSTEM = false

 

ZAAP = true

 

###~MAPS~###

MAP_NO_PRISMES = 7411

 

et la config de dofus

 

Link to comment
Share on other sites

  • 0

Hu, le port du game ne doit surtout pas être 3306, tout mais pas ça :c, le port 3306 est surtout réservée pour le service MySQL.

Donc pour le port game, il serait préférable de laisser celui que tu nous avais montrer au tout début.

 

Ta configuration de Dofus (xml) n'est pas du tout comme celle de ton serveur.

Le port utilisé dans la configuration XML doit être le même port que celui que tu as mis pour REALM_PORT.

Pour le "ephesia-games.com", je pense pas que cette adresse soit valide, il faudrait mettre le HOST_IP de la configuration du Game à la place.

Et donc mettre ton adresse no-ip.

Link to comment
Share on other sites

  • 0

Au début j'avais mis 5555 mais comme il n'est pas ouvert j'peux pas le laisser :/ du coup j'ai essayé avec d'autres mais ca n'a pas marché. Et oui effectivement y a 443 et 445, j'avais oublié de changer mais mon colloc a bien mis 445 sur sa config et ca n'a quand meme pas marché.

 

Au passage je viens d'essayer d'aller sur le site avec mon tél mais ca ne marche pas, y a que sur mon pc que ca me redirige sur ma page wamp server.

Link to comment
Share on other sites

  • 0

Bah.. Il suffirait simplement d'ouvrir le port 5555 dans ce cas, il ne faut surtout pas prendre un port déjà utilisé par un autre service.

(Pour ouvrir le port, il y a plein de tutoriels à disposition sur internet)

 

Oui car tu as mis ton adresse locale sur no-ip. Or, il faudrait que tu mettes l'adresse IP fournie par ton opérateur (adresse IP qui doit être fixe, sinon ça va foirer au prochain redémarrage).

Cette adresse peut être obtenue ici : http://www.mon-ip.com/

Link to comment
Share on other sites

  • 0

Re, j'vais essayer depuis un autre ordi. Donc mon ip c'est 176.127.181.72, je fais comment pour la rediriger sur NO-IP ? Concernant le 5555 j'ai déjà essayé ça ne marche pas, y a certains autres ports qui marchent mais lui pas.

Link to comment
Share on other sites

  • 0

Petit up, via hamachi les joueurs peuvent se co, j'aurais donc besoin d'aide pour que mon adresse dynamique puisse être en ligne avec no-ip (en fait mon ip dans no-ip et monip.com n'est pas en ligne é_è). Thx !

Link to comment
Share on other sites

  • 0
  • Retraité

Tutoriel sur no-ip : https://funky-emu.net/topic/1171-mettre-son-serveur-sous-no-ip/

Pour ce qui est de la création du serveur en lui-même :

- Pour toutes les ip que tu devras renseigner (config.xml + config.txt) (excepté celle de ta base de donnée), tu dois toujours indiquer celle fournie par no-ip (si tu utilises no-ip) ou ton ip hamachi

- Pour ce qui est du REALM_PORT : il doit bien entendu être ouvert (et pas un port comme 80 ou 3306, utilisé par des services) et doit être le même que celui renseigné dans ta config.xml

- Pour le GAME_PORT, il doit encore une fois aussi être ouvert & différent de ports comme 80/3306

Donc si vraiment tu ne peux ouvrir ton port 5555 (il n'y a de toute façon aucune raison d'utiliser lui en priorité), choisis en un autre ouvert mais veille à ce que ce soit le même renseigné dans la config.txt ainsi que la .xml (pour le realm_port)

Enfin, un dernier éclaircissement au niveau de ton IP qui semble être un petit point de confusion :

Tu disposes de 3 IPs :

  • Ton ip locale localhost ( = 127.0.0.1) qui renvoi sur ta propre machine et que tu ne peux donc bien sûr pas renseigner dans aucune config sauf pour ton ip de base de donnée étant donné que tu es le seul à utiliser cette dernière et qu'elle est sans aucun doute sur la même machine que ton émulateur
  • Ton ip privée qui est sûrement 176.127.181.72 (ce dont je ne suis pas sûr, me confirmer) et qui désigne ta machine au sein de ton réseau local. De nouveau, tu ne peux donc la renseigner dans aucune configuration (sauf pour l'ip de la db, même chanson). Tu peux la voir avec des commandes comme ipconfig sous Windows (équivalent ifconfig sous linux) mais qu'aucun site ne peut te donner
  • Ton ip publique, qui est celle que des sites comme mon-ip.com t'affichent et qui surtout, est la seule accessible de "l'extérieur", notamment de tes joueurs et de n'importe quel service/site comme no-ip.com

Ainsi, tu comprends donc qu'il est important que lorsque tu crées ton adresse dns sur no-ip, tu dois l'associer avec ton ip publique, qui est quoi qu'il en soit déjà renseignée dans le champ en question.

Ceci fait, c'est l'adresse fournie par no-ip (un sous nom de domaine) que tu renseigneras dans toutes tes configs.

Bref, lis bien le tutoriel de Sorbet.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



  • Flux d'Activité

    1. 0

      Projet Genesis

    2. 4

      Shiva.international serveur privé metin2 Oldschool Start 16.09.2022

    3. 0

      Metin2 Champions - Accès anticipé

    4. 0

      Barbok

    5. 4

      Shiva.international serveur privé metin2 Oldschool Start 16.09.2022

    6. 2

      Partage Émulateur 2.63

    7. 2

      Partage Émulateur 2.63

  • Recently Browsing

    • No registered users viewing this page.

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.