Jump to content
×
×
  • Create New...
  • 0

Problème de query


hubert68
 Share

Question

Bonjour , j'ai un problème avec cette query : 

 

INSERT INTO `item_proto` VALUES (91000, 'Armure d'acier charbonné+0', 'Armure d'acier charbonné+0', 2, 0, 0, 2, 56, 1, 1, '', 0, 0, 91001, 0, 0, 5, 1, 100, 0, 0, 8, -4, 37, 25, 10, 25, 0, 170, 0, 0, 20, 50, -1, -1, -1, -1, -1, -1, 0, 3, 0);

INSERT INTO `item_proto` VALUES (91001, 'Armure d'acier charbonné+1', 'Armure d'acier charbonné+1', 2, 0, 0, 2, 56, 1, 1, '', 0, 0, 91002, 0, 0, 5, 1, 100, 0, 0, 8, -4, 37, 25, 10, 25, 0, 180, 20, 0, 21, 50, -1, -1, -1, -1, -1, -1, 0, 3, 0);

INSERT INTO `item_proto` VALUES (91002, 'Armure d'acier charbonné+2', 'Armure d'acier charbonné+2', 2, 0, 0, 2, 56, 1, 1, '', 0, 0, 91003, 0, 0, 5, 1, 100, 0, 0, 8, -4, 37, 25, 10, 25, 0, 190, 40, 0, 22, 50, -1, -1, -1, -1, -1, -1, 0, 3, 0);

INSERT INTO `item_proto` VALUES (91003, 'Armure d'acier charbonné+3', 'Armure d'acier charbonné+3', 2, 0, 0, 2, 56, 1, 1, '', 0, 0, 91004, 0, 0, 5, 1, 100, 0, 0, 8, -4, 37, 25, 10, 25, 0, 200, 60, 0, 23, 50, -1, -1, -1, -1, -1, -1, 0, 3, 0);

INSERT INTO `item_proto` VALUES (91004, 'Armure d'acier charbonné+4', 'Armure d'acier charbonné+4', 2, 0, 0, 2, 56, 1, 1, '', 0, 0, 91005, 0, 0, 5, 1, 100, 0, 0, 8, -4, 37, 25, 10, 25, 0, 210, 80, 0, 24, 50, -1, -1, -1, -1, -1, -1, 0, 3, 0);

INSERT INTO `item_proto` VALUES (91005, 'Armure d'acier charbonné+5', 'Armure d'acier charbonné+5', 2, 0, 0, 2, 56, 1, 1, '', 0, 0, 91006, 0, 0, 5, 1, 100, 0, 0, 8, -4, 37, 25, 10, 25, 0, 220, 100, 0, 25, 50, -1, -1, -1, -1, -1, -1, 0, 3, 0);

INSERT INTO `item_proto` VALUES (91006, 'Armure d'acier charbonné+6', 'Armure d'acier charbonné+6', 2, 0, 0, 2, 56, 1, 1, '', 0, 0, 91007, 0, 0, 5, 1, 100, 0, 0, 8, -4, 37, 25, 10, 25, 0, 230, 120, 0, 26, 50, -1, -1, -1, -1, -1, -1, 0, 3, 0);

INSERT INTO `item_proto` VALUES (91007, 'Armure d'acier charbonné+7', 'Armure d'acier charbonné+7', 2, 0, 0, 2, 56, 1, 1, '', 0, 0, 91008, 0, 0, 5, 1, 100, 0, 0, 8, -4, 37, 25, 10, 25, 0, 240, 140, 0, 27, 50, -1, -1, -1, -1, -1, -1, 0, 3, 0);

INSERT INTO `item_proto` VALUES (91008, 'Armure d'acier charbonné+8', 'Armure d'acier charbonné+8', 2, 0, 0, 2, 56, 1, 1, '', 0, 0, 91009, 0, 0, 5, 1, 100, 0, 0, 8, -4, 37, 25, 10, 25, 0, 250, 160, 0, 28, 50, -1, -1, -1, -1, -1, -1, 0, 3, 0);

INSERT INTO `item_proto` VALUES (91009, 'Armure d'acier charbonné+9', 'Armure d'acier charbonné+9', 2, 0, 0, 2, 56, 1, 1, '', 0, 0, 0, 0, 0, 5, 1, 100, 0, 0, 8, -4, 37, 25, 10, 25, 0, 260, 200, 0, 29, 50, -1, -1, -1, -1, -1, -1, 0, 3, 0);

Quelqu'un pourrait-il y regarder et me dire d'ou vient l'erreur s'il vous plaît merci.

Message d'erreur : [Err] 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'acier charbonné+0', 'Armure d'acier charbonné+0', 2, 0, 0, 2, 56, 1, 1, '', 0, 0' at line 1

Link to comment
Share on other sites

  • Answers 7
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

7 answers to this question

Recommended Posts

  • 0

Bonjour,

 

Il est assez difficile de vous dire d'ou viens le problème exactement.

Tout se que je peux dire.

C'est que je pence que le souci vien d'une incompatibilité au niveau de la query & de votre item_proto.

A mon avis votre items proto et cette query non pas le même nombre de collone.

Après il faudrait donc, tester voir si ces pour 2012,2014, .... etc.

 

Cordialement,

Link to comment
Share on other sites

  • 0
  • Funkiest

Le problème vient du fait que tu as utilisé un " ' " (l'apostrophe) dans une requête: comme ce symbole sert de séparateur, ça plante toute ta query.

Tu dois mettre ici:

Armure d'acier charbonné+0', 'Armure d'acier charbonné+0'

 

ceci:

Armure d''acier charbonné+0', 'Armure d''acier charbonné+0'

 

Je précise qu'il faut bien mettre deux apostrophes, et pas un guillemet.

Fais ceci pour toutes les lignes, et ça devrait être bon :)

Link to comment
Share on other sites

  • 0
  • Funkiest

Moi j'opterais pour le "/" a la fin, pour les accent, les accent à la fin posent problème dans metin2.

 

De là a dire une incompatibilité proto pour une erreur de syntaxe, quand même pas. xD

 

Tu peux teznter de convertir en utf-8 ou modifier la query (j'tenvoie la syntaxe, je cherche).

Link to comment
Share on other sites

  • 0

Je disais que sa pouvais venir du fait que y a pas le même nombre de collone.

Vue que sa mes deja arrivée énormement de fois :P

Bref, donc oui, j'avais pas penser au '.

Donc remplace juste ' par /.

Exemple :

d/accord.

Je crois que sa marche.

Et les accent, pourquoi sa marcherai pas ? sa se mes moi.

Des fois les accent finisse en "?".

Mes la majoriter du temps, ces par rapport a un convertisseur mal fichu.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



  • Flux d'Activité

    1. 0

      Projet Genesis

    2. 4

      Shiva.international serveur privé metin2 Oldschool Start 16.09.2022

    3. 0

      Metin2 Champions - Accès anticipé

    4. 0

      Barbok

    5. 4

      Shiva.international serveur privé metin2 Oldschool Start 16.09.2022

    6. 2

      Partage Émulateur 2.63

    7. 2

      Partage Émulateur 2.63

  • Recently Browsing

    • No registered users viewing this page.

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.