Jump to content
×
×
  • Create New...
  • 0

Files 2014 : Lib manquante


XDarkKillerX
 Share

Question

Bonjour, j'en ai enfin eu marre de ces files 2012 qui étaient pourtant les meilleures à mes yeux mais voilà à force on est bloqué pour tous les systèmes récents et voilà pour la petite histoire ^^'

 

version des files : 2014

Domaine (Base de données, Core, etc.) : FTP

Votre niveau (débutant, intermédiaire, avancé) : Inter

 

Description du problème : Quand je tape la commande sh start.sh pour démarrer le serveur, il est dit qu'il me manque la lib "libz.so.6", le problème c'est que je ne connais pas la version du FreeBSD sur lequel mon serveur tourne, je suis en local et j'utilise à la base le serveur by emulateur (anciennement sous files 2006 puis passé sous 2012 et aujourd'hui 2014.)

 

Je pense donc que ça doit être une vieille version de BSD mais laquelle :/

 

Si quelqu'un connais la version du BSD du serveur by emulateur ou mieux qui a la lib je suis preneur :)

 

Comment reproduire le problème : Installer les files 2014 en local avec comme base le serveur by emulateur

Recherches et tests effectué : google, EB, funky

Résultat des recherches et tests : Rien du tout :/ *snif*

 

Message d'erreur, capture d'écran :

 

J'espère sincèrement que quelqu'un à déjà rencontré ce problème et saura m'éclairer ou m'informer d'une astuce pour avoir TOUTES les libs de la terre entière *-*

 

Cordialement :)

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le règlement des demandes d'aides.

 

Edit : J'suis un boulet c'est marqué en gros quand on lance le serveur donc c'est FreeBSD 7.0 RELEASE :)

Link to comment
Share on other sites

  • Answers 10
  • Created
  • Last Reply

Top Posters For This Question

10 answers to this question

Recommended Posts

  • 0
  • Funkiest

Bonjour, il suffit de taper "uname -a" ou "-rs".

 

La version est FreeBSD 7.3 si je ne me trompe pas, c'est écris au début.

 

Pour les libs, pour FreeBSD 9.2, il faut compat7x, mais comme je suis gentil, je vais te fournir toutes les libs FreeBSD 9.2 (fonctionnelles avec ton serveur normalement, tu m'écriras la version de ton game), je ne te fournis pas celles demandés par la compilation (notamment celle demandée par gcc49 etc...).

 

https://mega.co.nz/#!QAdWCIBD!BnTLKnMxKXGwuncWxwMI6Y6YPUhZMg9O79JfJTxA4Hc

Link to comment
Share on other sites

  • 0

Merci beaucoup je vais tester ça de suite et je dis quoi, le game c'est celui des 2014 le 40250 si je dis pas de bêtise ? ^^


Edit : ça ne fonctionne pas et virtual box m'affiche cette erreur : /libexec/lf-elf.so.1: /lib/libc.so.7: version FBSD_1.2 required by db not found

 

La version n'est pas bonne ? :/

Link to comment
Share on other sites

  • 0
  • Funkiest

Merci beaucoup je vais tester ça de suite et je dis quoi, le game c'est celui des 2014 le 40250 si je dis pas de bêtise ? ^^


Edit : ça ne fonctionne pas et virtual box m'affiche cette erreur : /libexec/lf-elf.so.1: /lib/libc.so.7: version FBSD_1.2 required by db not found

 

La version n'est pas bonne ? :/

 

Cherches le nom des libs sur google ou le forum et tu les toruveras.

 

Il y a 2 games 2014.

 

Le 40250 : novaline.

Le 44XXX (je crois) : mainline.

 

Ensuite mainline_sg etc... la même, le plus courrant reste le novaline.

Link to comment
Share on other sites

  • 0

J'ai rien compris pour l'histoire des novaline mainline c'est pas des truc pour le code source ou j'sais pas quoi ?

 

Bref j'ai rien trouvé, en revanche si jamais je mettais les files 2014 sur mon dédié (FreeBSD 9.2) avec les libs que tu m'a données, ça serait niquel non ?

Link to comment
Share on other sites

  • 0
  • Funkiest

J'ai rien compris pour l'histoire des novaline mainline c'est pas des truc pour le code source ou j'sais pas quoi ?

 

Bref j'ai rien trouvé, en revanche si jamais je mettais les files 2014 sur mon dédié (FreeBSD 9.2) avec les libs que tu m'a données, ça serait niquel non ?

 

Oui ça marcherait.

 

Et oui, c'est une histoire de source, car tout les games viennent de là et la version différe. xD

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.