Jump to content
×
×
  • Create New...
  • 0

Navicat error


Naia
 Share

Question

Bonsoir Funky-Émulation,

depuis 17 heures j'essai exécuter la base de donnée player sur ma nouvelle dédié, mais cela me marque une erreur, voici;

 

[Err] 1115 - Unknown character set: 'big5'
[Err] CREATE TABLE `item_proto` (
 `vnum` int(11) unsigned NOT NULL default '0',
 `name` varbinary(24) NOT NULL default 'Noname',
 `locale_name` varbinary(60) NOT NULL default 'Noname',
 `type` tinyint(2) NOT NULL default '0',
 `subtype` tinyint(2) NOT NULL default '0',
 `weight` tinyint(3) default '0',
 `size` tinyint(3) default '0',
 `antiflag` int(11) default '0',
 `flag` int(11) default '0',
 `wearflag` int(11) default '0',
 `immuneflag` set('PARA','CURSE','STUN','SLEEP','SLOW','POISON','TERROR') NOT NULL default '',
 `gold` int(11) default '0',
 `shop_buy_price` int(10) unsigned NOT NULL default '0',
 `refined_vnum` int(10) unsigned NOT NULL default '0',
 `refine_set` smallint(11) unsigned NOT NULL default '0',
 `refine_set2` smallint(5) unsigned NOT NULL default '0',
 `magic_pct` tinyint(4) NOT NULL default '0',
 `limittype0` tinyint(4) default '0',
 `limitvalue0` int(11) default '0',
 `limittype1` tinyint(4) default '0',
 `limitvalue1` int(11) default '0',
 `applytype0` tinyint(4) default '0',
 `applyvalue0` int(11) default '0',
 `applytype1` tinyint(4) default '0',
 `applyvalue1` int(11) default '0',
 `applytype2` tinyint(4) default '0',
 `applyvalue2` int(11) default '0',
 `value0` int(11) default '0',
 `value1` int(11) default '0',
 `value2` int(11) default '0',
 `value3` int(11) default '0',
 `value4` int(11) default '0',
 `value5` int(11) default '0',
 `socket0` tinyint(4) default '-1',
 `socket1` tinyint(4) default '-1',
 `socket2` tinyint(4) default '-1',
 `socket3` tinyint(4) default '-1',
 `socket4` tinyint(4) default '-1',
 `socket5` tinyint(4) default '-1',
 `specular` tinyint(4) NOT NULL default '0',
 `socket_pct` tinyint(4) NOT NULL default '0',
 `addon_type` smallint(6) NOT NULL default '0',
 PRIMARY KEY  (`vnum`)
) ENGINE=MyISAM DEFAULT CHARSET=big5;
[Msg] Finished - Unsuccessfully
--------------------------------------------------

 

J'ai tout essayer, mais rien ne marche, cordialement.

 

Files 2012

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le règlement des demandes d'aides.

Link to comment
Share on other sites

  • Answers 8
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

8 answers to this question

Recommended Posts

  • 0
  • Retraité

Salut, est ce que les autres tables sont passées à l’exécution du code SQL, car MySQL s’arrête à la première erreur il me semble, donc même si les autres tables l'utilisent, si elle viennent après dans le code tu auras pas d'erreur pour le reste. Donc big5 et peut-être mal implémenté

 

Je peux avoir la DB complète pour test chez moi stp

 

Edite : j'ai testé chez moi de créer la table que tu as donné, chez moi ça passe et big5 et bien présent, quel version de mysql as-tu, es-tu sûr de bien avoir big5

.png

https://xaaram.deviantart.com/
Co-Fondateur à la retraite

Link to comment
Share on other sites

  • 0

J'ai Mysql 55, c'est celui que j'ai utiliser pour installer mon serveur, soit:

 

cd /usr/ports/databases/mysql55-server

 

Je vais essayé de mettre le 51 voir.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.