Aller au contenu

Nouveau membre ?! Pense à te présenter pour accéder au contenu du forum !

New member ?! Introduce yourself to get access to the forum !

  • 0
skulldeath

en cours modélisation 3dsmax

Question

Bonjour tout le monde.

 

J'ai crée un moob sous 3dsmax 7 jusque la aucun soucis je lui est crée des animation la encore pas de soucis je vois le moob IG les animation fonctionne IG sauf que mon moob ne fait aucun déplacement l'animation run et walk fonction on vois le moob la faire mais il reste sur place et il regarde sur sa gauche au lieu d'en face.

 

Donc j'aurais aimer savoir si le run et le walk se faisait ou s'exportai de façon différente ou si au niveau de la création une option ou un réglage supplémentairement doit être fait.

 

Merci d'avance.

Partager ce message


Lien à poster
Partager sur d’autres sites

12 réponses à cette question

Messages recommandés

  • 0

Sur 3DS:

Au fur et à mesure de l'animation, le mob doit avancer sur l'axe, donc il part du centre de la grille au début, et à la fin de l'animation il doit être plus loin.

 

Dans l'expotron:

Pour exporter des walk/run, active la fonction "Constant Motion Extraction" dans l'onglet "Animation" de l'expotron.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

merci Kijaru sa fonctionne parfaitement bon il se déplace comme une tortue mais il se déplace c'est déjà sa =) par contre il se déplace toujours a 90° vers la gauche de la direction sélectionner du coup si je clic devant il va a gauche si je clique a gauche il va derrière etc et je sais pas pourquoi :/

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Modifie les axes, ils ne sont pas bon.

 

Ouvre en même temps un modèle originel de MT2 avec son animation de run + ton modèle et son animation de run.

Lance les deux animations, et regarde dans quel sens part le modèle de base de MT2: ton modèle devra aller dans le même sens.

 

Concernant la vitesse, elle se règle dans le .msa du run/walk sous le nom "accumulation", et il me semble qu'elle se règle également dans la BBD.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Modifie les axes, ils ne sont pas bon.

je vois pas bien se que tu veut dire par modifie les axes

sinon ok pour la vitesse

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Cela veut dire que si ton modèle avance par exemple vers la gauche sur 3DS, alors il faut le faire avancer en haut ou en bas par rapport à la grille.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

oui il avançait vers la droite suivant l'axe x je lui est mis une rotation vers la droite de 90° ( vu qu'il allais a 90° vers la gauche de la direction sélectionner) du coup j'ai mis une rotation aussi sur l'animation du coup il se déplace suivant -y quand je lance sous 3ds max ou granny viewer le moob se déplace bien dans le même sens que les autres mais IG il continue d'aller vers la gauche.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Je vais être honnête: je ne comprends strictement rien à ce que tu me dis ^_^

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

je peu te contacter pour que tu m'explique ?

 

mais pour faire simple j'ai mis une rotation sur la droite pour changer l'axe de déplacement et quand je regarde sous granny viewer le moob de déplace bien dans le même sens que les autre moob mais IG même soucis le moob va toujours a gauche.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Yep' bien sûr, je t'ajoute sur Skype dès que je peux.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Je connais pas grand chose niveau 3d mais j'ai une petit remarque dans mob_proto> ai_flag ton mob est peut être a NOMOVE ^^

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

oui c'est la première chose que j'ai regarde mais malheureusement je l'avais mis en AGGR.

 

si tu veux plus de précision kijaru si je fait spaw mon moob sans animation il spaw en regardant vers la gauche et j'ai essayer de lui mettre une rotation sa ne change rien je comprends pas pourquoi et je pense que c'est ce qui est a l'origine de mon problème mais je vois pas du tout comment le résoudre.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

j'ai réussi a debug intégralement mon moob merci a tous.

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×

Information importante

By using this site, you agree to our Conditions d’utilisation.