Aller au contenu
  • 0

Problème map


Calypso

Question

  • Administrateur

Bonsoir,

 

Version des files : 2013 pour le game 40250

Domaine (Base de données, Core, etc.) : Client/Base de donnée

Votre niveau (débutant, intermédiaire, avancé) : Avancée

 

Description du problème : Quand je me téléporte sur la map OX Event, le client se ferme avec le bug des ?????????????????

Comment reproduire le problème : Retourner sur la map

Test effectués : Mettre le côté serveur/client d'une map OX fonctionnelle. Mettre le chmod99, vérifier le atlasinfo de local et root.

 

Message d'erreur, capture d'écran :

 

0118 19:41:55178 :: invalid idx 0

0118 19:41:01632 :: CMapOutdoor::Load - LoadMonsterAreaInfo ERROR

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le règlement des demandes d'aides.

Lien vers le commentaire
  • Réponses 16
  • Created
  • Dernière réponse

Top Posters For This Question

16 réponses à cette question

Messages recommandés

  • 0
  • Administrateur

Non pas résolu, si tu pouvais arrêter de dire ce genre de chose afin de ne pas faire perdre du temps à Itachi ..

 

J'ai essayé de prendre le season1 du client 2012, le problème, c'est que ça me met:

 

 

0122 18:34:53173 :: CMapBase::LoadProperty(FileName=season1/metin2_map_oxevent\MapProperty.txt) - LoadMultipleTextData ERROR ÆÄÀÏÀÌ ¾øÀ» °¡´É¼ºÀÌ ¸¹½À´Ï´Ù.

0122 18:34:53173 :: CMapManager::LoadMap() Invalid Map Type

 

Donc on voit bien que dans les deux client, qu'il y a une différence entre le OX du client 2012 et le 40250. J'ai vérifié partout, beaucoup dans le serverinfo, j'ai comparé les fichiers, sont tous pareil, sauf les fichiers de maps du genre tile, height, etc bien entendu

Lien vers le commentaire
  • 0
  • Administrateur

L'erreur est réglé. Donc j'ai mit ma map ox dans son propre eix/epk. J'ai laissé dans season1 car je pouvais pas repack, après, j'ai changé dans atlasinfo (locale&root), pour que ça vise sur mon eix/epk. Mais toujours pareil !

 

Sysser:

 

 

0123 23:38:10026 :: invalid idx 0

0123 23:38:15587 :: CMapOutdoor::Load - LoadMonsterAreaInfo ERROR

 

 

log (client):

 

 

0123 23:43:42175 :: SYSERR: CMapOutdoor::Load - LoadMonsterAreaInfo ERROR

0123 23:43:42176 :: LoadWaterMapFile metin2_map_oxevent\000000\water.wtr 1

0123 23:43:42176 :: LoadRawHeightMapFile metin2_map_oxevent\000000\height.raw 0123 23:43:42180 :: LoadHeightMap::CalculateNormal 3 ms

0123 23:43:42180 :: LoadAttrMapFile metin2_map_oxevent\000000\attr.atr 0123 23:43:42180 :: 0

0123 23:43:42180 :: LoadSplatFile metin2_map_oxevent\000000\tile.raw 0123 23:43:42197 :: CTerrain::RAW_AllocateSplats 16

0123 23:43:42198 :: CTerrain::LoadShadowTexture 1 ms

0123 23:43:42198 :: LoadShadowMap metin2_map_oxevent\000000\shadowmap.raw 0123 23:43:42199 :: 1 ms

0123 23:43:42199 :: CTerrain::LoadMiniMapTexture 0 ms

0123 23:43:42201 :: CMapOutdoor::LoadTerrain 26

0123 23:43:42670 :: SYSERR: GRANNY: r:/granny/rt/granny_file_info.cpp(145): File has run-time type tag of 0x8000000f, which doesn't match this version of Granny (0x80000010). Automatic conversion will be attempted.

0123 23:43:43117 :: LoadWaterMapFile metin2_map_oxevent\001000\water.wtr 0

0123 23:43:43117 :: LoadRawHeightMapFile metin2_map_oxevent\001000\height.raw 0123 23:43:43120 :: LoadHeightMap::CalculateNormal 3 ms

0123 23:43:43120 :: LoadAttrMapFile metin2_map_oxevent\001000\attr.atr 0123 23:43:43121 :: 1

0123 23:43:43121 :: LoadSplatFile metin2_map_oxevent\001000\tile.raw 0123 23:43:43136 :: CTerrain::RAW_AllocateSplats 14

0123 23:43:43137 :: CTerrain::LoadShadowTexture 1 ms

0123 23:43:43137 :: LoadShadowMap metin2_map_oxevent\001000\shadowmap.raw 0123 23:43:43138 :: 1 ms

0123 23:43:43138 :: CTerrain::LoadMiniMapTexture 0 ms

0123 23:43:43140 :: CMapOutdoor::LoadTerrain 24

 

Et si je vous dis que j'ai déjà prit les fichiers d'une map fonctionnelle ?

J'ai aussi réimplanté la map, complètement, même les coordonnées ..

Lien vers le commentaire
  • 0
  • Funkiest

Ouaip ces une erreur de repack je pense donc lors du repack y'a forcément un bide ..

 

( ça y est je me transforme en Galet :o )

 

J'y suis :bave:

 

 

As tu essayé un autre dépackeur, car l'eternexus provoque pas mal de dysfonctionnement, et, si ce problème vient du jour au lendemain, vérifie bien ce que tu as implanté après.

Lien vers le commentaire
  • 0
  • Administrateur

Alors là :) L'erreur vient bien de l'objet |O|X| Pourquoi ?

 

Donc tout d'abord, j'ai bien gardé ma map OX en eix/epk pour éviter l'erreur de repack et j'ai ensuite enlevé la totalité des objets de cette map.

Et vous savez quoi ? Tout fonctionne !! Donc j'ai remit les objets sauf le |O|X|, qui je rappelle est blanc, et tout fonctionnait encore .. J'ai remit le |O|X| et là, plus rien ne fonctionne ..

 

Cet objet est blanc, sans texture ..

 

J'ai mit le dossier oxevent des files 2012 dans zone et property mais toujours pareil. Donc là, on est quand même bien avancé ..

Lien vers le commentaire
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.


×
×
  • Créer...

Information importante

Conditions d’utilisation / Politique de confidentialité / Règles / Nous avons placé des cookies sur votre appareil pour aider à améliorer ce site. Vous pouvez choisir d’ajuster vos paramètres de cookie, sinon nous supposerons que vous êtes d’accord pour continuer.