Aller au contenu
  • 0

implantation foiré armes


olivier52000

Question

[Message d'introduction]

salut, voila j'ai fait ma petite implentation d'armes, et la !!

boum gros bug !!. sans déc ><.

j'ai suivit tout les tuto et sa marche pas. présent dans l'inventaire. quand je met le curseur j'ai des stats qui s'affiche mais quand je met sur moi invisible, et aussi dans l'inventaire bug

 

Version des files :2012

Domaine (Base de données, Core, etc.) :client

Votre niveau (débutant, intermédiaire, avancé) :Débutant

 

Description du problème : l'arme ne s'affiche pas sur le personnage

Comment reproduire le problème :?

Recherches et tests effectué : j'ai suivit tout les tuto et sa rien changé

Résultat des recherches et tests :

 

Message d'erreur, capture d'écran :

395343testarmes.png

87128197p.png

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le règlement des demandes d'aides.

Lien vers le commentaire
  • Réponses 19
  • Created
  • Dernière réponse

Top Posters For This Question

Top Posters For This Question

19 réponses à cette question

Messages recommandés

  • 0

en faite le dds est intégré au gr2. mais le chemin n'est pas le bon...

je crois que je vient de comprendre il a du renommé sont dds. en tga... et il n'a pas mi d'icone avec sont arme ceux qui est souvent le cas je trouve ><

 

edit : non c'est pas ça.

 

donc ce que j'ai fait, j'ai implenté une arme comme il fallait, et ça marche pas ... j'ai ddl une arme avec un fichier gr2, et un tga

j'ai mis le tga dans icon, le gr2 dans weapon, repack, ect, navicak, et ça ma donné ça ><

 

petite info le dds est intégré dans le gr2, etant donné que quand j'ouvre le gr2 l'armes est coloré, mais la texture a une destination bizzard je l'est modiffier avec grani helper et ça change rien!! ><

Lien vers le commentaire
  • 0

en faite le dds est intégré au gr2. mais le chemin n'est pas le bon...

je crois que je vient de comprendre il a du renommé sont dds. en tga... et il n'a pas mi d'icone avec sont arme ceux qui est souvent le cas je trouve ><

 

edit : non c'est pas ça.

 

donc ce que j'ai fait, j'ai implenté une arme comme il fallait, et ça marche pas ... j'ai ddl une arme avec un fichier gr2, et un tga

j'ai mis le tga dans icon, le gr2 dans weapon, repack, ect, navicak, et ça ma donné ça ><

 

petite info le dds est intégré dans le gr2, etant donné que quand j'ouvre le gr2 l'armes est coloré, mais la texture a une destination bizzard je l'est modiffier avec grani helper et ça change rien!! ><

 

bonjour tu as déja une réponse dans ton message d'ou viens ton erreur

je m'explique : plus haut tu nous dis:" j'ai ddl une arme avec un fichier gr2, et un tga " donc si j'ai bien tout compris dans ton fichier il n'y avais qur le ( GR2 et un tga) rien d'autre ? si cela et bien le cas

il manque l'icon , car ton fichier dll a tout simplement que le ( gr2 et la tga qui lui es sa texture );car pour certaine arme la texture et en tga.

pour être certain je t'invite a poster un screen de ton gr2 vue via granny onglet ( texture ) .

pour corriger cela : il te faut te crée une icon pour ton arme

puis metre ton (gr2 et tga) dll dans ton dossier item et l'icon que tu a crée juste avant dans le dossier icon

et la normalement tout devrais fonctionner

Lien vers le commentaire
  • 0

voila le item_liste.txt

520000 WEAPON icon/item/520000.tga d:/ymir work/item/weapon/520000.gr2

520001 WEAPON icon/item/520000.tga d:/ymir work/item/weapon/520000.gr2

520002 WEAPON icon/item/520000.tga d:/ymir work/item/weapon/520000.gr2

520003 WEAPON icon/item/520000.tga d:/ymir work/item/weapon/520000.gr2

520004 WEAPON icon/item/520000.tga d:/ymir work/item/weapon/520000.gr2

520005 WEAPON icon/item/520000.tga d:/ymir work/item/weapon/520000.gr2

520006 WEAPON icon/item/520000.tga d:/ymir work/item/weapon/520000.gr2

520007 WEAPON icon/item/520000.tga d:/ymir work/item/weapon/520000.gr2

520008 WEAPON icon/item/520000.tga d:/ymir work/item/weapon/520000.gr2

520009 WEAPON icon/item/520000.tga d:/ymir work/item/weapon/520000.gr2

 

proto_item serveur :

520000 Test+0 Test+0 1 0 0 2 56 1 16 1000 500 520001 0 0 5 1 100 0 0 7 30 0 0 0 0 0 1000 1500 1000 1500 50 -1 -1 -1 -1 -1 -1 0 3 0

520001 Test+1 Test+1 1 0 0 2 56 1 16 1500 1000 520002 0 0 5 1 100 0 0 7 30 0 0 0 0 0 1100 1600 1100 1600 50 -1 -1 -1 -1 -1 -1 0 3 0

520002 Test+2 Test+2 1 0 0 2 56 1 16 2000 1500 520003 0 0 5 1 100 0 0 7 30 0 0 0 0 0 1200 1700 1200 1700 50 -1 -1 -1 -1 -1 -1 0 3 0

520003 Test+3 Test+3 1 0 0 2 56 1 16 2500 2000 520004 0 0 5 1 100 0 0 7 30 0 0 0 0 0 1300 1800 1300 1800 50 -1 -1 -1 -1 -1 -1 0 3 0

520004 Test+4 Test+4 1 0 0 2 56 1 16 3000 2500 520005 0 0 5 1 100 0 0 7 30 0 0 0 0 0 1400 1900 1400 1900 50 -1 -1 -1 -1 -1 -1 0 3 0

520005 Test+5 Test+5 1 0 0 2 56 1 16 3500 3000 520006 0 0 5 1 100 0 0 7 30 0 0 0 0 0 1500 2000 1500 2000 50 -1 -1 -1 -1 -1 -1 0 3 0

520006 Test+6 Test+6 1 0 0 2 56 1 16 4000 3500 520007 0 0 5 1 100 0 0 7 30 0 0 0 0 0 1600 2100 1600 2100 50 -1 -1 -1 -1 -1 -1 0 3 0

520007 Test+7 Test+7 1 0 0 2 56 1 16 4500 4000 520008 0 0 5 1 100 0 0 7 30 0 0 0 0 0 1700 2200 1700 2200 50 -1 -1 -1 -1 -1 -1 0 3 0

520008 Test+8 Test+8 1 0 0 2 56 1 16 5000 4500 520009 0 0 5 1 100 0 0 7 30 0 0 0 0 0 1800 2300 1800 2300 50 -1 -1 -1 -1 -1 -1 0 3 0

520009 Test+9 Test+9 1 0 0 2 56 1 16 5500 5000 0 0 0 5 1 100 0 0 7 30 0 0 0 0 0 1900 2400 1900 2400 50 -1 -1 -1 -1 -1 -1 0 3 0

item _proto client

Lien vers le commentaire
  • 0

j'ai changé ça bug un peut moins car avant quand je tappais je tappais au point maintenant je tappe avec une épée invisible... ya du mieux.

 

icone toujours la.

valeur quand je met le curseur, toujours la

valeur quand je tape, présente.

 

je l'est passer a 9990

 

on peut renommé les gr2, et tga comme on veut ? ça fait pas tout planté ?

Lien vers le commentaire
  • 0

hum!! petite question tu met bien des [TAB] dans ton item list ?

9990[TAB]WEAPON icon/item/9990.tga[TAB]d:/ymir work/item/weapon/9990.gr2

 

ensuite  ton icon 9990.tga = dossier icon
           ton gr2 9990.gr2 = dossier item/weapon
           ta texture name = axe_2h_alliance_d_01red.tga =dossier item/weapon

vue que la texture, du gr2 que tu as renommer ( 9990.gr2)

reste identique par ce que la tu change juste le nom de ton gr2 pas le chemin de sa texture qui elle restera la même sur ce nom la (axe_2h_alliance_d_01red.tga )

donner par granny

29297084pe.png

Lien vers le commentaire
  • 0

oui c'est tout bon c'est ce que j'ai fait et ça marche pas ><

 

je vais essayé d'implenté une autre armes pour voire si ça marche avec un autre gr2 et tga

 

bon ... je vais rien dire mais j'est fait avec une autres armes et ça marche ... >< même manip et tout et la tadammm! ça marche ça veu dire que c'est le fichier de l'armes qui plante pas moi qui c'est pas faire :x

 

donc résolut et l'armes va passé a la corbeille toute façon j'en ai assez d'autre --"

Lien vers le commentaire
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.


×
×
  • Créer...

Information importante

Conditions d’utilisation / Politique de confidentialité / Règles / Nous avons placé des cookies sur votre appareil pour aider à améliorer ce site. Vous pouvez choisir d’ajuster vos paramètres de cookie, sinon nous supposerons que vous êtes d’accord pour continuer.