Aller au contenu
  • 0

Déconnexion à la sélection des persos


Hope

Question

[Message d'introduction]

Salut tous le monde, alors voila il y a peu j'ai fait un serveur pour jouer avec des potes pour le fun. Le serveur tourne sous hamachi, et je précise que tous fonctionnent bien chez moi et que j'ai donné mon client à mes amis (a part le serverinfo.py que j'ai modifié .XXX au lieu de .100).

 

Version des files : 2012.

Domaine (Base de données, Core, etc.) : Client.

Votre niveau (débutant, intermédiaire, avancé) : Débutant.

 

Description du problème :

Déconnexion après la sélection du personnage et avant le début du chargement (seulement pour mes amis).

Comment reproduire le problème :

Recherches et tests effectué :

J'ai trouvé plusieurs problèmes à peu près similaire en effectuant des recherches mais sans trop de réponses ou alors des choses que j'avais déjà réalisés. J'ai fini par tomber sur les clés pong et je l'ai ai donc changer côté launcher et game. J'ai ensuite redonné mon launcher à mes amis et essayé sur l'ordinateur de mon frère.

Résultat des recherches et tests :

Cela n'a rien changé au problèmes. Il n'y a encore que moi qui arrive à accédé au jeu.

 

Message d'erreur, capture d'écran :

Il n'y a pas de message d'erreur.

 

Merci pour votre aide ;).

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le règlement des demandes d'aides.

Lien vers le commentaire
  • Réponses 21
  • Created
  • Dernière réponse

Top Posters For This Question

21 réponses à cette question

Messages recommandés

  • 0
  • Développeur

D'accord, je vais essayé ça, je vous tiens au courant :).

 

Edit : J'ai rajouté les ports 22 et 50000 ( j'avais déjà 3306 j'avais zapé de l'écrire ) et cela ne change rien au problème :S.

 

C'est normal, le port 22 est fait pour le SSH, et le port 50000 pour le Testserver qui n'est jamais utilisé;

le port 3306 n'est pas vraiment obligatoire, sauf si tu veux donner l'accès à ta base de données à quelqu'un.

Mis à part un souci de clé pong je ne vois rien d'autre...

Lien vers le commentaire
  • 0

Fushiida : Non, mais avec quelle autre client testé ?

 

Merci pour tes précisions Sparkk.

Pour la clé pong, une mauvaise manipulation de ma part ?

J'ai pourtant changé dans le launcher et dans le fichier game ( juste la 1ère ligne ).

 

Tu me conseil de recommencer à 0 niveau clé ?

 

Edit : Cela pourrait t'il venir de mon fichier game ? Et j'aimerais savoir comment savoir quelle est notre game ( beaucoup parle du game_rev2089M ). Sur un autre forum, ils disent d'ajouté des diffs au game_rev2089M pour que cela fonctionnent sous hamachi et no-ip et le problème dont ils parlent à l'air d'être le même que moi.

 

Cordialement.

Lien vers le commentaire
  • 0
  • Développeur

Avec les files 2012 d'Elea il n'y a pas besoin de le faire. Si tes amis sont déconnectés à la sélection de personnages,

ça ne peut venir que de la clé pong. Le souci c'est que toi par contre tu arrives à te connecter, donc je me demande si

tu ne t'es pas gouré d'une lettre en leur donnant leur Launcher étant donné que toi tu ne l'utilises pas.

Essaie de voir si tu as correctement mis ta clé pong, elle ne doit pas dépasser le nombre de caractères déjà présents,

elle doit en conséquent contenir le même nombre de caractères. Après tout l'erreur est humaine, tu n'as pas du t'en

rendre compte, mais je ne peux pas confirmer que le problème vienne bien de là. Mais si toi tu arrives à te connecter

c'est que la clé pong de ton exécutable est correcte; reste à savoir si tes joueurs ont la même clé.

Lien vers le commentaire
  • 0

Merci pour ta réponse.

 

Pour la clé pong du fichier game, il faut juste changer la 1ère ligne ou les 3 ?

J'essayerai de les changer a nouveaux en étant plus attentif, comme je suis un débutant, en effet il y a des chances que j'ai fait des erreurs ^^.

 

Edit : J'ai fini par créer le serveur sous no-ip mais après cela nouveaux problème "erreur lors de la connexion" pour les joueurs ( moi tout fonctionne comme avant ... ), j'ai bien modifié leur serverinfo.py ouvert mes ports sur la livebox ... Je perd éspoir.

Lien vers le commentaire
  • 0

Salut l'amis ! Tu as suivit quelle tuto pour crée ton serveur en no-ip ? Je peux surement éclair ta lanterne ! Pour plus d'info ajoute moi skype : daye.camara puis après on donnera la réponse dans le sujet une fois résolu et précise dans ton invitation le lien du poste et que c'est pour un serveur metin2 no-ip car j'ai beaucoup de demande !

 

Cordialement.

 

Dayedu91

Lien vers le commentaire
  • 0

D'acc :P.

 

Je pense que le no-ip ne marche pas car mes ports de la livebox doivent être mal configuré, j'ai trouvé quelques tutos mais pour des livebox plus anciennes.

 

Voila un petit screen, si quelqu'un peut m'aider à bien les config je lui en serais reconnaissant ;) ( j'ai effacé les anciens que j'avais mit c'est pour ça qu'il n'y en a aucun ne vous inquiétez pas ) :

 

201701boxport.png

 

Cordialement.

Lien vers le commentaire
  • 0

Sa marche, merci bien ;).

 

Je part de chez moi ce soir jusqu'à dimanche, j'essaye de t'ajouter au plus vite.

 

Je passe le topic en "résolu" étant donné que mon problème ne vient plus du sujet de départ, et je pense pouvoir faire les ports avec ton aide Liberty, sinon j'ouvrirai un nouveau sujet (si vraiment) pour ne pas partir sur plein de problèmes au même endroit :P.

 

Merci pour votre aide, cordialement.

Lien vers le commentaire
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.


×
×
  • Créer...

Information importante

Conditions d’utilisation / Politique de confidentialité / Règles / Nous avons placé des cookies sur votre appareil pour aider à améliorer ce site. Vous pouvez choisir d’ajuster vos paramètres de cookie, sinon nous supposerons que vous êtes d’accord pour continuer.