Jump to content
×
×
  • Create New...
  • 0

Problème de connexion pour les joueurs


rom
 Share

Question

Bonjour à tous, je viens poster cette discussion dans le but de réparer mon problème en espérant avoir des réponses constructives qui puisse m'aider.

 

Version des files : 2012

Domaine (Base de données, Core, etc.) : No-Ip

Votre niveau (débutant, intermédiaire, avancé) : Avancé ++

( Ancien [GT] / [GA] / [GM] )

 

Description du problème : Tout d'abord, je tiens à vous dire qu'il y a quelques années, j'ai déjà créer plusieurs serveurs privés dont j'ai laissé tomber pour des raisons personnels, mais je me reprend en main en créant un nouveau serveur privé, mais les années sont passés et j'ai perdu un peu de connaissance et depuis tout ce temps, il y a eu de nouvelle méthode pour créer un serveur privé....Donc revenons à mon problème, je n'arrive pas à faire fonctionner le launcher pour mes potes, j'ai suivis plusieurs tutoriels, mais cela ne fonctionne toujours pas.

 

Comment reproduire le problème : En cherchant les tutoriels.

 

Recherches et tests effectué : En ayant effectué plusieurs test suivit par plusieurs tutoriels, mes potes me disent qu'ils ont toujours erreur de la connexion... Donc soit j'ai pris la mauvaise carte réseau, soit ça doit être une mauvaise manipulation. Je vais vous partager ci-dessous, mes recherches et mes tests effectués ainsi que les capture d'écran.

 

Résultat des recherches et tests : Pour commencer, j'ai créé ce serveur aujourd'hui en début d'après-midi, donc vu que 2 potes veulent bien m'aider à avancer dans mon projet, je voulais qu'ils puissent rejoindre le serveur, mais ils m'ont dit qu'ils ne pouvaient pas se connecter, donc j'ai chercher des tutoriels :

 

- https://funky-emu.net/topic/12719-probleme-modifie-la-cle-pong/&highlight=cl%C3%A9+pong (La clé pong : Cette manipulation ma permise de voir que ce n'était pas le problème)

 

Ensuite j'ai essayé de chercher d'autres tutoriels qui expliquer souvent le problème mais pour des serveurs privés hamachi, mais j'ai suivis le tutoriel basique :

 

- https://funky-emu.net/topic/53-résolu-problème-de-mise-en-ligne/91

 

J'ai bien suivis les étapes de No-Ip comme vous pouvez le voir ci-dessous :

 

375344fdsf.jpg

 

Et voici le serverinfo.py :

 

695757fsa.jpg

 

 

Message d'erreur, capture d'écran : Erreur de la connexion pour les joueurs, Voici un screen :

 

967369fga.jpg

 

Donc j'attendrai de votre part, votre aide si vous savez la réponse à mon problème avec des réponses constructives et non des réponses inutiles comme "Je ne sais pas".

 

Sur ceux je vous laisse et vous souhaite une bonne soirée, je ne serai pas disponible ce soir à partir de 19H00, mais à partir de demain matin, je serai disponible toute la journée.

 

Cordialement Niamor.

 

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le règlement des demandes d'aides.

Link to comment
Share on other sites

  • Answers 43
  • Created
  • Last Reply

Top Posters For This Question

Recommended Posts

  • 0
  • Retraité

Pour ton client à toi, il ne faut pas mettre l'ip NoIP, mais l'ip qui commence par 192. Et pour les autres, il faut leurs donner un client avec l'ip no-ip.

 

Et si ça ne fonctionne pas, montre nous un screen de VirtualPC.

Link to comment
Share on other sites

  • 0

Je le sais très bien, j'arrive à me connecter moi, mais je parle pour les autres joueurs dans cette discussion. Et comme vous pouvez le voir dans le screen j'ai bien mis l'ip de no-ip pour le launcher des joueurs.

 

 

Voici un screen de VPC :

 

75073626a.jpg

 

Tout est normal.

Link to comment
Share on other sites

  • 0

Réponse pour Elea :

 

Donc sa viendrait de la carte réseau ? Bref je te montre un screen de toutes mes cartes réseaux. J'ai pris celle qui est jaune fluo.

 

344954494.jpg

 

Je ne sais plus si il fallait prendre "Realtek PCIe GBE Family Controller"

 

Car avec cette carte il me mette à chaque seconde des phrases "dhcpdiscover on de0 to 255.255.255.255 port 67" ensuite dès que le serveur est finit il me mette des "connexion refused" donc j'ai pris l'autre carte "802. 11n Wireless LAN Card" et sa marchait pour moi, donc je ne sais pas si c'est la carte ou un autre soucis. Car j'arrive à me connecter avec cette carte donc je vois pas pourquoi ce ne serai pas la bonne...

 

Réponse pour phil45 :

 

C'est moi qui gère les launchers pour mes potes, donc tout est correct, je leur passe metin2client.exe car de un, c'est celui là qu'il faut prendre et de deux, j'ai aussi modifié la clé pong du launcher ainsi que le fichier game se trouvant dans le dossier de metin2 dans Winscp.

Donc ce n'est dans aucun cas le launcher.

Car mon fichier serverinfo.py est pour moi correct...

Link to comment
Share on other sites

  • 0

Bonjour ;holà !! mon grand tu monte un peut trop sur tes grand chevaux la !!

Tu demande de l’aide , l’on te répond .

Reste un peut courtois, tu as un serveur en no-ip et non en dédier donc ton lancer pour les joueurs ne te sert a rien pour tes joueurs .

Pour tes joueurs il te faut absolument celui de danger pour un no-ip afin qu’ils puisent ce connecter.

Comme je te l’est dit plus haut et comme le certifie Kijaru

Après si tu veux garder ton lancer ouvre un dédier .

Link to comment
Share on other sites

  • 0

Réponse à Kijaru :

 

Merci pour l'info mais il a toujours erreur de la connexion lorsqu'il lance le launcher...

 

Réponse à phil45 :

 

Je ne vois pas d'où je te parle mal, je répond juste à ce que tu a dit...

Et comme je l'ai dis à Kiraju, même avec le launcher by danger, il y a aussi erreur de la connexion.

Link to comment
Share on other sites

  • 0
  • Developer

L'erreur lors de la connexion vient de:

- Mauvaise configuration de l'interface réseau,

- Oubli de modifier la clé pong (celui-ci, on peut l'écarter car si j'ai bien lu, tu l'as déjà modifiée)

- Mauvais launcher (si je comprends bien ça ne marche pas non plus)

et pour finir, ton IP est peut-être mal redirigée sur ton adresse hôte (Host).

 

Ce problème m'est déjà arrivé et il y a des chances qu'un pare-feu ou anti-virus bloque l'accès

à cette adresse IP, ou alors ton routeur utilise lui-même un pare-feu, à vérifier.

Et juste au passage, as-tu bien ouvert ton port 11002 en TCP et UDP ?

 

@phil45: Merci d'éviter ce genre de remarques ("mon grand tu monte un peut trop sur tes grand chevaux la !!")

s'il y a quelqu'un qui doit s'occuper du comportement des membres c'est bien nous les modérateurs,

en y ajoutant le fait qu'il n'a parlé mal à personne. Merci de ta compréhension.

Link to comment
Share on other sites

  • 0

Bonjour à toi Sparkk,

 

Bon pour mon problème,

 

 

- Mauvaise configuration de l'interface réseau,

 

=> Je suis en wi-fi et j'ai la bonne carte réseau.

 

 

- Oubli de modifier la clé pong (celui-ci, on peut l'écarter car si j'ai bien lu, tu l'as déjà modifiée)

 

=> La clé pong permet d'ouvrir le launcher quand il y a des bugs, mais en aucun cas il sert pour la connexion,enfin... pour régler le problème (erreur de connexion).

Donc j'ai remis le game normal, vu que j'ai le launcher "by danger" pour les joueurs et que je ne peux pas modifier la clé pong sur le launcher "by danger" j'ai remis le game normal ainsi que les launchers normal. Et cela fonctionne pour moi, donc ce n'est pas sa le problème.

 

- Mauvais launcher (si je comprends bien ça ne marche pas non plus)

 

=> Pour le launcher, c'est bon j'ai les bons...Mais le problème c'est que ça ne marche toujours pas...

Mais les launchers s'ouvrent bien en tout cas, juste le problème pour les joueurs "erreur de la connexion"

 

- Et pour finir, ton IP est peut-être mal redirigée sur ton adresse hôte (Host).

 

=> L'IP est bien redirigé, les ports bien mis etc...

 

- Il y a des chances qu'un pare-feu ou anti-virus bloque l'accès

à cette adresse IP, ou alors ton routeur utilise lui-même un pare-feu, à vérifier.

 

=> Pour le pare-feu du routeur, il est correct mais ce qui m'inquiète c'est le pare-feu de mon ordinateur qui ne fonctionne plus et je ne sais pas si c'est la cause qui fait que ça bloque ou non l’accès.

 

-> Screen de mon pare-feu d'ordinateur :

 

521390fzt.jpg

 

Pour l'anti-virus, je ne pense pas que ce soit le soucis, mais pour vérifier, je ne sais pas comment faire pour regarder ce que mon anti-virus bloque ou pas..

 

- Et juste au passage, as-tu bien ouvert ton port 11002 en TCP et UDP ?

 

=> Oui tout mes ports sont bien ouverts.

Link to comment
Share on other sites

  • 0

Je l'ai mise en 192.168.1.100 mais l'adresse se transforme en 192.168.1.15.

 

Puis c'est normal que l'IP se transforme en 192.168.1.15 car c'est un No-IP

Link to comment
Share on other sites

  • 0
  • Developer
Cela commence à devenir urgent :S Donc si vous pourriez essayer de m'aider ce serait sympa. Bonne soirée à vous.

 

Comme je te l'ai dit, ça vient de la configuration de l'interface réseau, je n'ai pas dit que tu avais choisi la mauvaise carte,

tu aurais du mieux lire ce que j'avais écrit ^^. Enfin bref, si l'ip dans le ifconfig revient à 192.168.1.15 c'est que c'est bon

tu as juste à ouvrir les ports sur cette adresse, et le tour est joué. Ensuite la clé pong ne se modifie pas directement

sur le launcher mais sur l'exécutable du jeu. Mais l'erreur vient de la configuration réseau, et pas du client.

Link to comment
Share on other sites

  • 0

Bonjour Sparkk,

 

Ma carte réseau est bonne car j'arrive à me connecter et mon ipconfig revient à 192.168.1.15.

Donc pour moi l'interface réseau fonctionne..Ah moins que je ne comprenne pas le sens d'interface réseau...

Vous parlez bien de la carte et toutes les modifications à faire en parlant d'interface réseau ?

 

Et pour les ports, ils sont tous ouvert.

 

Voici un screen :

 

2115167349.jpg

Link to comment
Share on other sites

  • 0

Bonjour,

 

le .com redevient à chaque fois .home.

 

J'ai refais un SP etc... je vous dis si aujourd'hui mon problème est réglé ou non.

 

 

PS : nan, le problème n'est toujours pas réglé.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



  • Flux d'Activité

    1. 30

      AresiaCMS

    2. 30

      AresiaCMS

    3. 30

      AresiaCMS

    4. 66

      Decay 2.51

    5. 0

      PACK Dofus Arcenciel

    6. 0

      Partage Ornament L'attaque des Titans

  • Recently Browsing

    • No registered users viewing this page.

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.