Jump to content
  • 0
Sign in to follow this  
Proxymo

en cours Acces SQL (Dédier)

Question

Bonjour,

 

Voici mon problème :

 

Je n'ai plus aucun acces a ma base de donnée SQL (dédier).

 

On dirais que qu'un a supprimer toutes les connections.

 

J'ai encore accès a WinSCP, et j'aimerais savoir comment recrée mes acces.

 

Merci

Cordialement Proxymo

Share this post


Link to post

6 answers to this question

Recommended Posts

  • 0

Quelle manipulation a été faite pour que ça marche plus ? Au pire déjà vérifie sur mysql est démarré, un petit :

 

/usr/local/etc/rc.d/mysql-server restart

 

 

Sinon ça m'est jamais arrivé, si tu veux créer un identifiant me semble l'avoir déjà vu sur le forum, la fonction recherche est ton amie.

Share this post


Link to post
  • 0

Si le jeu toune encore je te conseil de le couper avant mysql.

 

Comme l'a dit Takron t'as touché à quelque chose? Modifié l'utilisateur qui te sers en accès distant? Bloqué le port externe qui te sers à accéder à ta base SQL?

 

Pour créer un identifiant en ssh faut que tu passe par des requêtes SQL. Je l'ai pas en tête mais de très bons sites en dehors de FE disent comment procéder si jamais tu trouves pas.

Share this post


Link to post
  • 0

Grant all on *.* to 'user'@'%' identified by 'mot de passe' with grant options;

 

je crois que c'est ca mais j'suis pas sur a 100%

Share this post


Link to post
  • 0

Dans putty tu tape :

 

mysql -u root -p(entré)

(la il demande ton mdp tape entrer directement si sa fonctionne pas tu refait la manipe du dessus et tu va chercher le mdp ce trouvant sur le ftp de ton serveur dans root mysql_history)

 

dedans tu trouveras un truck du genre

UPDATE user SET password=password("tonmotdepass") WHERE user="root";

(tonmondepasse tu le copie/colle dans putty

 

la tu as passer l'étape de ton mot de passe alors nous allons appliqué l'ajout d'user :

 

[glow=red]mysql>[/glow] GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED BY 'Entrez_ici_votre_passe' WITH GRANT OPTION;

 

Puis nous allons créer l’utilisateur des files metin2:

[glow=red]mysql>[/glow] GRANT ALL PRIVILEGES ON *.* TO 'mt2'@'localhost' IDENTIFIED BY '[email protected]#' WITH GRANT OPTION;

[glow=red]mysql>[/glow] flush privileges;

[glow=red]mysql>[/glow] exit

 

[glow=red]texte comme sa[/glow] = a ne pas noté.

Share this post


Link to post
  • 0

Si votre problème est résolu, merci de mettre la balise résolue.

 

Si votre problème n'est pas résolu et que vous attendez une réponse, donnez un signe de vie.

 

Cordialement

Elea

Share this post


Link to post
  • 0

Bonsoir,

 

Le sujet contient la balise [glow=#800000][Résolu][/glow] ou reste sans réponse, de ce fait il a été déplacé dans la section "Résolu ou sans réponse".

 

Cordialement.

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.