• 0
Sign in to follow this  
[HSGA]Kiza

en cours Problème de dédier

Question

[Message d'introduction]

 

Version des files : 2012

Dédier chez OVH

 

 

Description du problème :J'ai chercher des gens qui on eu le même problème tous on réussi a le résoudre mais sans trop dire comment Voici le message que mon dédier m'envoi quand je lance le ch 1

 

 

Message d'erreur, capture d'écran :

'root'@'ks3295121.kimsufi.com' (using password: YES)

failed, retrying in 5 secondsconnect: Connection refused

connect: Connection refused

mysql_real_connect: Access denied for user

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le règlement des demandes d'aides.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Le connexion refused intervient quand la mémoire RAM est insuffisante ou pour d'"autres raison mais c'est la principale raison.

Le reste c'est une erreur de permission. Pour que ton dédié soit accessible il faut d'abord dire que l'utilisateur "root" à tout les droits.

Tu va dans VPC et tu tapes:

 

mysql -u root -p

Quand il te demande le mot de passe tu fais "enter".

 

Ensuite tu tapes les commandes suivantes en fonction de ce que tu veux :

 

Pour ton web ça devrait être ceci:

mysql> GRANT ALL PRIVILEGES ON *.* TO 'root'@'ks3295121.kimsufi.com' IDENTIFIED BY 'MOT DE PASSE' WITH GRANT OPTION;

 

Pour créer un nouvel utilisateur:

mysql> GRANT ALL PRIVILEGES ON *.* TO 'PSEUDO'@'localhost' IDENTIFIED BY 'MOT DE PASSE' WITH GRANT OPTION;

 

Ensuite tu as ceci au cas ou pour réparer la même erreur sur les files 2012, l'user [email protected] est l'utilisateur accèdant aux files logiquement mais ici dans les files 2012 faut mettre [email protected] avec en mdp = epv4minq, ça donne ça:

mysql> GRANT ALL PRIVILEGES ON *.* TO 'metin2'@'localhost' IDENTIFIED BY 'epv4minq' WITH GRANT OPTION;

 

Ensuite tu tapes

Flush privileges;

pour confirmer les changements puis

quit

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this