Jump to content
×
×
  • Create New...
  • 0

Problème lancement startRealm


LiightXx
 Share

Question

[Message d'introduction]

Bonjour à tous! Je me permets de poster car j'ai grand besoin de votre aide! Suite au tuto de Nicky31 sur la construction d'un serveur sous ancestra remake rev54 je n'arrive pas à lancer le serveur.

Émulateur : ancestra remake

Domaine (Base de données, Core, etc.) : navicat lite

Votre niveau (débutant, intermédiaire, avancé) : débutant sur cette rev

 

Description du problème : Les deux consoles se lancent à présent, mais il m'est impossible de créer un personnage car ça me met connexion interrompue

Résultat des recherches et tests : j'ai vérifié la map start+ cell id elle est bonne, le port est bien 5555,...

Message d'erreur, capture d'écran : connexion interrompue

 

Ma config Realm

 

# Fichier de configuration du serveur de connexion d'Ancestra_Remake

 

# AR - REALM

 

# Port du serveur

REALM_PORT = 444

REALM_COM_PORT = 443

 

# Version 1.29.1

CLIENT_VERSION = 1.29.1

REALM_IGNORE_VERSION = false

 

# Base de donnée

REALM_DB_HOST = 127.0.0.1

REALM_DB_USER = root

REALM_DB_PASSWORD =

REALM_DB_NAME = ancestra_realm

REALM_DB_COMMIT = 3000

 

# DEBUG (DEBUG = See on console)

REALM_DEBUG = true

 

# Abonnement

USE_SUBSCRIBE = false

 

 

Ma config game

# Fichier de configuration du serveur de jeu d'Ancestra_Remake

 

# AR - REALM

 

# IP du serveur

REALM_IP = 127.0.0.1

 

#Configuration de la base de donnée du serveur de connexion

REALM_DB_HOST = 127.0.0.1

REALM_DB_USER = root

REALM_DB_PASS =

REALM_DB_NAME = ancestra_realm

 

# AR - GAME

 

# LOG/DEBUG

DEBUG = true

LOG = false

 

# IP du serveur

USE_IP = true

HOST_IP = 127.0.0.1

LOCALIP_LOOPBACK = true

 

# Clef d'identification

AUTH_KEY = server1

 

# Port du serveur

GAME_PORT = 5555

COM_PORT = 443

 

# Configuration générale

MOTD =Bienvenue sur le serveur Semi-Ankalike d'Axeryon

MOTD_COLOR = 173ff

# Player Limite :

PLAYER_LIMIT = 100

LOAD_ACTION_DELAY = 10

SAVE_TIME = 30

 

# Configuration de la base de donnée

DB_HOST = 127.0.0.1

DB_USER = root

DB_PASS =

DB_NAME = ancestra_game

 

# Rates

XP_PVP = 1

XP_METIER = 5

XP_PVM = 3

DROP = 3

KAMAS = 3

HONOR = 3

 

# Configuration du GamePlay

ALLOW_MULTI_ACCOUNT = true

MAX_PERSO_PAR_COMPTE = 8

USE_MOBS = true

USE_CUSTOM_START = true

START_MAP = 10298

START_CELL = 314

START_LEVEL = 1

START_KAMAS = 0

ZAAP = true

LVL_PVP = 10

ALLOW_MULE_PVP = false

AURA_SYSTEM = true

MAX_IDLE_TIME = 30

NOT_IN_HDV = 4820

# Abonnement

USE_SUBSCRIBE = false

 

# Arenes

ARENA_MAP = 10134,10132,10131,10133,10137,10135,10136,10138

ARENA_TIMER = 10

 

Et enfin ma config.xml

 

 

Voila voila, pouvez-vous m'aider ?

Merci d'avance et bonne journée à tous!

 

LiightXx

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le règlement des demandes d'aides.

Que fait un hibou dans on le met dans l'eau chaude ?
Et ben il bout...

Link to comment
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Vérifie que ta configuration se nomme bien "Realm_Config.txt".

 

Si c'est le cas, regarde sur les dernières lignes, et remplace ajoute ce qui est en gras :

 

# DEBUG (DEBUG = See on console)

REALM_DEBUG = true

 

# Timer SendManager

REALM_TIME_DATA = 50

 

# Abonnement

USE_SUBSCRIBE = false

 

Je pense que ça doit être ça, voilou, bonne chance.

Link to comment
Share on other sites

  • 0

Merci de ta réponse, mais non ce n'est pas ça, j'ai testé sur la config Game_Config et sur Realm_config mais non ... En résumé quand je le StartRealm du dossier realm ça me met

"11:12:13: SQL : Unknown database 'ancestra'

11:12:13: SQL : Connexion failed"

et quand je lance le StartReal de la game ça m'affiche toujours :

"fichier de configuration non existant ou illisible."

Que fait un hibou dans on le met dans l'eau chaude ?
Et ben il bout...

Link to comment
Share on other sites

  • 0

ca me met sql no database selected + une dizaine de ligne at.com.mysql.sql.... dans le realm! Mais dans la game rien du tout, en attente de conn.

Que fait un hibou dans on le met dans l'eau chaude ?
Et ben il bout...

Link to comment
Share on other sites

  • 0
  • Retraité

Peut-on avoir un screen du realm afin de pouvoir visualiser la totalité de l'erreur ?

(Merci d'arrêter de me mp pour me demander de répondre au topic, je vois quand il y a une réponse mais je n'ai pas toujours le temps d'y répondre)

Link to comment
Share on other sites

  • 0

Voilà, résolu! Un énorme merci à Nicky31. C'était un 'simple' problème de ports ainsi qu'une erreur dans l'installation de la BDD !

Pour la forme je vous mets les deux nouvelles config.

Game:

# Fichier de configuration du serveur de jeu

 

d'Ancestra_Remake

 

# AR - REALM

 

# IP du serveur

REALM_IP = IPHAMACHI

 

#Configuration de la base de donnée du serveur de connexion

REALM_DB_HOST = 127.0.0.1

REALM_DB_USER = root

REALM_DB_PASS =

REALM_DB_NAME = ancestra_realm

 

# AR - GAME

 

# LOG/DEBUG

DEBUG = true

LOG = false

 

# IP du serveur

USE_IP = true

HOST_IP = 127.0.0.1

LOCALIP_LOOPBACK = true

 

# Clef d'identification

AUTH_KEY = server1

 

# Port du serveur

GAME_PORT = 443

COM_PORT = 489

 

# Configuration générale

MOTD =Bienvenue sur le serveur Semi-Ankalike

 

d'Axeryon

MOTD_COLOR = 173ff

# Player Limite :

PLAYER_LIMIT = 100

LOAD_ACTION_DELAY = 10

SAVE_TIME = 30

 

# Configuration de la base de donnée

DB_HOST = 127.0.0.1

DB_USER = root

DB_PASS =

DB_NAME = ancestra_game

 

# Rates

XP_PVP = 1

XP_METIER = 5

XP_PVM = 3

DROP = 3

KAMAS = 3

HONOR = 3

 

# Configuration du GamePlay

ALLOW_MULTI_ACCOUNT = true

MAX_PERSO_PAR_COMPTE = 8

USE_MOBS = true

USE_CUSTOM_START = true

START_MAP = 10298

START_CELL = 314

START_LEVEL = 1

START_KAMAS = 0

ZAAP = true

LVL_PVP = 10

ALLOW_MULE_PVP = false

AURA_SYSTEM = true

MAX_IDLE_TIME = 30

NOT_IN_HDV = 4820

# Abonnement

USE_SUBSCRIBE = false

 

# Arenes

ARENA_MAP = 10134,10132,10131,10133,10137,10135,10136,10138

ARENA_TIMER = 10

 

Realm:

 

# Fichier de configuration du serveur de connexion d'Ancestra_Remake

 

# AR - REALM

 

# Port du serveur

REALM_PORT = 444

REALM_COM_PORT = 489

 

# Version 1.29.1

CLIENT_VERSION = 1.29.1

REALM_IGNORE_VERSION = false

 

# Base de donnée

REALM_DB_HOST = 127.0.0.1

REALM_DB_USER = root

REALM_DB_PASSWORD =

REALM_DB_NAME = ancestra_realm

REALM_DB_COMMIT = 3000

 

# DEBUG (DEBUG = See on console)

REALM_DEBUG = true

 

# Abonnement

USE_SUBSCRIBE = false

 

 

Voilà j'espère que ça aidera ceux qui ont autant galéré que moi sur cette rev 54 !

Que fait un hibou dans on le met dans l'eau chaude ?
Et ben il bout...

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.