Aller au contenu

Nouveau membre ?! Pense à te présenter pour accéder au contenu du forum !

New member ?! Introduce yourself to get access to the forum !

  • Compteur de contenus

    158
  • Inscription

  • Dernière visite

  • Points

    0 [ Donner ]

Réputation sur la communauté

8 Neutre

À propos de Tituc

  • Rang
    Créateur de Hisocom
  • Date de naissance 04/01/1997

Visiteurs récents du profil

Le bloc de visiteurs récents est désactivé et il n’est pas visible pour les autres utilisateurs.

  1. Je ne pense pas que Mono soit la meilleure des solutions pour un émulateur x) Pour l'instant je ne fais qu'observer, les sources du Github et celles de Stump ont l'air de sortir tout droit d'un décompilateur. C'est hallucinant le nombre de fichiers qu'il y a. Et c'est encore plus hallucinant de voir que l'émulation 2.0 est complètement fermée sur les sources, même 5 ans après la sortie de cette version. J'ai quand même trouvé deux sources : [Contenu Masqué] et [Contenu Masqué] tous développés en C# ;( Je n'ai pas pu y plonger mon nez dedans pour le moment, mais ça ne vas pas trop tarder, j'espère que je pourrais comprendre le fonctionnement de Dofus 2 J'ai également pu constater que les versions de Dofus sur les serveurs privés s'arrêtent toutes à la 2.10. Sûrement dû à une mise à jour de sécurité pas encore contournée (signature de l'host dans la config.xml je suppose). Si je commence un développement quelconque, je n'hésiterais pas à te demander de l'aide ^^
  2. Merci pour vos réponses. J'ai vu qu'il y avait des sources partagées pour Stump, je vais m'y plonger un peu dessus pour voir un peu. Ça serait dommage de ne pas pouvoir faire un émulateur Java pour la version 2 Je cherche surtout un moyen de rendre compatible un émulateur sous linux, et le java me semble la solution la plus appropriée. Non parce que faire exécuter du .NET sous linux, ça doit pas être joli à voir.
  3. Coucou Je ne pense pas qu'il y ait d'émulateurs 2.X sur Funky-Emulation. Cependant, j'aimerais bien me lancer là dedans Ma question est la suivante : Existe-t-il un émulateur 2.X en JAVA et open-source ? (dans le même style qu'Ancestra) Si il n'y en a pas, pouvez-vous me conseiller un petit quelque chose pour connaître les paquets de 2.X ? ^^ Est-ce le même principe que Dofus 1.29 avec des paquets changés ? Ou le système est complètement à revoir ? Idem pour les SWF, est-ce qu'il faut mettre en place un système comparable (langs et tous les SWF) ? Voilà ça m’intéresse vraiment, j'espère avoir été le plus clair possible dans ma demande
  4. Coucou bonhomme En général, ce genre d’erreur signifie qu'il manque quelques "constantes" dans un des fichiers SWF, il devrait s'agir ici de lang_fr_XXX.swf. Il suffit simplement de modifier ce fichier, et d'ajouter les lignes manquantes, par exemple : AUTOMATIC_BOOST = "Ajout de caractéristiques"; PUT_QUANTITY_BOOST = "Insérer une quantité pour augmenter vos caractéristiques"; Ensuite il suffit d'enregistrer le tout, on met sur le dossier des langs en ligne, puis on vide le cache. Si les phrases semblent trop longues ou si elles ne correspondent pas à ce que tu désires, il suffit de les changer tout simplement et de refaire toutes les étapes (mettre en ligne, vider cache...). Voilà j'espère ne pas m'être trompé ^^
  5. Bah.. Il suffirait simplement d'ouvrir le port 5555 dans ce cas, il ne faut surtout pas prendre un port déjà utilisé par un autre service. (Pour ouvrir le port, il y a plein de tutoriels à disposition sur internet) Oui car tu as mis ton adresse locale sur no-ip. Or, il faudrait que tu mettes l'adresse IP fournie par ton opérateur (adresse IP qui doit être fixe, sinon ça va foirer au prochain redémarrage). Cette adresse peut être obtenue ici : [Contenu Masqué]
  6. Hu, le port du game ne doit surtout pas être 3306, tout mais pas ça :c, le port 3306 est surtout réservée pour le service MySQL. Donc pour le port game, il serait préférable de laisser celui que tu nous avais montrer au tout début. Ta configuration de Dofus (xml) n'est pas du tout comme celle de ton serveur. Le port utilisé dans la configuration XML doit être le même port que celui que tu as mis pour REALM_PORT. Pour le "ephesia-games.com", je pense pas que cette adresse soit valide, il faudrait mettre le HOST_IP de la configuration du Game à la place. Et donc mettre ton adresse no-ip.
  7. Petit soucis, le port de jeu est indiqué comme étant 3306 sur la capture d'écran, il y a quelque chose que tu aurais oublié de montrer sur la configuration ?
  8. On a tendance à l'oublier mais dans certains émulateurs (Ancestra Remake par exemple), il y a également des éléments à remplir dans la base de donnée. Toujours dans l'exemple d'Ancestra Remake, il y a une table nommée "gameservers" qui doit être remplie correctement. Sinon je pense que les autres joueurs auront du mal à se connecter à ton serveur. "192.168.1.105" est une adresse locale non ?
  9. Salut salut ! Avant de réclamer une aide, il serait tout d'abord préférable que tu lises le sujet "A lire avant de poster". Ainsi nous aurions eu plus d'informations pour pouvoir t'aider ^^. Je suis prêt à parier que c'est un simple problème de ports. Peux-tu nous partager la config ? Peux-tu nous montrer un message d'erreur (si il y en a un) ? On ne connait également pas l'émulateur que tu utilises.. Tu peux également chercher dans les sujets résolus, je pense que cela peut t'aider (si ce n'est pas déjà fait).
  10. Yups, il semblerait que le sujet existe déjà dans cette section, il vaudrait mieux supprimer le sujet déplacé ^^.
  11. À ma connaissance, il n'existe pas de révision 58. Les sources sont toujours ici : [Contenu Masqué] (rev54)
  12. Et ce site étant maintenant indisponible, il est impossible de sauvegarder ses cartes..
  13. Effectivement, mais étant sur DWE je n'avais pas cette fonction. Merci pour cette solution.
  14. Coucou, Faisant confiance à de nombreux éditeurs de cartes, je me suis lancé à faire une zone "forêt" d'une centaine de cartes. C'est en la terminant et en la testant en jeu que je me suis rapidement rendu compte d'un soucis sur l’interactivité des objets (arbres, puits, zaaps, etc..). Ce problème concerne bien évidemment tous les émulateurs. Voici donc le soucis : Lorsque l'on souhaite mettre un objet interactif, il faut bien évidemment mettre l'objet en interactif : tous les éditeurs ont cette option. En revanche, certains développeurs ont dû oubliés que pour poser un objet interactif, il faut que la case ait un mode spécial pour les objets interactifs. Ce mode spécial consiste à empêcher le joueur de pouvoir traverser un objet interactif tout en pouvant l'utiliser correctement. Actuellement : En mettant un objet interactif avec une case "marchable", on peut le traverser. En mettant un objet interactif avec une case "non-marchable", il devient inutilisable. Pour conclure ce sujet, je pense qu'aucun éditeur de carte n'est capable de gérer les objets interactifs correctement. Si une personne à quelque chose à proposer pour m'aider, et pour aider les x personnes qui doivent-êtres dans mon cas, n'hésitez pas ^^ !
  15. Pour quelle raison DWE devrait contacter mapeditor.npdev.eu a chaque sauvegarde de carte ? Petit soucis très gênant en cas de coupure internet (merci Free) .
×

Information importante

By using this site, you agree to our Conditions d’utilisation.